Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как в БП 3 добавить внешнюю обработку, взятую из этой же конфы?

Как в БП 3 добавить внешнюю обработку, взятую из этой же конфы?
Я
   lukinskiy
 
13.10.20 - 21:55
В БП 3.0 хочется повесить стандартную обработку "УниверсальныйОбменДаннымиXML" куда-нибудь поближе, чтоб не искать ее среди всех обработок.
При этом интерфейс менять не хочется, чтоб обновляться на полном автомате.
Сохранил ее, как внешнюю, и попытался добавить в "Админимистрирование\Печаные формы и обработки", но не дает. Как быть?
   Ненавижу 1С
 
1 - 13.10.20 - 21:56
Переименуй
   Михаил Козлов
 
2 - 13.10.20 - 22:01
В модуле внешней обработки сведения о ней оформили?
   acht
 
3 - 13.10.20 - 23:03
(0) > Админимистрирование
Ад мини миста =)

Лучше сделай полупустую внешнюю обработку, которая будет просто открывать типовую и закрываться сама. Привяжи куда надо. Убережет от возможных изенений в типовой. Хотя ее лет 100 уже не трогали по-моему...
   yzimin
 
4 - 13.10.20 - 23:17
а тупо в избранное добавить?))
   D_E_S_131
 
5 - 14.10.20 - 00:48
"чтоб не искать ее среди всех обработок" - для кого "Избранное" делали...
   Mihasya
 
6 - 14.10.20 - 02:23
(5) типо закрепил материал (4)... )))
   lukinskiy
 
7 - 15.10.20 - 00:37
А где это "Избранное" находится? Что-то не могу найти. Бухгалтерия предприятия КОРП, редакция 3.0 (3.0.77.78)
   Mihasya
 
8 - 15.10.20 - 01:32
(7) На самой форме, около заголовка формы есть "звездочка"
   Жан Пердежон
 
9 - 15.10.20 - 02:26
(7) это часть платформы, а не конфигурации
   Dmitry8Grek
 
10 - 15.10.20 - 10:38
Функция СведенияОВнешнейОбработке() Экспорт

    ПараметрыРегистрации = Новый Структура;
    МассивНазначений = Новый Массив;
    МассивНазначений.Добавить("Документ.ПеремещениеТоваров");// куда добавлять обработку


    ПараметрыРегистрации.Вставить("Вид", "СозданиеСвязанныхОбъектов");
    ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
    ПараметрыРегистрации.Вставить("Наименование", "ИмяОбработки");
    ПараметрыРегистрации.Вставить("Версия", "1.0");
    ПараметрыРегистрации.Вставить("БезопасныйРежим", Истина);
    ПараметрыРегистрации.Вставить("Информация", "Отображение наименования обработки");

    ТаблицаКоманд = ПолучитьТаблицуКоманд();

    ДобавитьКоманду(ТаблицаКоманд,
    "ИмяОбработки",
    "ИмяОбработки",
    "ВызовКлиентскогоМетода",
    Истина);

    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);

    Возврат ПараметрыРегистрации;
КонецФункции

Функция ПолучитьТаблицуКоманд()
  Команды = Новый ТаблицаЗначений;
  Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
  Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
  Возврат Команды;
КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Истина, Модификатор = "")
  НоваяКоманда = ТаблицаКоманд.Добавить();
  НоваяКоманда.Представление = Представление;
  НоваяКоманда.Идентификатор = Идентификатор;
  НоваяКоманда.Использование = Использование;
  НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
  НоваяКоманда.Модификатор = Модификатор;
КонецПроцедуры

Вставь данный код в модуль объекта внешней обработки и сможешь ее закрепить в базе.
   lukinskiy
 
11 - 15.10.20 - 17:42
Спасибо!
   Winnie Buh
 
12 - 15.10.20 - 18:13
(11) разобрались, как добавить обработку в "Избранное"?
   lukinskiy
 
13 - 15.10.20 - 19:17
(12) Да, большое спасибо! Не знал про эту фишку, очень удобно.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.