Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Выгрузка документов по Com подключению

Выгрузка документов по Com подключению
Я
   Kitana_666
 
12.10.20 - 14:43
Всем добрый день!
Делаю выгрузку по Com подключению, выдает ошибку:
Метод объекта не обнаружен (Записать)
{ВнешняяОбработка.КОМ.Форма.Форма.Форма(118)}:            Чтение.Записать();        
{ВнешняяОбработка.КОМ.Форма.Форма.Форма(137)}:        ВыгрузитьНаСервере();    


Код  ниже:

Для Каждого Стр Из ТаблицаВыгружаемыхОбъектов Цикл
    
        Попытка
            ОбъектКВыгрузке = Стр.Объект.ПолучитьОбъект();
        Исключение
            ОбъектКВыгрузке = Неопределено;
        КонецПопытки;
        
        Если НЕ ОбъектКВыгрузке = Неопределено Тогда    
            ЗаписьXML = Новый ЗаписьXML;
            ЗаписьXML.УстановитьСтроку();
            ЗаписатьXML(ЗаписьXML, Стр.Объект.ПолучитьОбъект());
            Текст = ЗаписьXML.Закрыть();
            
            Чтение = База.NewObject("ЧтениеXML");
            Чтение.УстановитьСтроку(Текст);
        Если ВозможностьЧтенияXML(Чтение) Тогда     
            СоздаваемыйОбъект = ПрочитатьXML(Чтение);
            СоздаваемыйОбъект.Записать();

             КонецЕсли;
            
        Чтение.Записать();        
        
        
        КонецЕсли;
        
    КонецЦикла;



Буду рада любой помощи. Спасибо!
   ДенисЧ
 
1 - 12.10.20 - 14:46
Ну, значит, объект не создался...
   Kitana_666
 
2 - 12.10.20 - 14:47
(1) В отладке когда проверяю он создается
   Cthulhu
 
3 - 12.10.20 - 15:00
(2) а чему (на Чтение.Запмсать()) равно значение ТипЗнч(Чтение)?..
   ДенисЧ
 
4 - 12.10.20 - 15:07
(3) сом-объект же
   Kitana_666
 
5 - 12.10.20 - 15:14
(0)//МенеджерДокумента = База.Документы.ПлатежноеПоручение;

//База.УстановитьБезопасныйРежим(Ложь);
//База.УстановитьПривилегированныйРежим(Истина);

//Документ = МенеджерДокумента.СоздатьДокумент();  
//Документ.Дата=ТекущаяДата();

//Документ.Number =ОбъектКВыгрузке.Номер;
//Документ.Записать();



Так загружает, но это объемно

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.