Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Ожидается ключевое слово 'КонецПроцедуры' везде...

Ожидается ключевое слово 'КонецПроцедуры' везде...
Я
   Филатус55
 
12.10.20 - 13:59
&НаКлиенте
Процедура ПосчитатьНа(Команда)
    ПоказатьОповещениеПользователя(ПосчитатьНаСервере());
КонецПроцедуры


&НаСервереБезКонтекста
Функция ПосчитатьНаСервере()

КоличествоНа=0;
ВыборкаИзСправочника=Справочники.Номенклатура.Выбрать();
Пока ВыборкаИзСправочника.Следующий() Цикл
Переменная1=ВыборкаИзСправочника.Наименование;
Если ВРег(Лев(Переменная1,1))="А"
    Тогда
КоличествоНаА=КоличествоНаА+1;
Возврат(КоличествоНаА);
    
КонецЕсли
КонецЦикла
КонецФункции


&НаКлиенте
Процедура ПеренестиВПредопределеннуюГруппу(Команда)
ПеренестиВПредопределеннуюГруппуНаСервере();
КонецПроцедуры


&НаСервереБезКонтекста
Процедура ПеренестиВПредопределеннуюГруппуНаСервере()
КудаПеренести=Справочники.Номенклатура.ПрочиеТовары;
Выборка=Справочники.Номенклатура.Выбрать();
Пока Выборка.Следующий() Цикл
    Если Не Выборка.Ссылка=КудаПеренести Тогда ПолученныйОбъект=Выборка.ПолучитьОбъект();
        ПолученныйОбъект.Родитель=КудаПеренести;
        ПолученныйОбъект.Записать();

КонецЕсли;

КонецЦикла
КонецФункции
КонецПроцедуры


&НаСервере
Процедура ВыдатьСписокНаСервере()

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
|    КонтактныеЛица.Владелец

|ИЗ

|    Справочник.КонтактныеЛица КАК КонтактныеЛица
|ГДЕ
| КонтактныеЛица.Ссылка = &КЛ";

Запрос.УстановитьПараметр("КЛ", КЛ);
РезультатЗапроса = Запрос.Выполнить;
ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий()
    Цикл Сообщение=Новый СообщениеПользователю;
    Сообщение.Текст=
    
    ВыборкаДетальныеЗаписи.Наименование+":"+ ВыборкаДетальныеЗаписи.Номенклатура.ЦенаПродажи;
Сообщение.Сообщить();

КонецЦикла
КонецФункции
КонецПроцедуры


&НаКлиенте
Процедура ВыдатьСписок(Команда)
ВыдатьСписокНаСервере();
КонецПроцедуры



____________________________________________________________________________________________________________________________




{Справочник.Номенклатура.Форма.ФормаЭлемента.Форма(42,1)}: Ожидается ключевое слово 'КонецПроцедуры' ('EndProcedure')
<<?>>КонецФункции (Проверка: Сервер)
{Справочник.Номенклатура.Форма.ФормаЭлемента.Форма(72,1)}: Ожидается ключевое слово 'КонецПроцедуры' ('EndProcedure')
<<?>>КонецФункции (Проверка: Сервер)
{Справочник.Номенклатура.Форма.ФормаЭлемента.Форма(42,1)}: Ожидается ключевое слово 'КонецПроцедуры' ('EndProcedure')
<<?>>КонецФункции (Проверка: Сервер)
{Справочник.Номенклатура.Форма.ФормаЭлемента.Форма(42,1)}: Ожидается ключевое слово 'КонецПроцедуры' ('EndProcedure')
<<?>>КонецФункции (Проверка: Тонкий клиент)
{Справочник.Номенклатура.Форма.ФормаЭлемента.Форма(72,1)}: Ожидается ключевое слово 'КонецПроцедуры' ('EndProcedure')
<<?>>КонецФункции (Проверка: Тонкий клиент)
   ДенисЧ
 
1 - 12.10.20 - 14:00
"КонецЦикла
КонецФункции
КонецПроцедуры"

Это что? Сильная неуверенность в себе?
   программистище
 
2 - 12.10.20 - 14:13
не хватает
КонецМодуля
...
КонецВселенной
   Franchiser
 
3 - 12.10.20 - 14:17
Добавь КонецКлиента
   Cthulhu
 
4 - 12.10.20 - 15:01
КонуцФмльма
   Cthulhu
 
5 - 12.10.20 - 15:02
* КонецФильма //клавадура!
   Провинциальный 1сник
 
6 - 12.10.20 - 15:05
А в паскале можно было вложенные процедуры-функции делать. С соответствующей областью видимости. Иногда не хватает такого в 1с.
   ДенисЧ
 
7 - 12.10.20 - 15:06
(6) Переходи на жабаскрипт, там это недавно сделали...
   PuhUfa
 
8 - 12.10.20 - 15:07
(6) 1С еще сырая...
   УдавВПопугаях
 
9 - 12.10.20 - 15:10
(8) да, особенно восьмерка (

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.