Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Не могу ни базу загрузить ни cf файл загрузить в чистую пустую базу. Как лечить?

Не могу ни базу загрузить ни cf файл загрузить в чистую пустую базу. Как лечить?
Я
   Обработка
 
12.10.20 - 10:28
В процессе обновления информационной базы произошла критическая ошибка
по причине:
Ошибка СУБД:
Длина ключа индекса превышает максимально допустимую '_AccumRg18431_ByDims_TSSSSSNN (_Period, _Fld18419_TYPE, _Fld18419_S, _Fld18420_TYPE, _Fld18420_S, _Fld18421_TYPE, _Fld18421_S, _Fld18422_TYPE, _Fld18422_S, _Fld18423, _DimHash, _Splitter)'
по причине:
Длина ключа индекса превышает максимально допустимую '_AccumRg18431_ByDims_TSSSSSNN (_Period, _Fld18419_TYPE, _Fld18419_S, _Fld18420_TYPE, _Fld18420_S, _Fld18421_TYPE, _Fld18421_S, _Fld18422_TYPE, _Fld18422_S, _Fld18423, _DimHash, _Splitter)'

*****
База БП2 каз с доработками. объем базы 8-9 гига, выгрузка дт 1.3 гига, сф файл всего 152 мб
   Кулибин
 
1 - 12.10.20 - 10:37
В каком-то регистре слишком много проиндексированных измерений/реквизитов.
   ДенисЧ
 
2 - 12.10.20 - 10:39
Из скуля в файловую?
С таким кривым индексом не загрузишь...
   Обработка
 
3 - 12.10.20 - 12:26
Мне всего лишь надо из этой базы вытащить контрагентов и номенклатуру с ее реквизитами и залить в УТ3 каз (типа УТ11).
Если база в предприятии на каком-то релизе стабильно то могу вытащить и забить на эту ошибку?
   mikecool
 
4 - 12.10.20 - 12:28
(3) бери из источника
   Обработка
 
5 - 12.10.20 - 13:59
Как выташить из конфы что за поля и что за регистр _AccumRg18431_ByDims_TSSSSSNN ???
   RomanYS
 
6 - 12.10.20 - 14:02
(5) ПолучитьСтруктуруХраненияБазыДанных
   Обработка
 
7 - 12.10.20 - 14:44
Среди названий не нашел

Процедура КнопкаВыполнитьНажатие(Кнопка)
Таблицы = ПолучитьСтруктуруХраненияБазыДанных();
Для Каждого Таблица Из Таблицы Цикл
    ПоляТаблицы = Таблица.Поля;
    Для Каждого Поле Из ПоляТаблицы Цикл
         Если найти(Таблица.ИмяТаблицы,"РегистрНакопления") <>0 Тогда
             Сообщить(Поле.ИмяПоляХранения+" "+Таблица.ИмяТаблицы);
         КонецЕсли;
    КонецЦикла;    
    ИндексыТаблицы = Таблица.Индексы;
    Для Каждого Индекс Из ИндексыТаблицы Цикл
        // Просмотр свойств индекса.

    КонецЦикла;            
КонецЦикла;       
КонецПроцедуры
   ДенисЧ
 
8 - 12.10.20 - 14:47
И не найдёшь. При загрузке из дт имена таблиц новые создаются..
Придётся тебе шерстить все регистры и смотреть на все измерения-реквизиты, где длинная строка индексируется
   Обработка
 
9 - 12.10.20 - 14:57
(9) Спасибо.
Видим сделаю ПОД через КД2 раз уж работает 1с Предприятие на 8.3.11-ом релизе. А вот на 8.3.15-м уже база падает.
И вытащу данные. Да и положу-ка болт на все эти индексы.
   МихаилМ
 
10 - 12.10.20 - 15:16
(8) так было до  1с 8.2.14. начиная с неё имена таблиц в дт сохраняются и восстанавливаются.
   evorle145
 
11 - 13.10.20 - 09:14
(0) у меня была такая же ошибка. В одном из регистров сведений оказалось измерение со слишком большой длины строки.
   ИС-2
 
12 - 13.10.20 - 09:25
(0) можно попробовать в XML конфигурацию выгрузить

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.