Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Печатные формы

Печатные формы
Я
   н7ер
 
12.10.20 - 08:56
1) В печатную форму (СВ) Расходная накладная по складам (печатается из расходной) выводить адрес склада (в самом складе брать, выводить через запятую после наименования склада);


//{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("Ссылка", СсылкаНаОбъект.Ссылка);
    Запрос.УстановитьПараметр("СкладВТабличнойЧасти",Строка(ВыборкаСклады.Склад));
    Запрос.Текст =
        "ВЫБРАТЬ
        |    СтруктурныеЕдиницыКонтактнаяИнформация.Ссылка КАК Ссылка
        |ИЗ
        |    Справочник.СтруктурныеЕдиницы.КонтактнаяИнформация КАК СтруктурныеЕдиницыКонтактнаяИнформация
        |ГДЕ
        |    СтруктурныеЕдиницыКонтактнаяИнформация.Ссылка = &Ссылка";
      
     ОбластьМакета.Параметры.ПредставлениеСклада = ПредставлениеСклада;

    Ссылка = ДанныеОбъекта.Ссылка;
    ПоложениеСклада = Строка(ВыборкаСклады.Склад);
    
    Запрос.УстановитьПараметр("Ссылка", Ссылка);
    Запрос.УстановитьПараметр("СкладВТабличнойЧасти", ПоложениеСклада = Перечисления.ПоложениеРеквизитаНаФорме.ВТабличнойЧасти);
    //Запрос.УстановитьПараметр("СкладВТабличнойЧасти", ПоложениеСклада = Перечисления.ПоложениеРеквизитаНаФорме.ВТабличнойЧасти);
    
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        // Вставить обработку выборки ВыборкаДетальныеЗаписи
    КонецЦикла;
    
    //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
   acht
 
1 - 12.10.20 - 08:59
10000 рублей
   Ёпрст
 
2 - 12.10.20 - 09:01
(0) и?
   н7ер
 
3 - 12.10.20 - 09:07
не могу понять что с кодом не так
   Ёпрст
 
4 - 12.10.20 - 09:08
(3) что написал. то и получил.
Надо то что ?
   н7ер
 
5 - 12.10.20 - 09:12
я бы хотела понять, как надо правильно написать, чтобы из формы Склад, строчка Адрес выводилась в отчете Расходная накладная со складами
   Ёпрст
 
6 - 12.10.20 - 09:22
(5) Ну так, возьми форму готовую, и переделай текст запроса.
   Ёпрст
 
7 - 12.10.20 - 09:23
Только, непонятно, какой склад нужно будет брать, если в первой строке будет СкладВася, а в третьей СкладФедя..
   н7ер
 
8 - 12.10.20 - 09:32
я не понимаю, как это выразить
   н7ер
 
9 - 12.10.20 - 09:33
Там, получается, что склады разные и адрес у них разный
   Ёпрст
 
10 - 12.10.20 - 09:34
(8) чего выразить то ?

Выбрать первые 1 ТвойДокумент.склад.ТвойАдрес из Документ.Твой.ТабличнаяЧастьТвоя как ТвойДокумент Где ТвойДокумент.ССылка = &ССылка
   Ёпрст
 
11 - 12.10.20 - 09:37
(9)
Тогда так
Запрос = Новый Запрос ("Выбрать ТвойДокумент.склад.ТвойАдрес как Адрес из Документ.Твой.ТабличнаяЧастьТвоя как ТвойДокумент Где ТвойДокумент.ССылка = &ССылка");
Запрос.УстановитьПараметр("ССылка",ССылка);
ТекстАдреса = "";
Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий Цикл
   ТекстАдреса  = ТекстАдреса +", "+Выборка.Адрес;
КонецЦикла;
 

   н7ер
 
12 - 12.10.20 - 09:37
Спасибо, я сейчас попробую
   н7ер
 
13 - 12.10.20 - 09:58
Запрос = Новый Запрос; 
        Запрос.Текст = 
        "ВЫБРАТЬ
        |    СтруктурныеЕдиницыКонтактнаяИнформация.Ссылка КАК Ссылка
        |ИЗ
        |    Справочник.СтруктурныеЕдиницы.КонтактнаяИнформация КАК СтруктурныеЕдиницыКонтактнаяИнформация
        |ГДЕ
        |    СтруктурныеЕдиницыКонтактнаяИнформация.Ссылка = &Ссылка";        
        Ссылка = ДанныеОбъекта.Ссылка;
        Запрос.УстановитьПараметр("ССылка",ССылка);
        Если ДоставкаСервер.АдресОтправленияИзСклада() Тогда
        ПоляАдресаОтправления = ДоставкаСервер.ПоляАдресаОтправления(СтруктурныеЕдиницыКонтактнаяИнформация);
    Иначе
        ПоляАдресаОтправления = ДоставкаСервер.ПоляАдресаОтправления(Организация);
    КонецЕсли;
        Выборка = Запрос.Выполнить().Выбрать();
        Пока Выборка.Следующий Цикл
           ПредставлениеСклада  = ПредставлениеСклада +", "+Выборка.ПоляАдресаОтправления;
        КонецЦикла;
   н7ер
 
14 - 12.10.20 - 10:00
вообщем я ничего не понимаю
   н7ер
 
15 - 12.10.20 - 10:07
https://otvet.mail.ru/question/222119256              у меня по этой ссылки есть фотографии
   н7ер
 
16 - 12.10.20 - 10:30
ОбластьМакета = Макет.ПолучитьОбласть("Склад");
        ПредставлениеСклада = Строка(ВыборкаСклады.Склад);  //Не Гут

        ОбластьМакета.Параметры.ПредставлениеСклада = ПредставлениеСклада;
        
        ТабДокумент.Вывести(ОбластьМакета);
   hhhh
 
17 - 12.10.20 - 10:44
(16) вот тут у вас какая-то фигня
        Запрос.УстановитьПараметр("ССылка",ССылка);


Ссылка - это же Расходная накладная. А не какая-то там СтруктурнаяЕдиница.

Может Ссылка.Склад ?
   н7ер
 
18 - 12.10.20 - 10:46
Может
   н7ер
 
19 - 12.10.20 - 10:47
Я не могу понять, что и от куда мне взять

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.