Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

УТ 11. Web клиент. Как сделать чтобы стартовая страница была такая же как в ДО

УТ 11. Web клиент. Как сделать чтобы стартовая страница была такая же как в ДО
Я
   buketovav
 
09.10.20 - 13:52
Добрый день, Дорогие Форумчане!
УТ 11. Web клиент.
Как сделать чтобы стартовая страница была такая же как в ДО , с квадратиками, а в них задачи, календарь и тд и тп
Развернул я у себя ДО, развернул веб сервер, но не запускается в вебе ДО, нет лицензии.
   buketovav
 
1 - 09.10.20 - 14:55
Рабочее место "Текущие дела" это монитор сигналов для текущего пользователя. Это все то, на что пользователь должен обратить внимание и предпринять какие-либо действия.

"Текущие дела" представляют собой форму c двенадцатью настраиваемыми виджетами.
   buketovav
 
2 - 09.10.20 - 14:55
я так понимаю, квадратики - это виджеты
   buketovav
 
3 - 24.11.20 - 23:53
// Возвращает html представление виджета.

//
// Параметры:

//   Заголовок - Строка - html текст заголовка виджета.
//   Подвал - Строка - html текст подвала виджета.

//   ТелоВиджета - Строка - html текст тела виджета.
//   ФонаВиджета - Строка - цвет фона виджета в виде шестнадцатеричного значения.

//   ЦветРамкиТаблицы - Строка - цвет рамок таблиц в виджете, в виде шестнадцатеричного значения.
//

// Возвращаемое значение:
//   Строка - html представление виджета.

//
Функция HTMLПредставлениеВиджета(
        Заголовок = "", Подвал = "", ТелоВиджета, ФонаВиджета, ЦветРамкиТаблицы)
    
    HTMLТекст = "<html><head><meta name=""viewport"" content=""viewport-fit=cover, width=device-width"" />"
        + СтильHTML(ЦветРамкиТаблицы)
        + "<body bgcolor=" + ФонаВиджета + ">";
        
    HTMLТекст = HTMLТекст + СтрЗаменить("
    |<table class=""one"">
    |<tr><td>
    |<table class=""title"">
    |<tr>
    |<td class=""menu"">
    |</td>
    |<td class=""title"">
    |<p>    
    |" + Заголовок + "
    |</td>
    |</tr>
    |</table>    
    |</td></tr>    
    |<tr class=""height100""><td>
    |" + ТелоВиджета + "
    |</td></tr>    
    |<tr><td>    
    |<table>
    |<tr>    
    |<td width=""5"">
    |</td>    
    |<td height=""18"">
    |" + Подвал + "
    |</td>    
    |</tr>
    |</table>    
    |</td></tr>    
    |</table>    
    |</body></html>", "|","");
        
        
    
    УдалитьВредоносныйКодИзТекста(HTMLТекст); 
    
    Возврат HTMLТекст;
    
КонецФункции

// Удаляет вредоносный код html из текста.

//
// Параметры:

//   Текст - Строка - текст
//

Процедура УдалитьВредоносныйКодИзТекста(Текст) Экспорт
    
    НРегТекст = НРег(Текст);
    
    МассивСтрокБезВредоносногоТекста = Новый Массив;
    
    // Удаление скриптов

    НомерСкрипта = 1;
    ПозицияНачалаОбработки = 1;
    
    Пока Истина Цикл
        
        ПозицияНачалаОткрывающегоТегаScript = СтрНайти(НРегТекст, "<script",,, НомерСкрипта);
        ПозицияНачалаЗакрывающегоТегаScript = СтрНайти(НРегТекст, "</script",,, НомерСкрипта);
        
        Если ПозицияНачалаОткрывающегоТегаScript = 0 Или ПозицияНачалаЗакрывающегоТегаScript = 0 Тогда
            Прервать;
        КонецЕсли;
        
        ПозицияОкончанияОткрывающегоТегаScript = СтрНайти(НРегТекст, ">",, ПозицияНачалаОткрывающегоТегаScript + 1);
        ПозицияОкончанияЗакрывающегоТегаScript = СтрНайти(НРегТекст, ">",, ПозицияНачалаЗакрывающегоТегаScript + 1);
        
        Если ПозицияОкончанияОткрывающегоТегаScript = 0 Или ПозицияОкончанияЗакрывающегоТегаScript = 0 Тогда
            Прервать;
        КонецЕсли;
        
        // Добавим текст до скрипта

        ТекстДоСкрипта = Сред(Текст, ПозицияНачалаОбработки, ПозицияНачалаОткрывающегоТегаScript - ПозицияНачалаОбработки);
        МассивСтрокБезВредоносногоТекста.Добавить(ТекстДоСкрипта);
        
        ПозицияНачалаОбработки = ПозицияОкончанияЗакрывающегоТегаScript + 1;
        НомерСкрипта = НомерСкрипта + 1;
        
    КонецЦикла;
    
    Если МассивСтрокБезВредоносногоТекста.Количество() > 0 Тогда
        
        // Добавим текст после последнего скрипта

        ТекстДоСкрипта = Сред(Текст, ПозицияНачалаОбработки);
        МассивСтрокБезВредоносногоТекста.Добавить(ТекстДоСкрипта);
        
        // Сформируем итоговую строку без скрипта

        Текст = СтрСоединить(МассивСтрокБезВредоносногоТекста);
    КонецЕсли;
    
КонецПроцедуры

Список тем форума
 
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.