Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Обработка рабочий стол руководителя

Обработка рабочий стол руководителя
Я
   Блатная Зефирка
 
09.10.20 - 08:30
В модуле обработки рабочий стол руководителя прописаны следующие процедуры, которые необходимы для отбора задач по бизнес-процессу при нажатии на кнопку.
Отрабатывает почему-то неверно и выводит все задачи на исполнение и проверить.
А должны отдельно на проверить и отдельно на исполнение.
Никак не могу понять в чем дело, вроде все корректно прописано.
Буду благодарна за помощь!

&НаКлиенте
&Вместо("ОткрытьУтверждение")
Процедура ДН_ОткрытьУтверждение()
    Если ЧислоЗадачУтверждение = 0 Тогда
        Возврат;  
    КонецЕсли;
    ПараметрыФормы = Новый Структура("ИмяБизнесПроцесса, ОткрытаИзФормыРабочийСтолРуководителя", "Исполнение", Истина);  
    ОткрытьФорму("Задача.ЗадачаИсполнителя.Форма.ЗадачиМне", ПараметрыФормы, "Исполнение", ПараметрыФормы.ИмяБизнесПроцесса);
    
КонецПроцедуры

&НаКлиенте
&Вместо("ВсеЗадачи")
Процедура ДН_ВсеЗадачи()    
    Если ЧислоЗадачВсего = 0 Тогда
        Возврат;
КонецЕсли;
    ПараметрыФормы = Новый Структура ("ИмяБизнесПроцесса, ОткрытаИзФормыРабочийСтолРуководителя", "Проверить", Истина);
    ОткрытьФорму ("Задача.ЗадачаИсполнителя.Форма.ЗадачиМне", ПараметрыФормы, "Проверить", ПараметрыФормы.ИмяБизнесПроцесса);
КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.