Вход | Регистрация
 

Как сделать так, чтобы результат запроса выдавал сообщением?

Как сделать так, чтобы результат запроса выдавал сообщением?
Я
   undertale
 
09.10.20 - 07:41
Я новичок, не судите строго.
Мне нужно выбрать руководителя, затем нажать на кнопку и чтобы сообщение выдавало сколько листов оценки заполнил определенный руководитель.
Я сделал это через еще одно поле (реквизит), но меня попросили сделать так, а я никогда не пользовался функцией " Сообщить".

Помогите пожалуйста.

Вот код:
Процедура КнопкаВыполнитьНажатие(Кнопка)

КонецПроцедуры



Функция ПолучитьЛистОценки(мРуководитель)

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| КП_ОценкаСотрудника.Ссылка,
| КП_ОценкаСотрудника.Руководитель
|ИЗ
| Справочник.КП_ОценкаСотрудника КАК КП_ОценкаСотрудника
|ГДЕ
| КП_ОценкаСотрудника.Руководитель = &Руководитель";

Запрос.УстановитьПараметр("Руководитель", мРуководитель);

апапа = Запрос.Выполнить().Выгрузить();

Если апапа.Количество()=0 тогда
        Возврат ложь;
    Иначе
        возврат истина;
    КонецЕсли;
    
КонецФункции
   undertale
 
1 - 09.10.20 - 07:46
Повторяюсь, не судите строго, я только начал изучать 1с.
   ДенисЧ
 
2 - 09.10.20 - 07:50
Иначе
сообщить("" + апапа.Количество());
        возврат истина;
   undertale
 
3 - 09.10.20 - 07:55
(2) А что писать в  
Процедура КнопкаВыполнитьНажатие(Кнопка)

КонецПроцедуры
   ДенисЧ
 
4 - 09.10.20 - 08:01
Процедура КнопкаВыполнитьНажатие(Кнопка)
ПолучитьЛистОценки(мРуководитель)
КонецПроцедуры
   Kigo_Kigo
 
5 - 09.10.20 - 08:03
(2) Но мы пока не знаем, там УФ или ОФ )))))
   ДенисЧ
 
6 - 09.10.20 - 08:04
(5) А что, Сообщить() от этого как-то по-другому будет работать?
   undertale
 
7 - 09.10.20 - 08:05
(5) Обычная форма
   undertale
 
8 - 09.10.20 - 08:06
(6) Что-то не выводится сообщение
   Kigo_Kigo
 
9 - 09.10.20 - 08:06
(6) Ну в определенных вариантах клинте сервере, сильно выругается )))
(7) Тогда все нормально
   Kigo_Kigo
 
10 - 09.10.20 - 08:07
(8)
а так?
Если апапа.Количество()=0 тогда
сообщить("В выборке ноль");
        Возврат ложь;
    Иначе
       сообщить("" + апапа.Количество());
        возврат истина;
    КонецЕсли;
   ДенисЧ
 
11 - 09.10.20 - 08:09
(9) Ни разу. Даже во внешнем соединении не. Не выведт, но не выругается
   Kigo_Kigo
 
12 - 09.10.20 - 08:09
или так
Сообщить(" "+ апапа.Количество());
Если апапа.Количество()=0 тогда
        Возврат ложь;
    Иначе
        возврат истина;
    КонецЕсли;
   Kigo_Kigo
 
13 - 09.10.20 - 08:10
(11) Выругается, что не обнаружено "Сообщить", по этому в типовых используется СообщениеПользователю()
   undertale
 
14 - 09.10.20 - 08:11
(10) Работает, спасибо огромное
   Kigo_Kigo
 
15 - 09.10.20 - 08:11
(11) Сообщить()
Доступность:
Тонкий клиент, веб-клиент, мобильный клиент, сервер, толстый клиент, внешнее соединение, мобильное приложение (клиент), мобильное приложение (сервер).
   Kigo_Kigo
 
16 - 09.10.20 - 08:12
(15) +15, то есть на сервере выругается
   ДенисЧ
 
17 - 09.10.20 - 08:14
(16) "Сообщить()
Доступность: ... сервер

Чего бы ему ругаться? Ты вообще читаешь, что пишешь? )))
   Kigo_Kigo
 
18 - 09.10.20 - 08:17
(17) А ну да, значит где то я протупил/пропустил, но точно помню до каких то версий платформы ругалось, ну да ладно, эт уже не важно
   ДенисЧ
 
19 - 09.10.20 - 08:19
(18) В 8.2 точно работала
   Kigo_Kigo
 
20 - 09.10.20 - 08:23
(19) Где то на стыке ОФ  и УФ, в УФ не работала , по моему на сервере
   Василий Алибабаевич
 
21 - 09.10.20 - 08:25
Сообщить() работала всегда.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.