Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Подключение внешней компоненты для ТСД

Подключение внешней компоненты для ТСД
Я
   Калыван
 
08.10.20 - 18:09
Доброго времени суток.
Пытаюсь подключить внешнюю компоненту для ТСД UROVO i6200A.

Процедуры находятся в общем клиентском модуле:
[CODE]
Функция ИнициализироватьВК_RSDriver () Экспорт
    //#Если МобильноеПриложениеКлиент ИЛИ МобильныйКлиент Тогда
        Оповещение = Новый ОписаниеОповещения("ПодключитьВК_RSDriver", ЭтотОбъект);
        НачатьУстановкуВнешнейКомпоненты(Оповещение, "ОбщийМакет.RSDriver");
    //#КонецЕсли
  Возврат Ложь;
КонецФункции
[/CODE]
[CODE]
Процедура ПодключитьВК_RSDriver(ДополнительныеПараметры)Экспорт
    Подключено = Ложь;
    Оповещение = Новый ОписаниеОповещения("НастройкаВК_RSDriver", ЭтотОбъект);
    НачатьПодключениеВнешнейКомпоненты(Оповещение, "ОбщийМакет.RSDriver","RSDriver", ТипВнешнейКомпоненты.Native);
КонецПроцедуры
[/CODE]
[CODE]
Процедура НастройкаВК_RSDriver(Подключено, ДополнительныеПараметры)Экспорт
    Если Подключено Тогда
        Попытка
            глВКRSDriver = Новый ("AddIn.RSDriver.RSDriver");
            
            ИмяДрайвера         = "";
            ОписаниеДрайвера    = "";
            ДоступныеУстройства = "";
            Версия = 0;
            ТипВК  = "";
            Загружен = Ложь;
            Адрес = "";
            
        //глВКRSDriver.ПолучитьОписание(ИмяДрайвера,ОписаниеДрайвера,ДоступныеУстройства,Версия,ТипВК,Загружен,Адрес);
        Исключение
            Сообщить(ОписаниеОшибки());
            Сообщить("Ошибка создания класса RSDriver");
        Конецпопытки;
    Иначе
        Сообщить("Компонента RSDriver не загружена");
    КонецЕсли;
КонецПроцедуры
[/CODE]

Так же пробовал с Драйвер1СУстройстваВводаNative.
RSDriver нигде не хочет регистрироваться, Драйвер1СУстройстваВводаNative устанавливается на десктопе, на мобильном не хочет.
Пока просто пытаюсь зарегистрировать ВК на смартфоне.

Подскажите в какую сторону копать ?
   Калыван
 
1 - 15.10.20 - 14:04
В общем тестировать такие ВК на смартфоне с Андроид 9 не самый лучший вариант, на ТСД драйвера установились.
   Garykom
 
2 - 15.10.20 - 14:30
(1) Я тебе больше скажу на разных ТСД с разным android и с разными настройками безопасности в т.ч. хрен там что "установились"

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.