Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Печать X-отчета и Z-отчета из драйвера ФР (PUBID_58344-1CFPEmulatorWinPrinter_v2UT )

Печать X-отчета и Z-отчета из драйвера ФР (PUBID_58344-1CFPEmulatorWinPrinter_v2UT )
Я
   Boudybuilder
 
08.10.20 - 00:40
Здравствуйте, может кто знает - не печатается X-отчета и Z-отчета. Вот такие убогие функции там:


// Функция осуществляет снятие X-отчёта на ФР.
// (API v2.0)
//
// Параметры:
//  Объект                         - <*>
//                                 - Объект драйвера ФР.
//
//  Пароль                         - <Число>
//                                 - Пароль пользователя ФР.
//
//  НомерЧека                      - <Число>
//                                 - Выходной параметр; номер чека ФР.
//
//  НомерСмены                     – <Число>
//                                 - Выходной параметр; номер текущей смены ФР.
//
// Возвращаемое значение:
//  <ПеречислениеСсылка.ТООшибки*> - Результат выполнения операции.
//
Функция XОтчет(Объект, Пароль, НомерЧека, НомерСмены) Экспорт

    Результат = мНетОшибки;

    Сообщить("Печать Х-отчета");

    Возврат Результат;

КонецФункции // XОтчет()

// Функция осуществляет снятие Z-отчёта на ФР.
// (API v2.0)
//
// Параметры:
//  Объект                         - <*>
//                                 - Объект драйвера ФР.
//
//  Пароль                         - <Число>
//                                 - Пароль пользователя ФР.
//
//  НомерЧека                      - <Число>
//                                 - Выходной параметр; номер чека ФР.
//
//  НомерСмены                     – <Число>
//                                 - Выходной параметр; номер текущей смены ФР.
//
// Возвращаемое значение:
//  <ПеречислениеСсылка.ТООшибки*> - Результат выполнения операции.
//
Функция ZОтчет(Объект, Пароль, НомерЧека, НомерСмены) Экспорт

    Результат = мНетОшибки;

    Если мСменаОткрыта Тогда
        Сообщить("Печать Z-отчета");
        Сообщить("------------------- Смена закрыта ------------------" + Символы.ПС);
        мСменаОткрыта = Ложь;
    Иначе
        Объект.ОписаниеОшибки = "На данном ФР смена уже закрыта";
        Результат = мОшибкаНеизвестно;
    КонецЕсли;

    Возврат Результат;

КонецФункции // ZОтчет()


Где найти полноценные функции или драйвер поновее?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.