Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как удалить строки ТЧ (ПередЗаписью) ?

Как удалить строки ТЧ (ПередЗаписью) ?
Я
   Snail
 
07.10.20 - 16:52
Создал кнопку на форме "Удалить" при нажатии удаляет строки ТЧ где количесво = 0. Как впихнуть ее в кнопку "Провести и закрыть"?
   Fish
 
1 - 07.10.20 - 16:53
(0) Перенеси код из обработчика кнопки в событие перед записью. Не благодари.
   Dionisious
 
2 - 07.10.20 - 16:54
Ну все правильно в событие ПередЗаписью.
   fisher
 
3 - 07.10.20 - 17:01
(0) Просто в ПередЗаписью проверяй режим записи. И если режим записи (он в параметрах обработчика прилетает) проведение - тогда и чистишь. Можно это делать в обработчике объекта (в модуле объекта), а не формы. Тогда и при программном проведении и при проведении из списка мимо формы тоже будет чистить.
   Snail
 
4 - 07.10.20 - 17:07
Массив = Новый Массив;
    Для Каждого Строка из Объект.ТЧМат Цикл
        Если Строка.Количество = 0 Тогда
            Массив.Добавить(Строка);
        КонецЕсли;
    КонецЦикла;
    Для Каждого Строка из Массив Цикл
        Объект.ТЧМат .Удалить(Строка);
    КонецЦикла;     

Вообще не реагирует (((
Я и сообщить прописал, ничего не сообщает
   Snail
 
5 - 07.10.20 - 17:08
и в модуле и в форме никакой реакции
   fisher
 
6 - 07.10.20 - 17:12
(5) В форме у тебя обработчик может быть не привязан. Проверь в палитре свойств формы привязку обработчиков к событиям.
А в модуле объекта у тебя этот код вообще падать по ошибке должен. "Объект" - это у тебя реквизит формы. А модуль объекта отрабатывает в контексте, в котором форма отсутствует как класс.
   Snail
 
7 - 07.10.20 - 17:13
Я ждал ошибку в модуле, но нет ошибки
   Fish
 
8 - 07.10.20 - 17:13
(6) Видимо, у него и в модуле обработчик не привязался.
   Snail
 
9 - 07.10.20 - 17:13
о, прекращена работа 1С
   Dionisious
 
10 - 07.10.20 - 17:14
В модуле объекта переменной Объект не существует.
   Dionisious
 
11 - 07.10.20 - 17:14
А в модуле формы надо не Объект менять а параметр обработчика.
   fisher
 
12 - 07.10.20 - 17:14
"Не вынесла душа поэта позора мелочных обид" (с)
   Snail
 
13 - 07.10.20 - 17:15
Все, заработало!
   Snail
 
14 - 07.10.20 - 17:17
Всем СПАСИБО! (После перезагрузки компа все заработало)
   fisher
 
15 - 07.10.20 - 17:19
Чудеса кэша конфы могли быть после динамических обновлений. Или конфигуратор редко случается клинит похожим образом в нештатных ситуациях - когда обновления на самом деле не применяются.
   fisher
 
16 - 07.10.20 - 17:20
Раз 1С свернулась в коврик - однозначно ей нехорошо было :)
   Snail
 
17 - 07.10.20 - 17:23
целый час просидел ) Главное что Сообщить нигде не реагировало, нужно было задуматься, что что-то не так ))

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.