Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

УФ: Не могу подключить внешний отчёт

УФ: Не могу подключить внешний отчёт
Я
   OnePrg
 
07.10.20 - 16:19
http://imagizer.imageshack.com/img924/5877/AtfYfL.png

http://imagizer.imageshack.com/img922/2376/LNphVB.png

http://imagizer.imageshack.com/img922/6779/FdILPS.png

Функция СведенияОВнешнейОбработке() Экспорт

ПараметрыРегистрации = Новый Структура;
МассивНазначений = Новый Массив;

ПараметрыРегистрации.Вставить("Вид", "ДополнительныйОтчет");
ПараметрыРегистрации.Вставить("Наименование", "Оперативный учёт партий");
ПараметрыРегистрации.Вставить("БезопасныйРежим",ЛОЖЬ);
ПараметрыРегистрации.Вставить("Информация", "Оперативный учёт партий");
ПараметрыРегистрации.Вставить("Версия", "1.0");    

ТаблицаКоманд = ПолучитьТаблицуКоманд();
ДобавитьКоманду(ТаблицаКоманд, "Оперативный учёт партий", "СформироватьОтчет", "ОткрытиеФормы");
ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);

Возврат ПараметрыРегистрации;

КонецФункции

Функция ПолучитьТаблицуКоманд()
Команды = Новый ТаблицаЗначений;
Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));//как будет выглядеть описание печ.формы для пользователя
Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка")); //имя макета печ.формы
Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка")); //ВызовСерверногоМетода
Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));

Возврат Команды;
КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")

НоваяКоманда = ТаблицаКоманд.Добавить();
НоваяКоманда.Представление = Представление;  
НоваяКоманда.Идентификатор = Идентификатор;
НоваяКоманда.Использование = Использование;
НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
НоваяКоманда.Модификатор = Модификатор;

КонецПроцедуры
   Mihasya
 
1 - 07.10.20 - 16:35
Первым делом чистить кэш ))
   Mihasya
 
2 - 07.10.20 - 16:37
А вторым показать что выводит при нажатии "Раздел Склад и Доставка" из первого скрина
   Greeen
 
3 - 07.10.20 - 16:39
1) Может быть в пользователях не выбран
2) Возможно, есть еще дополнительные отчеты (а не обработки)
   hhhh
 
4 - 07.10.20 - 16:40
(0) вообще-то у вас эта функция
Функция СведенияОВнешнейОбработке() 

какая-то старинная, наверно лет 5 назад так писали. Из интернета похоже скачали.

замените на более свежую, из бсп, возьмите демоконфигурацию бсп и там посмотрите примеры.
   OnePrg
 
5 - 07.10.20 - 16:42
Всем спасибо.

Разобрался. В разделе, куда я его добавлял нет ссылки "Дополнительные отчеты", есть ссылка "Дополнительные обработки". Добавил в раздел, где есть именно "Дополнительные отчеты" - всё видно.
   Mihasya
 
6 - 07.10.20 - 16:43
(4)
"(0) вообще-то у вас эта функция
Функция СведенияОВнешнейОбработке()" 
Да ладно, а щас как?!
   Mihasya
 
7 - 07.10.20 - 16:44
(5) Попутал обработку с отчетом... )))
   worker-good
 
8 - 07.10.20 - 16:44
(5) А я так и знал, но не успел ответить)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.