Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Получить имя назначенной картинки элементу формы

Получить имя назначенной картинки элементу формы
Я
   Chameleon1980
 
07.10.20 - 13:49
привет всем.

http://prntscr.com/uuogmm

как узнать какое имя картинки из библиотеки?
   acht
 
1 - 07.10.20 - 14:02
Для Каждого МетаКартинка Из Метаданные.ОбщиеКартинки Цикл
    Если БиблиотекаКартинок[МетаКартинка.Имя] = Искомое Тогда
...
   Chameleon1980
 
2 - 07.10.20 - 14:05
не. Вы не поняли.
У меня элемент формы. У него картинка из общих картинок.
Как из элемента формы получить имя картинки в общих картинках?
   Chameleon1980
 
3 - 07.10.20 - 14:05
хотя сек.
   Chameleon1980
 
4 - 07.10.20 - 14:06
(1) да - подходит - спасибо
   Chameleon1980
 
5 - 07.10.20 - 15:08
(4) + но чет не всегда срабатывает. :(
   mikecool
 
6 - 07.10.20 - 15:41
(5) значит не всегда из общих
   Chameleon1980
 
7 - 07.10.20 - 16:01
(5) есть такое подозрение, но, вроде все картинки запихнули в общие
посмотрю еще раз откуда картинки, которые не определяются и обязательно отпишусь для справки
   Chameleon1980
 
8 - 08.10.20 - 08:10
неее. Картинки из общих и не определяются некоторые из способа (1)
хз почему. Не знает ли кто еще способов?
привет всем.
   TormozIT
 
9 - 08.10.20 - 08:44
В ИР есть общая форма ирВыпускВариантаПортативный. Она выпускает портативный вариант. Там есть _рабочий_ код
            Если ТипЗнч(ЗначениеСвойства) = Тип("Картинка") Тогда
                Если ЗначениеСвойства.Вид = ВидКартинки.ИзБиблиотеки Тогда
                    ИмяОбщейКартинки = СериализаторXDTO.записатьXDTO(ЗначениеСвойства).ref.ЛокальноеИмя;
...
                КонецЕсли;
            ИначеЕсли ТипЗнч(ЗначениеСвойства) = Тип("Цвет") Тогда
                ИмяЦветаСтиля = СериализаторXDTO.записатьXDTO(ЗначениеСвойства).ЛексическоеЗначение;
                ПозицияСкобки = Найти(ИмяЦветаСтиля, "}");
                Если ПозицияСкобки > 0 Тогда
                    ИмяЦветаСтиля = Сред(ИмяЦветаСтиля, ПозицияСкобки + 1);
...
                КонецЕсли; 
            КонецЕсли;
   Chameleon1980
 
10 - 08.10.20 - 11:58
(9) спасибо огромное тебе. тоже думал смотреть из результата сериализации

Список тем форума
Рекламное место пустует  Рекламное место пустует
Миста — веселый ресурс со своими эксклюзивными тараканами Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.