Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

ERP интеграция с ДО . Пропала кнопка в "Задачах" Создать на основании

ERP  интеграция с ДО . Пропала кнопка в "Задачах"  Создать на основании
Я
   Юзер123
 
06.10.20 - 12:36
Доброго времени.

Есть ЕРП и ДО.  После обновления ЕРП из обекта Задача пропала кнопка создать на основании.  Куда  копать подскажите пож-та
   Юзер123
 
1 - 06.10.20 - 12:42
   Юзер123
 
2 - 06.10.20 - 12:43
В конфигураторе в объекте задача  она есть
   Юзер123
 
3 - 06.10.20 - 12:43
   Юзер123
 
4 - 06.10.20 - 12:48
Процедура ДобавитьКомандыСозданияНаОсновании(КомандыСозданияНаОсновании, Параметры) Экспорт
    
    БизнесПроцессы.Задание.ДобавитьКомандуСоздатьНаОсновании(КомандыСозданияНаОсновании);
    
КонецПроцедуры

// Для использования в процедуре ДобавитьКомандыСозданияНаОсновании других модулей менеджеров объектов.

// Добавляет в список команд создания на основании этот объект.
//

// Параметры:
//  КомандыСозданияНаОсновании - см. СозданиеНаОснованииПереопределяемый.ПередДобавлениемКомандСозданияНаОсновании.КомандыСозданияНаОсновании

//
// Возвращаемое значение:

//  СтрокаТаблицыЗначений, Неопределено - описание добавленной команды.
//

Функция ДобавитьКомандуСоздатьНаОсновании(КомандыСозданияНаОсновании) Экспорт
    
    Если ОбщегоНазначения.ПодсистемаСуществует("СтандартныеПодсистемы.ПодключаемыеКоманды") Тогда
        МодульСозданиеНаОсновании = ОбщегоНазначения.ОбщийМодуль("СозданиеНаОсновании");
        Команда = МодульСозданиеНаОсновании.ДобавитьКомандуСозданияНаОсновании(КомандыСозданияНаОсновании, Метаданные.Задачи.ЗадачаИсполнителя);
        Если Команда <> Неопределено Тогда
            Команда.ФункциональныеОпции = "ИспользоватьБизнесПроцессыИЗадачи";
        КонецЕсли;
        Возврат Команда;
    КонецЕсли;
    
    Возврат Неопределено;
    
КонецФункции
   Юзер123
 
5 - 06.10.20 - 12:48
Это в модуле объекта Задача
   Юзер123
 
6 - 06.10.20 - 12:53
   Юзер123
 
7 - 06.10.20 - 13:50
up
   Юзер123
 
8 - 07.10.20 - 00:46
(
   Юзер123
 
9 - 07.10.20 - 08:14
Утренний ап.  подскажите кто работает ДО _ ЕРП.
   Momus
 
10 - 07.10.20 - 08:32
Это бесшовная интеграция с ДО?
   Фрэнки
 
11 - 07.10.20 - 08:37
Если были какие-то обновления, то есть вероятность и она возможно сработала, что закэшированная для сеанса пользователя на клиенте форма просто не совпадает с тем, как она теперь выглядит в конфигураторе.

Либо надо вычищать кэши целиком

Либо пытаться устанавливать в нужной форме в "изменить форму" и "... стандартные настройки", затем форму закрывать и открывать заново - следующий пуск возможно считает данные формы уже из конфигуратора и проигнорирует сохраненную в кэше информацию, а при выходе из формы ее перезапишет.
   Юзер123
 
12 - 07.10.20 - 09:11
(10) да
   Юзер123
 
13 - 07.10.20 - 09:12
(11)  Хорошо. Попробую.  Но это на тестовых базах тоже.  А они перезаливаются каждый день.
   Momus
 
14 - 07.10.20 - 09:45
(12) так это ж надо не в модуль задачи глядеть, а смотреть в форме обработки "Интеграция с ДО".
   Юзер123
 
15 - 07.10.20 - 11:07
(14) Если ссылочку открыть в окне который открывается.  Там стоит Задача.ЗадачаИсполнителя
   xraf
 
16 - 07.10.20 - 11:15
(0) Наверняка в новом релизе исправят.
как правило эти все объекты в общих формах, попробуйте в конфигураторе отобрать по "Документооборот"
и сравни общие команды и общие формы со старым релизом.
   Momus
 
17 - 07.10.20 - 11:33
(15) странно. Моя erp все данные тащит из ДО и ничего в себе не хранит (кроме идентификаторов объектов)
   Юзер123
 
18 - 07.10.20 - 11:49
(17)  мне кажется Вы правы. Меня ссылка ввела в заблуждение.  Сейчас посмотрю форму обработки
   Momus
 
19 - 07.10.20 - 11:52
(18) а что создавать нужно? Там вроде только внутренние документы можно
   Momus
 
20 - 07.10.20 - 11:53
(19) просто документы, не только внутренние*
   Юзер123
 
21 - 07.10.20 - 22:53
Нашел.
Да это обработка интеграция.  До обновы там или объект типа договор можно было создавать или  процесс.  После обновы пропал "Процесс" и кнопка сама с формы выпилилась и осталась только в меню еще.  Разобрался.  Работает.  Спасибо.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.