Вход | Регистрация
 

Как перехватить форму списка в расширении

Как перехватить форму списка в расширении
Я
   lite777
 
06.10.20 - 11:36
1с розн, нужно изменить форму списка документа Заказ Покупателя , добавил форму списка в расш, там дин список, запрос дин списка менять не дает, пишет режим просмотра, куда тут копать ?
Перехватывать проц модуля списка "ПрисозданиинаСервере" ?
   lite777
 
1 - 06.10.20 - 12:03
Формы списка кто нить дорабатывал ?
   Галахад
 
2 - 06.10.20 - 12:11
(0) Список добавил в расширение?
   Dionisious
 
3 - 06.10.20 - 13:00
(0) А чем не нравится вариант ПриСозданииНаСервере поменять запрос програмно?
   lite777
 
4 - 06.10.20 - 13:43
Список добавил, как именно поменять ?
   lite777
 
5 - 06.10.20 - 13:44
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    // Пропускаем инициализацию, чтобы гарантировать получение формы при передаче параметра "АвтоТест".

    Если Параметры.Свойство("АвтоТест") Тогда
        Возврат;
    КонецЕсли;
    
    // СтандартныеПодсистемы.ПодключаемыеКоманды

    ПодключаемыеКоманды.ПриСозданииНаСервере(ЭтотОбъект);
    // Конец СтандартныеПодсистемы.ПодключаемыеКоманды

    
    ИспользоватьРезервированиеПоЗаказамПокупателей = ПолучитьФункциональнуюОпцию("ИспользоватьРезервированиеПоЗаказамПокупателей");
    
    УстановитьОтборДинамическихСписков();
    
    ОбщегоНазначенияРТ.УстановитьУсловноеОформлениеПоляДата(ЭтотОбъект, "Список", "Дата");
    
КонецПроцедуры
   lite777
 
6 - 06.10.20 - 13:44
Здесь такая вот штука
   sitex
 
7 - 06.10.20 - 13:45
(3) Ну запрос то он может и поменяет . НО будет в типовой штатный функционал которые также будет менять запрос и не чего не взлетит. По этому тут надо Вместо использовать.
   Dionisious
 
8 - 06.10.20 - 13:46
Список.ТекстЗапроса = "";
   Dionisious
 
9 - 06.10.20 - 13:47
(7) Конструктором запроса запарится добавить нужные поля и таблицы. Но я ни разу не пробовал.
   lite777
 
10 - 06.10.20 - 13:51
&НаСервере
&Вместо("ПриСозданииНаСервере")
Процедура Расш_ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    // Вставить содержимое метода.

    Сообщить("777") ;
    ПродолжитьВызов(Отказ, СтандартнаяОбработка);
КонецПроцедуры  
Да ,Список.ТекстЗапроса = ""; 

Попробую !
   NWsFF
 
11 - 06.10.20 - 13:52
(0) в (2) тебе же написали, чтобы настройка списка была доступна, добавь ее в расширение https://prnt.sc/uu0l1r
   sitex
 
12 - 06.10.20 - 13:54
(10) Ну типовой то код тоже добавить не забудь. И дополняй своим. (11) тоже не игнорь
   lite777
 
13 - 06.10.20 - 13:55
(11) Форма списка в расширении
   lite777
 
14 - 06.10.20 - 13:55
(12) Да спасибо,счас попробую
   Dionisious
 
15 - 06.10.20 - 13:59
(11) А и точно. После такой операции можно текст запроса менять.
   lite777
 
16 - 06.10.20 - 14:04
(15) Похоже да ,
   lite777
 
17 - 06.10.20 - 14:04
Недопер сразу
   lite777
 
18 - 06.10.20 - 14:44
Чот запрос поменял ,но нужные мне поля не появились
   lite777
 
19 - 06.10.20 - 14:45
в запрос добавил нужные мне поля
   sitex
 
20 - 06.10.20 - 14:52
(19) Ну так добавь программное свое поле в Расш_ПриСозданииНаСервере
   lucbak
 
21 - 06.10.20 - 14:54


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.