Вход | Регистрация
 

1C Мобильное приложение и сохранение файлов на андроид

1C Мобильное приложение и сохранение файлов на андроид
Я
   Nik_Zzz
 
06.10.20 - 10:52
Пытаюсь сохранить текстовый файл с выбором каталога :

&НаКлиенте
Процедура Сохранение()
Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Сохранение);
    Диалог.Заголовок = "Сохранить в файл";
    Диалог.Фильтр = "Файл ТЧ документа (*.txt)|*.txt|Все файлы (*.*)|*.*";
    Диалог.ПолноеИмяФайла = "Документ1";
    Диалог.Показать(Новый ОписаниеОповещения("ВыгрузитьЗавершение", ЭтаФорма, Новый Структура("Диалог", Диалог)));
КонецПроцедуры


Пишет ОШИБКУ:
ДиалогВыбораФайла не работает в режиме "Сохранение".
Для записи используйте метод ПолучитьФайл с параметром "Интерактивно".



Ошибку пишет только в самом приложение .apk  , в толстом клиенте работает отлично.
Подскажите куда копать , может у кого есть примеры сохранения файлов в мобильном приложении.
   PR
 
1 - 06.10.20 - 10:57
(0) Используй НачатьПомещениеФайла
   PR
 
2 - 06.10.20 - 10:58
+(1) В СП есть пример
   Nik_Zzz
 
3 - 06.10.20 - 12:01
(2) &НаКлиенте
Процедура ПоместитьФайлИнтерактивно()
    ОбработкаОкончанияПомещения = Новый ОписаниеОповещения
        ("ОбработчикОкончанияПомещения", ЭтотОбъект);

    НачатьПомещениеФайла(ОбработкаОкончанияПомещения,,,Истина,ЭтотОбъект.УникальныйИдентификатор);
КонецПроцедуры


&НаКлиенте
Процедура ОбработчикОкончанияПомещения(Результат, Адрес,  ВыбранноеИмяФайла, ДополнительныеПараметры) Экспорт
    Если Результат Тогда
        Сообщить(Адрес);
    Иначе
        Сообщить("Файл не был помещен.");
    КонецЕсли 
КонецПроцедуры



https://i.ibb.co/XWdvDGw/image.png
только вместо открыть , нужно сохранить , как это сделать?
   Nik_Zzz
 
4 - 06.10.20 - 15:03
нужно не перемещать, а  именно сохранять
   Nik_Zzz
 
5 - 09.10.20 - 08:33
https://i.ibb.co/6JvgMxT/image.jpg

(3)Это получается диалог открытия, а нужно сохранения
   Сияющий в темноте
 
6 - 11.10.20 - 01:40
для диалога сохранения файла на андройд у программы должны быть определенные рпзрешения запрошены,а 1с  это не делает.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.