Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Проблема с доступом после переименования компа в локальной сети

Проблема с доступом после переименования компа в локальной сети
Я
   i_oops_i
 
02.10.20 - 06:46
Всем привет!
Ребята, помогите чайнику разобраться что и откуда растет...

Имеем маленькую сетку, на одном из компов(BELEOKS) установлен ключ на 5 пользователей. Потребовалось изменить имя компа с ключем и вообще на днях комп будет меняться. Меняю имя и при входе в 1С у других пользователей наблюдаю [url=https://i.postimg.cc/Wz9F9g6x/image.jpg]ошибку[/url], то есть где прописано старое название компа с ключом, вопрос где и как его поменять?
На компе с ключом есть [url=https://i.postimg.cc/c426rsD7/image.png]управление службой сервера[/url], [url=https://i.postimg.cc/cL3C3Vjp/image.png]соединение с сервером[/url], [url=https://i.postimg.cc/J4VzLTtK/image.png]консоль сервера[/url]. Мне кажется что то прописано на клиентских компах по сети, не разберусь только где.
   Галахад
 
1 - 02.10.20 - 06:54
Вообще в hasp.ini
   i_oops_i
 
2 - 02.10.20 - 06:59
(1) смотрел nethasp.ini на клиентских компах, он не редактировался вообще, в девственном состоянии
   hhhh
 
3 - 02.10.20 - 07:04
(2) тут 2 варианта: или ничего не нужно делать, всё само собой получиться или вы смотрели не тот nethasp.ini
   i_oops_i
 
4 - 02.10.20 - 08:19
(3) смотреть нужно ведь на клиентских компах? в сети нет терминального сервера...
версия 1С 8.3.13.1513
путь C:\Program Files (x86)\1cv8\bin\conf\ не содержит nethasp.ini вообще
https://i.postimg.cc/0jzgKKZ9/1c2.png

путь C:\Program Files (x86)\1cv8\conf\ содержит оригинальный nethasp.ini
https://i.postimg.cc/FsJ59c7Z/1c1.png
   i_oops_i
 
5 - 02.10.20 - 08:50
файл hosts посмотрел на всех компах, он не тронут, но недавно перешли на DrWeb и он восстанавливал файлы hosts на компах в исходное состояние, видимо были какие то записи, но не известно было что нибудь в них по 1С или нет. Думаю файл hosts не связан с 1С, т.к. при изменении имени компа с ключом 1С на клиентских компах всплывает старое имя, которого нет в файле hosts/
   del123
 
6 - 02.10.20 - 09:12
так это лицензия СЛК, причем тут хасп. Сотрите обработку по работе с лицензированием в конфигурации
   i_oops_i
 
7 - 02.10.20 - 12:08
(6) вооот! я знал что где то в ж@пе это спрятано)
можно подробнее, какая обработка отвечает за путь к ключам?
   del123
 
8 - 02.10.20 - 13:50
(7) в твоей конфе без понятия, в общепите от Раруса есть обработка "Менеджер лицензий СЛК"
Ищи по словам "лицензир", что-нибудь такое)
   i_oops_i
 
9 - 02.10.20 - 19:15
(8) спасибо большое за наВОДКУ :)
нашел сие:
https://i.postimg.cc/B6k9LYnp/image.png

дальше стал искать что то похожее в режиме предприятия, но видимо не там ищу.
   i_oops_i
 
10 - 02.10.20 - 21:43
Может кто подскажет где найти эту форму с настройками?
   Neg
 
11 - 02.10.20 - 21:46
В Администрировании наверное, либо "Все функции"
   i_oops_i
 
12 - 03.10.20 - 08:43
(11) сижу битый час и не могу ничего найти, обшарил все пункты меню в режиме Придприятия
есть только "Настройка программы (ЖКХ)"
https://i.postimg.cc/YCWPShqw/image.jpg
но это не то...

В режиме Конфигуратора:
Общие - Подсистема - СЗК_СистемаЛицензированияКонфигурации
Общие - Общие формы - СЗК_СистемаЛицензированияКонфигурации
https://i.postimg.cc/N08P1SHJ/image.png
видимо эти настройки скрыты как то?

////////////////////////////////////////////////////////////////////////////////

// ПРОЦЕДУРЫ И ФУНКЦИИ УПРАВЛЕНИЯ ВИДИМОСТЬЮ

&НаКлиентеНаСервереБезКонтекста
// Процедура устанавливает значения по умолчанию полей ввода и управляет их видимостью.

Процедура УстановитьВидимость(Форма, ВидСвязиИзменен = Ложь)
    
    Элементы = Форма.Элементы;
    
    Элементы.ГруппаАдресСервераСЛК.Видимость      = Не (Форма.ВариантСвязи = 2);
    Элементы.ГруппаАдресСервераСЛК.ТолькоПросмотр = Не (Форма.ВариантСвязи = 1);
    
КонецПроцедуры

////////////////////////////////////////////////////////////////////////////////

// ВСПОМОГАТЕЛЬНЫЕ ПРОЦЕДУРЫ И ФУНКЦИИ

&НаСервере
// Процедура устанавливает вариант связи в зависимости от значения константы СЗК_ПараметрыСвязи.

Процедура ПрочитатьПараметрыСвязи()
    
    СтрокаПараметровСвязи = НаборКонстант.СЗК_ПараметрыСвязи;
    
    ИмяАдресКомпьютера = ПолучитьНастройкуИзКонстанты("host=", СтрокаПараметровСвязи);
    СетевойПорт        = ПолучитьНастройкуИзКонстанты("port=", СтрокаПараметровСвязи);
    
    Если ПустаяСтрока(СтрокаПараметровСвязи) И ЭтоФайловыйВариантИБ Тогда
        ВариантСвязи = 2;
    ИначеЕсли НРег(ИмяАдресКомпьютера) = "localhost" Тогда
        ВариантСвязи = 0;
    Иначе
        ВариантСвязи = 1;
    КонецЕсли;
    
КонецПроцедуры

&НаСервере
// Функция разбирает строковое значение константы и возвращает значение настройки.

//
// Параметры:

//    НазваниеНастройки - название настройки, значение которой нужно вернуть из строковй константы СЗК_ПараметрыСвязи.
//

Функция ПолучитьНастройкуИзКонстанты(НазваниеНастройки, СтрокаПараметровСвязи)
    
    ЗначениеНастройки = "";
    
    ПозицияНачалаНастройки = Найти(НРег(СтрокаПараметровСвязи), НазваниеНастройки);
    Если НЕ ПозицияНачалаНастройки = 0 Тогда
        СтрокаНастройки = Сред(СтрокаПараметровСвязи, ПозицияНачалаНастройки, СтрДлина(СтрокаПараметровСвязи) - ПозицияНачалаНастройки + 1);
        ПозицияКонцаНастройки = Найти(СтрокаНастройки, ";");
        ЗначениеНастройки = Сред(СтрокаНастройки, СтрДлина(НазваниеНастройки) + 1, ПозицияКонцаНастройки - СтрДлина(НазваниеНастройки) - 1);
    КонецЕсли;
    
    Возврат ЗначениеНастройки;
    
КонецФункции

&НаКлиенте
// Процедура сброса параметров связи при изменении вида связи с сервером лицензий.

//
Процедура СброситьПараметрыСвязи()
    
    Если ВариантСвязи = 0 Тогда
        ИмяАдресКомпьютера = "localhost";
        СетевойПорт        = "9099";
    ИначеЕсли ВариантСвязи = 1 Тогда
        ИмяАдресКомпьютера = "";
    Иначе
        ИмяАдресКомпьютера = "";
        СетевойПорт        = "";
    КонецЕсли;
    
КонецПроцедуры

////////////////////////////////////////////////////////////////////////////////

// ОБРАБОТЧИКИ СОБЫТИЙ ФОРМЫ

&НаСервере
// Процедура - обработчик события "ПриСозданииНаСервере" формы.

Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    ЭтоФайловыйВариантИБ = (Найти(СтрокаСоединенияИнформационнойБазы(), "File=") > 0);
    
    Элементы.ПереключательВариантСвязи.СписокВыбора.Добавить(0, "Локально, на этом компьютере");
    Элементы.ПереключательВариантСвязи.СписокВыбора.Добавить(1, "На другом компьютере сети");
    Если ЭтоФайловыйВариантИБ Тогда
        Элементы.ПереключательВариантСвязи.СписокВыбора.Добавить(2, "Индивидуально для каждого пользователя");
    КонецЕсли;
    
    ПрочитатьПараметрыСвязи();
    
    УстановитьВидимость(ЭтаФорма);
    
КонецПроцедуры

&НаКлиенте
// Процедура - обработчик события "ПередЗаписью" формы.

Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
    
    Если ВариантСвязи = 2 Тогда
        НаборКонстант.СЗК_ПараметрыСвязи = "";
    Иначе
        НаборКонстант.СЗК_ПараметрыСвязи = "host=" + ИмяАдресКомпьютера + ";" + "port=" + СетевойПорт + ";";
    КонецЕсли;
    
КонецПроцедуры

////////////////////////////////////////////////////////////////////////////////

// ОБРАБОТЧИКИ СОБЫТИЙ ЭЛЕМЕНТОВ ФОРМЫ

&НаКлиенте
// Процедура - обработчик события "ПриИзменении" переключателя "ПереключательВариантСвязи".

Процедура ПереключательВариантСвязиПриИзменении(Элемент)
    
    СброситьПараметрыСвязи();
    
    УстановитьВидимость(ЭтаФорма);
    
КонецПроцедуры
   i_oops_i
 
13 - 03.10.20 - 18:23
help(
   МимохожийОднако
 
14 - 04.10.20 - 07:54
К разработчикам конфигурации или к документации пробовал обратиться?
   i_oops_i
 
15 - 04.10.20 - 08:02
(14) не пробовал, поддержка прекращена, конфигурация вроде типовая.
   Alexor
 
16 - 04.10.20 - 08:04
(15) Дык. "Расположение сервера СЛК на другом компьютере сети" делал?
   aka AMIGO
 
17 - 04.10.20 - 08:07
Обратно переименовать не пробовал?
Шутю, но.. доля шутки есть :)
   i_oops_i
 
18 - 04.10.20 - 20:26
(16) как попасть в настройки где указывается ip или имя компа СЛК? вот в чем вопрос!
   Ёпрст
 
19 - 04.10.20 - 22:19
(18) дык в константах жешь..
   Ёпрст
 
20 - 04.10.20 - 22:19
судя по картинке

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.