Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

УПП: Возврат излишне выплаченной зарплаты

УПП: Возврат излишне выплаченной зарплаты
Я
   Mikhail Volkov
 
01.10.20 - 09:26
Как правильно в УПП/КА1 оформить Возврат излишне выплаченной зарплаты. Сотруднику насчитали отпускные, выплатили. Потом оказалось много, надо часть вернуть срочно (еще вчера, конец квартала).
   Kongo2019
 
1 - 01.10.20 - 09:52
ПКО, возврат денежных средств работником.
   Mikhail Volkov
 
2 - 01.10.20 - 10:25
(1) Какие особенности этого ПКО? При выплате зарплаты никаких РКО вроде не делалось: делалось п/п исходящее, приносились деньги из банка, раздавались...
   Kongo2019
 
3 - 01.10.20 - 11:39
(2) Ну так как он тебе деньги возвращать будет? В кассу же.
   Mikhail Volkov
 
4 - 01.10.20 - 12:04
(3) Ну да, больше никак. Дело в том, что все работают в Альфа-Авто, документы выгружаются в УПП. В Альфа-Авто тоже ПКО надо делать, чтобы касса увеличилась на сумму возврата. Но как?
   Kongo2019
 
5 - 01.10.20 - 12:26
Ты спросил как в УПП, я тебе рассказал. А как Альфа-Авто не знаю, я ее в глаза не видел. На чем она построена?
   sitex
 
6 - 01.10.20 - 12:33
(0) Если уволен то вернуть излишне выплаченные  в кассу.
    Если работает учесть при начислении заработной платы в следующем месяце.
   sitex
 
7 - 01.10.20 - 12:35
(4) А что есть какие то другие способы даже если это не УПП ?
   Mikhail Volkov
 
8 - 01.10.20 - 13:34
(7) Сперва озадачили: вроде как не через кассу, сразу в банк. В Альфа-Авто нет зарплаты, есть сотрудники как исполнители работ.
Вроде решил задачу. Всем спс.
   Mikhail Volkov
 
9 - 03.10.20 - 16:21
Дальше собираемся переходить в ERP/КА2. Пока в нее качаем документы из УПП/КА1, по правилам написанными в КД2. Столкнулся с такими трудностями:
1. В УПП/КА1 одному виду операции ВозвратДенежныхСредствРаботником теперь соответствует 2 хоз. операции ERP/КА2: ВозвратДенежныхСредствОтПодотчетника и ПрочееПоступлениеДенежныхСредств.
В ПКС ВидОперации - ХозяйственнаяОперация Перед выгрузкой написал так:
Если Источник.ВидОперации = Перечисления.ВидыОперацийПКО.ВозвратДенежныхСредствРаботником    //+МВ 03.10.2020

   И СокрЛП(Источник.СтатьяДвиженияДенежныхСредств.Наименование) = "Возврат заработной платы" Тогда
    Значение = "ПрочееПоступлениеДенежныхСредств";
Иначе
    ИмяПКО = "ХозяйственныеОперацииПКО";
КонецЕсли;
Вроде работает. Может как-то проще?
2. Для переноса остальных реквизитов После загрузки объекта написал так:
Если Объект.ХозяйственнаяОперация = Перечисления.ХозяйственныеОперации.ПрочееПоступлениеДенежныхСредств    //+МВ 03.10.2020

   И СокрЛП(Объект.СтатьяДвиженияДенежныхСредств.Наименование) = "Возврат заработной платы" Тогда
    Для каждого Строка Из Объект.РасшифровкаПлатежа Цикл
        Строка.СтатьяДоходов = ПланыВидовХарактеристик.СтатьиАктивовПассивов.ОплатаТруда;
        Строка.Подразделение = Объект.Подразделение;
        Строка.Субконто1     = Объект.ПодотчетноеЛицо;
    //    Строка.Субконто2     = ???;

    КонецЦикла;
КонецЕсли;
Вроде тоже работает. Но где Субконто2 брать? По гуглил, нашел https://its.1c.ru/db/answers1c/content/588/hdoc Вид начисления оплаты труда: "пп.25, ст.255 НК РФ". Но откуда это брать?
   hhhh
 
10 - 03.10.20 - 17:22
(9) Справочники.ТакойтоСправочник.найтиПоНаименованию("пп.25, ст.255 НК РФ")

или там перечисление? тогда Перечисления.ВидПеречисленияТакойто.ЗначениеТакоето;
   Mikhail Volkov
 
11 - 03.10.20 - 18:16
(10) Нашел модуле ОбновлениеИнформационнойБазыБП: Субконто = Объект.ВидыСубконто.Найти(ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.ВидНачисленийОплатыТрудаПоСтатье255НК, "ВидСубконто"); Заменял "ВидСубконто" на "пп.25, ст.255 НК РФ" - ошибку дает!?
   hhhh
 
12 - 03.10.20 - 18:25
(11) какое еще видСубконто? Вы (10) читали?

Строка.Субконто2 = томуто;
   Mikhail Volkov
 
13 - 03.10.20 - 18:41
(12) Строка.Субконто2 = Перечисления.ВидыНачисленийОплатыТрудаДляНУ.пп25ст255; - Получилось!
   Mikhail Volkov
 
14 - 05.10.20 - 09:08
А еще вопрос: в кассовых документах ERP/КА2 есть поля:  кассир и гл. бухгалтер. Если организация ИП эти поля оставлять пустыми, или заполнять самим владельцем ИП?
   zelyak
 
15 - 05.10.20 - 09:29
(14) поля есть, да если ИП - везде заполняется ИП.
Вы давно там работаете? Судя по статусу Мисты и задаваемым вопросам - аккаунт не Ваш.
   Mikhail Volkov
 
16 - 05.10.20 - 09:45
Заполняю ИП пишет: Ответственное лицо "Главный бухгалтер" не имеет права подписи этого документа. Что ни так?
(15) Давно не работаю, но поддерживаю. В чем сомнения?
   Mikhail Volkov
 
17 - 05.10.20 - 10:18
(16) + Стоит "Основное ответственное лицо организации"!? "Лицо имеющее право подписи документов" ставится, если оно за кого-то?
   Mikhail Volkov
 
18 - 05.10.20 - 13:13
А это (15) точно? Проверяется: РеквизитыОтветственногоЛица.ОтветственноеЛицо <> РеквизитыДляПроверки.ОтветственноеЛицо - Руководитель и Главный бухгалтер.
   Mikhail Volkov
 
19 - 05.10.20 - 15:55
+ Добавил в условие проверки:
    ИП = РеквизитыОтветственногоЛица.Владелец.ЮрФизЛицо = Перечисления.ЮрФизЛицо.ИндивидуальныйПредприниматель
       И РеквизитыОтветственногоЛица.ОтветственноеЛицо = Перечисления.ОтветственныеЛицаОрганизаций.Руководитель;    //+МВ 05.10.2020

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.