Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Помочь с добавлением внутри цикла по каждому результату строку табличной части.

Помочь с добавлением внутри цикла по каждому результату строку табличной части.
Я
   undertale
 
01.10.20 - 06:56
Задание: Заполнить табличную часть прохождения адаптации ( заполнить виды адаптаций которые привязаны к должности стажера). За ключевое поле брать должность стажера указанного в реквизите документа адаптации.

План действий:
1. Запрос с привязкой по должности, в котором выбираешь адаптации;(Сделано)
2. В цикле обходишь результат этого запроса;(Сделано)
3. Внутри цикла по каждому результату добавляешь строку табличной части.(не сделано, проблема)

Мой код:
Процедура ЗаполнитьНаСервере()

    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    ПрохождениеАдаптации.Стажеры.(
        |        ВидыВсякойАдаптации КАК ВидыВсякойАдаптации
        |    ) КАК Стажеры
        |ИЗ
        |    Документ.ПрохождениеАдаптации КАК ПрохождениеАдаптации
        |ГДЕ
        |    ПрохождениеАдаптации.ЛицаСтажеры.Должность = &Должность";
    
    Запрос.УстановитьПараметр("Должность", );
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
    
КонецЦикла;

    
КонецПроцедуры

&НаКлиенте
Процедура Заполнить(Команда)
    ЗаполнитьНаСервере();
КонецПроцедуры
   undertale
 
1 - 01.10.20 - 07:16
Прошу помочь разобраться с данным заданием, буду благодарен.
   piter3
 
2 - 01.10.20 - 07:17
Новаястрока=ТЧ.Добавить();
ЗаполнитьзначениеСвойств(Новаястрока,ВыборкаДетальныеЗаписи);
   Йохохо
 
3 - 01.10.20 - 07:25
данные 99% не из той таблицы берете, из стажеры надо не читать, а наоборот ее заполнять
   Ёпрст
 
4 - 01.10.20 - 07:36
(0)
   Запрос.Текст =
        "ВЫБРАТЬ
        |    ПрохождениеАдаптации.ВидыВсякойАдаптации  как  ВидыВсякойАдаптации
        |    
        |ИЗ
        |    Документ.ПрохождениеАдаптации.Стажеры КАК ПрохождениеАдаптации
        |ГДЕ
        |    ПрохождениеАдаптации.ссылка.ЛицаСтажеры.Должность = &Должность";

дальше как в (2)
   lEvGl
 
5 - 01.10.20 - 08:30
зачем нужен цикл?
ТЧ.Загрузить(Запрос.Выполнить().Выгрузить())
   lEvGl
 
6 - 01.10.20 - 08:31
(0) сумничай постановщику задачи при помощи (5) он оценит
   undertale
 
7 - 01.10.20 - 08:53
Ребят, спасибо, человек написал, что у меня ошибка в коде и он оказался прав, я переделал все и всё заработало <3
   lEvGl
 
8 - 01.10.20 - 09:10
(7) больше уверенности в себе, не без гонора

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.