Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Конвертация 2. Не загрузить документ если документ отмечен

Конвертация 2. Не загрузить документ если документ отмечен
Я
   чувак
 
30.09.20 - 14:00
Добрый день.
Как добиться того что если в базе приемнике есть документ с ключом, например реквизит "На перезаписать" с типом булево стоит истина, то документ не загрузился и не перезаписался?
   Ботаник Гарден Меран
 
1 - 30.09.20 - 14:08
Проверять Объект.Ссылка
   mistеr
 
2 - 30.09.20 - 14:09
ПКО При загрузке:
    Если ОбъектНайден И Объект.НеПерезаписывать Тогда
        НеЗамещатьОбъект = Истина;
    КонецЕсли;
   чувак
 
3 - 30.09.20 - 14:23
вот так уот сделал, вроде работает. После загрузки

Если Ссылка <> Документы.ОтчетОРОзничныхПродажах.ПустаяСсылка() Тогда
    Если Найти(Ссылка.Комментарий,"@@@") > 0 Тогда
        Отказ = Истина;
    КонецЕсли;    
КонецЕсли;    

всем спасибо
   mistеr
 
4 - 30.09.20 - 14:31
(3) Лучше делать до записи. Не создавать лишнюю нагрузку на базу.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.