Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Пара вопрос по работе в веб-клиенте (отладка и открытие файла excel)

Пара вопрос по работе в веб-клиенте (отладка и открытие файла excel)
Я
   RomarioAgro
 
30.09.20 - 11:19
Здравствуйте, подскажите, правильно ли я понимаю, что клиентский код при работе в веб-клиенте не отлаживается? И еще один вопрос, можно ли на клиентской стороне при работе в веб-клиенте открыть файл excel? У меня при работе в веб-клиенте не открывается, а при работе в тонком клиенте с опубликованной базой - работает. Может там какое расширение нужно дополнительно подключать, по типу как когда файл открываешь?
   RomarioAgro
 
1 - 30.09.20 - 11:58
1
   ejikbeznojek
 
2 - 30.09.20 - 12:09
(0) У меня без расширений открывается на 8.3.13.1690.

    ПолноеИмяФайла = "";
    Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие); 
    Диалог.Заголовок = "Выберите файл в формате xls.";     
    Диалог.Фильтр    = "Изображения (xls)|*.xls";    
    ОбработкаОкончанияЗагрузки =Новый ОписаниеОповещения("Обработка_Окончания_Загрузки", ЭтотОбъект,  Диалог);
    ОбработкаНачалаЗагрузки = Новый ОписаниеОповещения("Обработчик_Начала_Загрузки", ЭтотОбъект, Диалог);     
    НачатьПомещениеФайлов(ОбработкаОкончанияЗагрузки,Диалог , Истина,,ОбработкаНачалаЗагрузки);

Ну и 2 процедуры Обработка_Окончания_Загрузки и Обработчик_Начала_Загрузки
    
Про отладку не помню, тестить лень
   RomarioAgro
 
3 - 30.09.20 - 12:16
(2) Спасибо, у меня главный вопрос как ексель запустить на клиенте на вебе. Код я без отладчика написал, хоть это и не удобно, но самая печаль, что Excel = Новый COMОбъект("Excel.Application"); не работает
   lEvGl
 
4 - 30.09.20 - 12:25
(0) рыбак?
   ejikbeznojek
 
5 - 30.09.20 - 12:28
(3) хз...я на сервере это делаю.

&НаКлиенте
Процедура Обработка_Окончания_Загрузки(ДиалогВыбораФайла, Адрес) Экспорт
    ЗагрузитьБланкНаСервереВебКлиент(ДиалогВыбораФайла);    
КонецПроцедуры


&НаСервере
Процедура ЗагрузитьБланкНаСервереВебКлиент(МассивФайлов)
    если МассивФайлов=Неопределено тогда Возврат;КонецЕсли;    
    для каждого стрм из МассивФайлов цикл
        ДД=ПолучитьИзВременногоХранилища(стрм.Хранение);
        Адрес=ПоместитьВоВременноеХранилище(ДД,ЭтаФорма.УникальныйИдентификатор);
        ЗагрузкаНаСервере(Адрес);        
    КонецЦикла;        
КонецПроцедуры

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.