Вход | Регистрация
 

Вывод параметров на форму отчета СКД

Вывод параметров на форму отчета СКД
Я
   NIGHTHUNTER
 
28.09.20 - 08:43
Создан отчет на СКД. У него есть параметры. Но устанавливать их можно через Ещё -> Изменить вариант .
Каким образом их можно вывести на форму отчета ?

http://joxi.ru/ZrJxEqGHMaelM2
   NIGHTHUNTER
 
1 - 28.09.20 - 08:46
Сделал галкой включать в пользовательские настройки.

Можно ли как то регулировать размер этих полей ?
   NIGHTHUNTER
 
2 - 28.09.20 - 08:57
Задал программно параметры в СКД, но при открытии отчета там пусто. Почему не появляются в них заданные значения?

//

Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
    Настройки                         = КомпоновщикНастроек.Настройки;
    ПараметрСвойство               = Настройки.ПараметрыДанных.Элементы.Найти("Свойство");
    ПараметрСвойство.Значение      = ПланыВидовХарактеристик.ДополнительныеПоля.НайтиПоКоду("00015");
    ПараметрСвойство.Использование = Истина;
    //

    ПараметрНачДата                  = Настройки.ПараметрыДанных.Элементы.Найти("НачДата");
    ПараметрНачДата.Значение      = ПланыВидовХарактеристик.ДополнительныеПоля.НайтиПоКоду("00015");
    ПараметрНачДата.Использование = Истина;
    //

    ПараметрКонДата                  = Настройки.ПараметрыДанных.Элементы.Найти("КонДата");
    ПараметрКонДата.Значение      = ПланыВидовХарактеристик.ДополнительныеПоля.НайтиПоКоду("00015");
    ПараметрКонДата.Использование = Истина;
КонецПроцедуры
//
   NIGHTHUNTER
 
3 - 28.09.20 - 08:57
Или это они при выполнении отчета проставляются. А в программно генерируемую форму как их заполнить при открытии?
   NIGHTHUNTER
 
4 - 28.09.20 - 09:27
почему ругается на КомпоновщикНастроек ?


&НаКлиенте
Процедура ПриОткрытии(Отказ)

    ПараметрДанных= КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("Товар");
      

    ПараметрДанных.Значение = Справочники.Номенклатура.НайтиПоНаименованию("Гвозди");
      

    ПараметрДанных.Использование=Истина;
    
КонецПроцедуры
   hhhh
 
5 - 28.09.20 - 09:34
(4) наверно это надо &Сервере делать
   NIGHTHUNTER
 
6 - 28.09.20 - 09:39
Почему параметр НачДата не устанавливается в значение ?


//

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    ПараметрДанныхНачДата          = Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("НачДата");
    ПараметрДанныхНачДата.Значение = НачалоМесяца(ТекущаяДата());
    ПараметрДанныхНачДата.Использование   = Истина;
КонецПроцедуры
//
   NIGHTHUNTER
 
7 - 28.09.20 - 09:40
Форма открывается с пустым параметром
   NIGHTHUNTER
 
8 - 28.09.20 - 09:41
Делаю Изменить вариант там стоит, а на форме нет
   Pro-tone
 
9 - 28.09.20 - 09:44
   Pro-tone
 
10 - 28.09.20 - 09:46
+ (9) а значение параметра сохранять в пользовательском варианте отчета
   NIGHTHUNTER
 
11 - 28.09.20 - 09:47
(9) Да я так сделал, на форме появились поля, но при таком коде они без значений, значения только есть в изменить вариант.


//
&НаКлиенте
Процедура ПриОткрытии(Отказ)
    ПараметрДанныхНачДата               = Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("НачДата");
    ПараметрДанныхНачДата.Значение      = НачалоМесяца(ТекущаяДата());
    ПараметрДанныхНачДата.Использование = Истина;
    //

    ПараметрДанныхКонДата               = Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("КонДата");
    ПараметрДанныхКонДата.Значение      = НачалоМесяца(ТекущаяДата());
    ПараметрДанныхКонДата.Использование = Истина;
    //

    ПараметрДанныхСвойство               = Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("Свойство");
    ПараметрДанныхСвойство.Значение      = ПланыВидовХарактеристик.ДополнительныеПоля.НайтиПоКоду("00015");;
    ПараметрДанныхСвойство.Использование = Истина;
КонецПроцедуры
//
   NIGHTHUNTER
 
12 - 28.09.20 - 09:48
   NIGHTHUNTER
 
13 - 28.09.20 - 09:49
Открываю отчет на форме нет значений ((
   Pro-tone
 
14 - 28.09.20 - 09:54
(11) а зачем этот код? если в варианте отчета должно сохраняться?
   vicof
 
15 - 28.09.20 - 09:59
(11) Все это можно задавать в самом конструкторе схемы на вкладке "параметры".
   NIGHTHUNTER
 
16 - 28.09.20 - 10:05
(14) Код что бы при открытии отчета, уже стояли параметры.

Что бы пользователь их видел на форме. И мог менять.

Я задаю при открытии, они заполняются в форме изменить вариант. Но на форме отчета стоят пустыми. Как что бы они заполнились сделать?
   NIGHTHUNTER
 
17 - 28.09.20 - 10:17
(14) Это оно сохраняется в варианте отчета, нужно что бы отображалось на форме.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.