Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Собрать цифры в число

Собрать цифры в число
Я
   Облачко
 
25.09.20 - 16:53
Как можно собрать в СКД число из знаков: 1 2 35 6? Т.е. Нужно получить число 12356
   shuhard
 
1 - 25.09.20 - 16:56
(0) число из цифр ?
   Волшебник
 
2 - 25.09.20 - 16:57
1*10000 + 2*1000 + 3*100 + 5*10 + 6
   Облачко
 
3 - 25.09.20 - 16:58
(1) да
   Облачко
 
4 - 25.09.20 - 16:59
собрал огромный запрос, а почти в самом конце оказалось что переменная которая мне нужна числом, хранится как строка. Блин.. )
   Волшебник
 
5 - 25.09.20 - 16:59
Ещё никому не удавалось преобразовать строку в число в запросе.
   Облачко
 
6 - 25.09.20 - 17:02
задумка такая, я знаю разрядность - 6 знаков. преобразовываю символы строки в знаки, и знаки как-то соединяю. Отсюда вопрос, как два знака соединить в число? )
   Облачко
 
7 - 25.09.20 - 17:06
помогите, братья )))
   kubik_live
 
8 - 25.09.20 - 17:11
(7) А чем в (2) не устраивает???
   Облачко
 
9 - 25.09.20 - 17:13
(8) с первого раза не получилось, но теперь  похоже я выкручусь )
   Облачко
 
10 - 25.09.20 - 17:13
спасибо )
   Жан Пердежон
 
11 - 25.09.20 - 17:31
(5) ВЫБОР КОГДА ЧислоСтрокой = "1" ТОГДА 1 ИНАЧЕ 0 КОНЕЦ ЧислоЧислом
   Волшебник
 
12 - 25.09.20 - 17:35
(11) Это не число, а цифра
   eTmy
 
13 - 25.09.20 - 17:38
А в запросе ВЫРАЗИТЬ, не вариант?)
   eTmy
 
14 - 25.09.20 - 17:40
Вполне пятнично
   Жан Пердежон
 
15 - 25.09.20 - 17:52
(12) вполне число
   RomanYS
 
16 - 25.09.20 - 17:55
(12) При должном упорстве вполне решаемая задача, но причина почему Джо неуловим известна
   youalex
 
17 - 25.09.20 - 18:11
В СКД можно пользовать функции ОМ. Но то такое
   kubik_live
 
18 - 25.09.20 - 18:33
Функция СтрокаВЧисло(Стр)
    
    Результат=0;
    
    ИсхСтр=СокрЛП(Стр);
    
    ПромСтр="";
    
    Для Сч=1 По СтрДлина(ИсхСтр) Цикл
        
        ТекСимв=СокрЛП(Сред(ИсхСтр,Сч,1));
        
        Если НЕ ОбщегоНазначения.ЕстьНеЦифры(ТекСимв) И НЕ ТекСимв="" Тогда
            ПромСтр=ПромСтр+ТекСимв;
        Иначе
            Продолжить;
        КонецЕсли;    
        
    КонецЦикла;    
    
    
    Для Сч=-СтрДлина(ПромСтр) По -1 Цикл
        
        ТекМножитель=Сред(ПромСтр,-Сч,1);
        ТекРазряд=Pow(10,(СтрДлина(ПромСтр)+Сч));
        
        Результат=Результат+ТекМножитель*ТекРазряд;
        
    КонецЦикла;    
    
    Возврат Результат;
    
КонецФункции
   МихаилМ
 
19 - 25.09.20 - 19:10
   HeKrendel
 
20 - 26.09.20 - 09:38
(4) ну так заведи ещё одну числом
   Ненавижу 1С
 
21 - 26.09.20 - 10:27
(12) это число
7 - это число
"7" - это цифра
   Fram
 
22 - 26.09.20 - 10:48
Можно ещё собрать временную таблицу соответствия символа цифре (числу если угодно) и соединением
   Гений 1С
 
23 - 26.09.20 - 12:36
(5) через функции СКД же, Волшебник. Йопта


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.