Вход | Регистрация
 

При выводе табличного документа изменить формат ячейки по условию

При выводе табличного документа изменить формат ячейки по условию
Я
   Juliette_Juliette
 
23.09.20 - 09:11
ОбластьСтрока = Макет.ПолучитьОбласть("Строка");
Для Каждого СтрокаТЧ Из ЭтотОбъект.Объект.Сотрудники Цикл
   ОбластьСтрока.Параметры.Заполнить(СтрокаТЧ);
   Если СотрудникУволен(СтрокаТЧ.Сотрудник, Документ.Дата) Тогда
      НомерСтроки = 22 + НомПП;
      ТабДок.Область("R" + НомерСтроки+"C10:R" + НомерСтроки + "C10").Текст = "0,00";            
   КонецЕсли;
КонецЦикла;

получается ерунда, дикое смещение
по-умолчанию в ячейке "ЧДЦ=2, а надо при условии,что сотрудник уволен, вывести по формату "ЧН=0" (выводить 0)
в примере играла с текстом, все равно не то.
номер строки смещаем на 22 - это количество строк шапки отчета
   Ёпрст
 
1 - 23.09.20 - 09:50
(0) надо как то заставить себя отличать выведенную область в результирующий табличный документ и область макета, подготовленную к выводу в результирующий табличный документ
   Ёпрст
 
2 - 23.09.20 - 09:52
Если не поняла, то

//ТабДок.Область("R" + НомерСтроки+"C10:R" + НомерСтроки + "C10").Текст = "0,00";      

ОбластьСтрока...блаблабла установи формат там, потов ТабДок.Вывести(ОбластьСтрока)
   Juliette_Juliette
 
3 - 23.09.20 - 10:00
(2) вот это блабла и не понятно, пробовала по разному
ОбластьСтрока.Область(НомПП, 10, НомПП, 10).Текст = "0,00";            
делала и так
0,00 выходит, но добавляется новая пустая строка
   Juliette_Juliette
 
4 - 23.09.20 - 10:02
+
если последовательно увеличивается количество уволенных, но и количество пустых строк добавляется
   Ёпрст
 
5 - 23.09.20 - 10:05
(3) ОбластьСтрока.Область(1,10,1,10).
   Ёпрст
 
6 - 23.09.20 - 10:07
Ну  и Формат задавай..
   Ёпрст
 
7 - 23.09.20 - 10:07
Только потом верни Формат взад...
   Ёпрст
 
8 - 23.09.20 - 10:11
Если СотрудникУволен(СтрокаТЧ.Сотрудник, Документ.Дата) Тогда
           ОбластьСтрока.Область(1,10,1,10).Формат = "ЧН=0";
 Иначе
           ОбластьСтрока.Область(1,10,1,10).Формат = "ЧДЦ=2";

   КонецЕсли;
   Juliette_Juliette
 
9 - 23.09.20 - 10:11
(5) спасибо!
                Если СотрудникУволен(СтрокаТЧ.Сотрудник, Документ.Дата) Тогда
                    ОбластьСтрока.Область(1, 10, 1, 10).Формат = "ЧН=0";
                Иначе    
                    ОбластьСтрока.Область(1, 10, 1, 10).Формат = "ЧДЦ=2";
                КонецЕсли;

Список тем форума
Рекламное место пустует  Рекламное место пустует
Кaк может человек ожидaть, что его мольбaм о снисхождении ответит тот, кто превыше, когдa сaм он откaзывaет в милосердии тем, кто ниже его? Петр Трубецкой
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.