Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Заполнить доп сведение типа "Дополнительного значения"

Заполнить доп сведение типа "Дополнительного значения"
Я
   Sayan_mi
 
16.09.20 - 12:38
Простого типа доп сведение нормально заполнил.
ПВХ = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоРеквизиту("Заголовок", "Вид отчета");
    Если ЗначениеЗаполнено(ПВХ) Тогда
        МассивСтруктур.Добавить(Новый Структура("Свойство, Значение", ПВХ, ПараметрыОтчета.ВидОтчета));
    КонецЕсли;
    ПВХ = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоРеквизиту("Заголовок", "Дата формирования отчета");
    Если ЗначениеЗаполнено(ПВХ) Тогда
        МассивСтруктур.Добавить(Новый Структура("Свойство, Значение", ПВХ, ПараметрыОтчета.ДатаФормирования));
    КонецЕсли;
    
    Если НЕ МассивСтруктур.Количество() = 0 Тогда
        УправлениеСвойствами.ЗаписатьСвойстваУОбъекта(СпрОбъект.Ссылка, МассивСтруктур);
    КонецЕсли;
А вот как заполнить у объекта доп сведение если оно имеет тип "Дополнительное значение"?
Имеется в виду что "Вид отчета" имеет тип "Дополнительное значение" и принимает значение, в том числе, и то что в ПараметрыОтчета.ВидОтчета.
   polosov
 
1 - 16.09.20 - 12:49
(0) см. Справочник ЗначенияСвойствОбъектов
   Sayan_mi
 
2 - 16.09.20 - 12:54
Спасибо.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.