Вход | Регистрация
 

Вытянуть цену из справочника

Вытянуть цену из справочника
Я
   Mafiozaa
 
16.09.20 - 04:03
Приветствую,есть поле ввода в котором выбирается товар/услуга в номенклатуре,цена данного товара/услуги заложено в том же справочнике номенклатура
из созданного документа оказания услуг, мы выбираем то что нам нужно,но не переносится цена данного товара/услуги в чем ошибка
Процедура ВыбАвтоПриИзменении(Элемент)
    Справочник = Справочники.Автомобили;
    СуммаАвто = Справочник.Выбрать(Объект.ВыбАвто.Сумма); // Выбрали из справочника сумму того объекта что выбрал пользователь
    Объект.Сумма = СуммаАвто; // Вывели сумму
КонецПроцедуры
или я что то не так понимаю
   hhhh
 
1 - 16.09.20 - 04:14
(0) не так понимаете

Выбрать - это выборка элементов справочника из базы.

Ему абсолютно нас.рать на пользователя, что он там выбрал или ничего не выбрал.
   Mafiozaa
 
2 - 16.09.20 - 04:16
(1) Хорошо,переиграл на НайтиПоНаименованию,результат тот же,не выдает ничего
   hhhh
 
3 - 16.09.20 - 04:23
(2)

Процедура ВыбАвтоПриИзменении(Элемент)
    Объект.Сумма = ПолучитьСуммуНаСервере(Объект.ВыбАвто);// Вывели сумму

КонецПроцедуры 

&НаСервереБезКонтекста
Функция ПолучитьСуммуНаСервере(ПараметрВыбАвто)
    Возврат ПараметрВыбАвто.Сумма; 
КонецФункции
   Mafiozaa
 
4 - 16.09.20 - 04:26
(3)
Тоже мимо
   Chameleon1980
 
5 - 16.09.20 - 05:36
(0)ересь
   Chameleon1980
 
6 - 16.09.20 - 05:37
(4) должнл раблтать. что отладчик говорит?
   Mafiozaa
 
7 - 16.09.20 - 05:47
(6) (5)
Запускает без ошибок,и при выполнении события ничего не вскрикивает,но должного результата не выводит
   Chameleon1980
 
8 - 16.09.20 - 05:50
ну в отладчике то что показывает?
вот это, например
ПараметрВыбАвто.Сумма;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.