Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

УТ 11. Как на внешнюю ПФ добавить типовые команды редактирования и отправки по электронной

УТ 11. Как на внешнюю ПФ добавить типовые команды редактирования и отправки по электронной
Я
   buketovav
 
14.09.20 - 10:22
Добрый день, дорогий Форумчане!
Собственно вопрос в заголовке темы - УТ 11. Как на внешнюю ПФ добавить типовые команды редактирования и отправки по электронной?
Может кто-то уже что-то подобное делал или знает как делать и может подсказать.
Заранее всем благодарен за ответ.
Хорошего дня!
   PaulBC
 
1 - 15.09.20 - 03:08
Процедура Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
    
    Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "СчетНаОплату") Тогда
        СтруктураТипов = ОбщегоНазначенияУТ.СоответствиеМассивовПоТипамОбъектов(МассивОбъектов);
        УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(
            КоллекцияПечатныхФорм,
            "СчетНаОплату",
            НСтр("ru='Счет на оплату'"),
            СформироватьПечатнуюФормуСчетНаОплату(СтруктураТипов, ОбъектыПечати, ПараметрыПечати));
    КонецЕсли;

КонецПроцедуры

Функция СформироватьПечатнуюФормуСчетНаОплату(СтруктураТипов, ОбъектыПечати, ПараметрыПечати) Экспорт

    // Возвращает табличный документ


КонецФункции

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.