Вход | Регистрация
 

хочу чтоб когда выбираешь номенклатуру в реализации товара чтоб цена бралась из регистра с

хочу чтоб когда выбираешь номенклатуру в реализации товара чтоб цена бралась из регистра с
Я
   wolfacker
 
11.09.20 - 19:02
хочу чтоб когда выбираешь номенклатуру в реализации товара чтоб цена бралась из регистра сведений вот написал код может кто обьяснит почему он не работает
&НаКлиенте
Процедура НоменклатураТоварПриИзменении()
    ПолучитьРесурсИзРегистраНаСервере();
КонецПроцедуры

&НаСервере
Функция ПолучитьРесурсИзРегистраНаСервере()
    //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    ЦеныНоменклатуры.Номенклатура КАК Номенклатура,
        |    ЦеныНоменклатуры.Цена КАК Цена
        |ИЗ
        |    Документ.РеализацияТовара.Номенклатура КАК РеализацияТовараНоменклатура
        |        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЦеныНоменклатуры КАК ЦеныНоменклатуры
        |        ПО РеализацияТовараНоменклатура.Товар = ЦеныНоменклатуры.Номенклатура";
    
    РезультатЗапроса = Запрос.Выполнить();
    
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
    
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        // Вставить обработку выборки ВыборкаДетальныеЗаписи
    КонецЦикла;
    
    //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА


КонецФункции
   Dmitry1c
 
1 - 11.09.20 - 19:08
(0) потому что ты выбираешь данные запросом, но с выбираемыми данными ничего не делаешь

иными словами тебе официант принес меню, а ты ничего не заказал и спрашиваешь у нас, почему ты голодный
   RomanYS
 
2 - 11.09.20 - 19:09
(0) Потому что номенклатуру ты меняешь в форме, а запрос делаешь к базе данных.
   Dmitry1c
 
3 - 11.09.20 - 19:09
(0) у тебя есть и другие ошибки, если это задача практическая
   Сергиус
 
4 - 11.09.20 - 20:42
(0)Этим запросом ты получишь цены по всем товарам из всех реализаций в твоей базе.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.