Вход | Регистрация
 

одинаковая номенклатура введенная двумя строчками выводилась на печать тоже двумя строчка

одинаковая номенклатура введенная двумя строчками выводилась на печать тоже двумя строчка
Я
   Novaginn
 
11.09.20 - 14:23
Печатная форма  сделать чтобы одинаковая номенклатура введенная двумя строчками выводилась на печать тоже двумя строчками, а не складывалась в одну. ПФ писала не я, помогите разобраться,почему одинаковая номенклатура складывается.

Процедура ЗаполнитьТабличныйДокументМ11(ТабличныйДокумент, ДанныеДляПечати, ОбъектыПечати)
        
        ШаблонОшибкиТовары = НСтр("ru = 'В документе %1 отсутствуют товары. Печать М-11 не требуется'");
        
        ТоварКод = ФормированиеПечатныхФорм.ИмяДополнительнойКолонки();
        Если Не ЗначениеЗаполнено(ТоварКод) Тогда
            ТоварКод = "Код";
        КонецЕсли;
        
        //++ Изм. EssA 26.07.2018 11:03:28  получаем макет местный, поэтому другим способом
        Макет = ПолучитьМакет("ПФ_MXL_М11_ДрагМеталлы");
        //-- Изм. EssA 26.07.2018 11:03:28
        
        
        ПервыйДокумент = Истина;
        ВыборкаДокументы = ДанныеДляПечати.РезультатПоШапке.Выбрать();
        ВыборкаПоТабличнымЧастям = ДанныеДляПечати.РезультатПоТабличнойЧасти.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
        СтруктураОтбора = Новый Структура("Ссылка");
        
                
        Пока ВыборкаДокументы.Следующий() Цикл
            
            
            
            СтруктураОтбора.Ссылка = ВыборкаДокументы.Ссылка;
            ВыборкаПоТабличнымЧастям.Сбросить();
            Если НЕ ВыборкаПоТабличнымЧастям.НайтиСледующий(СтруктураОтбора) Тогда
                ОбщегоНазначенияКлиентСервер.СообщитьПользователю(
                СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(
                ШаблонОшибкиТовары,
                ВыборкаДокументы.Ссылка
                ),
                ВыборкаДокументы.Ссылка);
                Продолжить;
            КонецЕсли;
            
            НомерСтрокиНачало = ТабличныйДокумент.ВысотаТаблицы + 1;
            
            ВыборкаПоСкладам = ВыборкаПоТабличнымЧастям.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
            
            
            Пока ВыборкаПоСкладам.Следующий() Цикл
                
                
                //Если  ВыборкаДокументы.Ссылка.ТМЦ_Спирт = Истина Тогда  
                //    
                //    ОбластьШапкаЛимитки                             = Макет.ПолучитьОбласть("ШапкаЛимитки");
                //    ОбластьШапкаЛимитки.Параметры.Месяц             = Формат(ВыборкаДокументы[0].Дата,"Л=ru_RU; ДФ=ММММ");
                //    ОбластьШапкаЛимитки.Параметры.Год                 = Формат(ВыборкаДокументы[0].Дата,"Л=ru_RU; ДФ=ггг");
                //    ОбластьШапкаЛимитки.Параметры.Номер             = ВыборкаДокументы.Ссылка.Номер ;
                //    ОбластьШапкаЛимитки.Параметры.СкладПолучатель     = ВыборкаДокументы.Ссылка.СкладПолучатель.Код ;
                //    
                //    ОбластьШапкаЛимитки.Параметры.ЦенаЗаЛитр         = ВыборкаДокументы[0].Товары[0].Номенклатура.ТМЦ_Цена ;
                //    ОбластьШапкаЛимитки.Параметры.НомНомерВодный     = ВыборкаДокументы.Ссылка.ТМЦ_НоменклатураВодногоСпирта.Код ;
                //    ОбластьШапкаЛимитки.Параметры.НомНомерБезВодный = ВыборкаДокументы[0].Товары[0].Номенклатура.Код;
                //    ОбластьШапкаЛимитки.Параметры.Количество         = ВыборкаДокументы.Ссылка.ТМЦ_КоличествоВодногоСпирта ;
                //    ОбластьШапкаЛимитки.Параметры.КоличествоПрописью = ЧислоПрописью(ВыборкаДокументы.Ссылка.ТМЦ_КоличествоВодногоСпирта,"Л=ru_RU;ДП=Истина", "целая, целых, целых, ж, сотая, сотой, сотых, ж, 2") + " литра";
                //                    
                //    ТабличныйДокумент.Вывести(ОбластьШапкаЛимитки);
                //    
                //    
                //    
                //    ОбластьСтрокаЛимитки = Макет.ПолучитьОбласть("СтрокаЛимитки");
                //    ОбластьСтрокаЛимитки.Параметры.Дата             = Формат(ТекущаяДата(),"ДФ=dd.MM.yy");
                //    ОбластьСтрокаЛимитки.Параметры.Темпиратура         = ВыборкаДокументы.Ссылка.ТМЦ_ТемператураСпирта;
                //    ОбластьСтрокаЛимитки.Параметры.КоличествоЗаДень = ВыборкаДокументы.Ссылка.ТМЦ_КоличествоВодногоСпирта ;
                //    ОбластьСтрокаЛимитки.Параметры.Количество         = ВыборкаДокументы[0].Товары[0].Количество;
                //    ОбластьСтрокаЛимитки.Параметры.Процент             = ВыборкаДокументы.Ссылка.ТМЦ_ГрадусСпирта;
                //                    
                //    
                //    
                //    ТабличныйДокумент.Вывести(ОбластьСтрокаЛимитки);
                //    
                //    
                //    ОбластьПодвалЛимитки = Макет.ПолучитьОбласть("ПодвалЛимитки");
                //    ТабличныйДокумент.Вывести(ОбластьПодвалЛимитки);
                    
                    
                    
                    
                //Иначе    

                
                //++ Изм. EssA 26.07.2018 11:11:29  формируем ТЗ с драгметаллами, присутствующими в ТЧ Товары в данном документе
                ТЗ = Новый ТаблицаЗначений;
                ТЗ.Колонки.Добавить("ДрагоценныйМатериал");
                ТЗ.Колонки.Добавить("Норма");
                ТЗ.Колонки.Добавить("Серия");
                ТЗ.Колонки.Добавить("Количество");
                ТЗ.Колонки.Добавить("Номенклатура");
                
                Если ТипЗнч(ВыборкаДокументы.Ссылка) = Тип("ДокументСсылка.ВнутреннееПотреблениеТоваров") Тогда
                    Запрос = Новый Запрос;
                    Запрос.Текст =
                    //"ВЫБРАТЬ
                    //    |    ВнутреннееПотреблениеТоваровТовары.Номенклатура КАК Номенклатура,
                    //    |    ВнутреннееПотреблениеТоваровТовары.Количество КАК Количество,
                    //    |    НоменклатураДрагоценныеМатериалы.ДрагоценныйМатериал КАК ДрагоценныйМатериал,
                    //    |    ВнутреннееПотреблениеТоваровТовары.Серия.Номер КАК СерияНомер
                    //    |ПОМЕСТИТЬ ВТ
                    //    |ИЗ
                    //    |    Справочник.Номенклатура.ДрагоценныеМатериалы КАК НоменклатураДрагоценныеМатериалы
                    //    |        ВНУТРЕННЕЕ СОЕДИНЕНИЕ Документ.ВнутреннееПотреблениеТоваров.Товары КАК ВнутреннееПотреблениеТоваровТовары
                    //    |        ПО НоменклатураДрагоценныеМатериалы.Ссылка = ВнутреннееПотреблениеТоваровТовары.Номенклатура
                    //    |ГДЕ
                    //    |    ВнутреннееПотреблениеТоваровТовары.Ссылка = &Ссылка
                    //    |;
                    //    |
                    //    |////////////////////////////////////////////////////////////////////////////////
                    //    |ВЫБРАТЬ
                    //    |    ВТ.Номенклатура КАК Номенклатура,
                    //    |    ВТ.Количество КАК Количество,
                    //    |    ВТ.ДрагоценныйМатериал КАК ДрагоценныйМатериал,
                    //    |    ВнутреннееПотреблениеТоваровис_ДрагМеталлы.Норма КАК Норма,
                    //    |    ВнутреннееПотреблениеТоваровис_ДрагМеталлы.Серия.Номер КАК Серия
                    //    |ИЗ
                    //    |    ВТ КАК ВТ
                    //    |        ЛЕВОЕ СОЕДИНЕНИЕ Документ.ВнутреннееПотреблениеТоваров.ис_ДрагМеталлы КАК ВнутреннееПотреблениеТоваровис_ДрагМеталлы
                    //    |        ПО ВТ.Номенклатура = ВнутреннееПотреблениеТоваровис_ДрагМеталлы.Номенклатура
                    //    |            И ВТ.Количество = ВнутреннееПотреблениеТоваровис_ДрагМеталлы.Количество
                    //    |            И ВТ.ДрагоценныйМатериал = ВнутреннееПотреблениеТоваровис_ДрагМеталлы.ДрагоценныйМатериал
                    //    |ГДЕ
                    //    |    ВнутреннееПотреблениеТоваровис_ДрагМеталлы.Ссылка = &Ссылка";
                    "ВЫБРАТЬ
                    |    ВнутреннееПотреблениеТоваровТовары.Номенклатура КАК Номенклатура,
                    |    ВнутреннееПотреблениеТоваровТовары.Номенклатура.ТМЦ_ШПЗ КАК ШПЗ,
                    |    ВнутреннееПотреблениеТоваровТовары.Номенклатура.ТМЦ_Изделие КАК Изделие,
                    |    ВнутреннееПотреблениеТоваровТовары.Количество КАК Количество,
                    |    ВнутреннееПотреблениеТоваровТовары.Серия.Номер КАК СерияНомер
                    |ПОМЕСТИТЬ ВТ
                    |ИЗ
                    |    Документ.ВнутреннееПотреблениеТоваров.Товары КАК ВнутреннееПотреблениеТоваровТовары
                    |ГДЕ
                    |    ВнутреннееПотреблениеТоваровТовары.Ссылка = &Ссылка
                    |;
                    |
                    |////////////////////////////////////////////////////////////////////////////////
                    |ВЫБРАТЬ
                    |    ВТ.Номенклатура КАК Номенклатура,
                    |    ВТ.ШПЗ КАК ШПЗ,
                    |    ВТ.Изделие КАК Изделие,
                    |    ВТ.Количество КАК Количество
                    |ИЗ
                    |    ВТ КАК ВТ";
                Иначе
                    Запрос = Новый Запрос;
                    Запрос.Текст =
                    "ВЫБРАТЬ
                    |    ПеремещениеТоваровТовары.Номенклатура КАК Номенклатура,
                    |    ПеремещениеТоваровТовары.Номенклатура.ТМЦ_ШПЗ КАК ШПЗ,
                    |    ПеремещениеТоваровТовары.Номенклатура.ТМЦ_Изделие КАК Изделие,
                    |    ПеремещениеТоваровТовары.Количество КАК Количество,
                    |    ПеремещениеТоваровТовары.Серия.Номер КАК СерияНомер,
                    |    ПеремещениеТоваровТовары.КодСтроки КАК КодСтроки
                    |ПОМЕСТИТЬ ВТ
                    |ИЗ
                    |    Документ.ПеремещениеТоваров.Товары КАК ПеремещениеТоваровТовары
                    |ГДЕ
                    |    ПеремещениеТоваровТовары.Ссылка = &Ссылка
                    |;
                    |
                    |////////////////////////////////////////////////////////////////////////////////
                    |ВЫБРАТЬ
                    |    ВТ.Номенклатура КАК Номенклатура,
                    |    ВТ.ШПЗ КАК ШПЗ,
                    |    ВТ.Изделие КАК Изделие,
                    |    ВТ.Количество КАК Количество,
                    |    ВТ.КодСтроки КАК КодСтроки
                    |ИЗ
                    |    ВТ КАК ВТ";
                КонецЕсли;
                
                Запрос.УстановитьПараметр("Ссылка", ВыборкаДокументы.Ссылка);
                ТЗ = Запрос.Выполнить().Выгрузить();
                
                
                //-- Изм. EssA 26.07.2018 11:11:29
                
                Если Не ПервыйДокумент Тогда
                    ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
                КонецЕсли;
                ПервыйДокумент = Ложь;
                НомерСтраницы   = 1;
                НомерСтроки = 0;
                
                // Создаем массив для проверки вывода
                МассивВыводимыхОбластей = Новый Массив;
                
                ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
                
                //Вывод шапки.
                ОбластьШапка = Макет.ПолучитьОбласть("Шапка");
                //ШтрихкодированиеПечатныхФорм.ВывестиШтрихкодВТабличныйДокумент(ТабличныйДокумент, Макет, ОбластьШапка, ВыборкаДокументы.Ссылка);
                ОбластьШапка.Параметры.Заголовок = НСтр("ru = 'ТРЕБОВАНИЕ-НАКЛАДНАЯ №'") + ПрефиксацияОбъектовКлиентСервер.НомерНаПечать(ВыборкаДокументы.Номер, Истина, Истина);
                ОбластьШапка.Параметры.Заполнить(ВыборкаДокументы);
                ОбластьШапка.Параметры.Заполнить(ВыборкаПоСкладам);
                Если ЗначениеЗаполнено(ВыборкаДокументы.ТМЦ_Получатель)  Тогда
                     ОбластьШапка.Параметры.ПредставлениеПодразделения = ВыборкаДокументы.ТМЦ_Получатель;
                Иначе
                    ОбластьШапка.Параметры.ПредставлениеПодразделения = ВыборкаДокументы.Подразделение;
                КонецЕсли;
                                
                СведенияОбОрганизации = ФормированиеПечатныхФорм.СведенияОЮрФизЛице(ВыборкаДокументы.Организация, ВыборкаДокументы.ДатаДокумента);
                ОбластьШапка.Параметры.ПредставлениеОрганизации = ФормированиеПечатныхФорм.ОписаниеОрганизации(СведенияОбОрганизации);
                ОбластьШапка.Параметры.КодОКПО = СведенияОбОрганизации.КодПоОКПО;
                
                //ЛАП
                ДолжностьРазрешил = Справочники.Пользователи.НайтиПоНаименованию(ПользователиИнформационнойБазы.ТекущийПользователь()).ФО_Должность;
                ФИОСИнициаламиРазрешил = ФизическиеЛицаКлиентСервер.ФамилияИнициалы(ПользователиИнформационнойБазы.ТекущийПользователь().ПолноеИмя);
                //ОбластьШапка.Параметры.Разрешил = " " + ДолжностьРазрешил + " / " + ФИОСИнициаламиРазрешил;
                ОбластьШапка.Параметры.НомерФормы = "Модифицированная форма АО """"НПП """"Исток"""" им.Шокина"""" на основе" + Символы.ПС + "формы № М-11, утвержденной постановлением Госкомстата России" + Символы.ПС + "от 30.10.97г. № 71а";
                ОбластьШапка.Параметры.ШПЗ = Лев(ВыборкаДокументы.Ссылка.ТМЦ_ШПЗ.Наименование, 9);
                ОбластьШапка.Параметры.Изделие = ВыборкаДокументы.Ссылка.ТМЦ_Изделие;
                ДолжностьУтвердил = "Начальник отдела";
                ФИОСИнициаламиНачальникУтвердил = ФизическиеЛицаКлиентСервер.ФамилияИнициалы(ВыборкаДокументы.Ссылка.Подразделение.ТекущийРуководитель);
                //ОбластьШапка.Параметры.Утвердил = " " + ДолжностьУтвердил + " / " + ФИОСИнициаламиНачальникУтвердил;
                
                //ЛАП
                ВыборкаПоСтрокам = ВыборкаПоСкладам.Выбрать();
                ТабличныйДокумент.Вывести(ОбластьШапка);
                
                //Если ВыборкаДокументы.Ссылка.ТМЦ_Комплектация = Истина Тогда
                //    Область = Макет.ПолучитьОбласть("Строка");
                //    Область.Параметры.НоменклатурныйНомер = Формат(ВыборкаДокументы.Ссылка.ТМЦ_НоменклатурныйНомерКомплектации,"ЧГ=0" );
                //    Область.Параметры.МатериалНаименование = ВыборкаДокументы.Ссылка.ТМЦ_НоменклатураКомплектации;
                //    Область.Параметры.Количество = "1";
                //    Область.Параметры.КоличествоОтпущено = "1";
                //    Область.Параметры.Счет = ВыборкаДокументы.Ссылка.ТМЦ_БалансовыйСчетКомплектации;
                //    Область.Параметры.Цена =  ВыборкаДокументы.Ссылка.ТМЦ_ЦенаКомплектации;
                //    Область.Параметры.ЕдиницаИзмеренияКод = "796";
                //    Область.Параметры.ЕдиницаИзмеренияНаименование = "ШТ";
                //    
                //                        
                //    ТабличныйДокумент.Вывести(Область);
                ////    
                //    ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
                //    ОбластьПодвал.Параметры.ДолжностьОтправителя = ВыборкаПоСкладам.ДолжностьКладовщикаОтправителя;
                //            ОбластьПодвал.Параметры.ФИООтправителя = ФизическиеЛицаКлиентСервер.ФамилияИнициалы(ВыборкаПоСкладам.КладовщикОтправитель);
                //            
                //            //++ Изм. EssA 20.11.2018 14:26:23  добавление штрих-кода    
                //            Запрос = Новый Запрос;
                //            Запрос.Текст =
                //            "ВЫБРАТЬ
                //            |    ФО_СоответствиеОбъектов.ИдентификаторИсточника КАК ДопПараметр
                //            |ИЗ
                //            |    РегистрСведений.ФО_СоответствиеОбъектов КАК ФО_СоответствиеОбъектов
                //            |ГДЕ
                //            |    ФО_СоответствиеОбъектов.СсылкаПриемник = &СсылкаПриемник
                //            |    И ФО_СоответствиеОбъектов.ИмяТаблицыИсточника = &ИмяТаблицыИсточника";
                //            
                //            Запрос.УстановитьПараметр("СсылкаПриемник", ВыборкаДокументы.Ссылка);
                //            Запрос.УстановитьПараметр("ИмяТаблицыИсточника", "PrintInfos");
                //            
                //            РезультатЗапроса = Запрос.Выполнить();
                //            ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
                //            ВыборкаДетальныеЗаписи.Следующий();
                //            //ШК = Формат(ВыборкаДетальныеЗаписи.ДопПараметр, "ЧРГ=''; ЧГ=0");
                //            ШК = СтрЗаменить(ВыборкаДетальныеЗаписи.ДопПараметр, " ", "");  //" " В СКОБОЧКАХ СИМВОЛ НЕ ПРОБЕЛ
                //            
                //            ДлинаШК = СтрДлина(ШК);
                //            Если ДлинаШК < 11 Тогда
                //                Для к = 1 По 11 - ДлинаШК Цикл
                //                    ШК = "0" + ШК;
                //                КонецЦикла;
                //            КонецЕсли;
                //            
                //            
                //            ПараметрыШтрихкода = Новый Структура;
                //            ПараметрыШтрихкода.Вставить("Ширина",          200);
                //            ПараметрыШтрихкода.Вставить("Высота",          75);
                //            ПараметрыШтрихкода.Вставить("Штрихкод",        ШК);
                //            ПараметрыШтрихкода.Вставить("ТипКода",         4); // 1 - EAN13, 4 - Code128, 3 - Code39, 2 - EAN-128, 13 - CodaBar
                //            ПараметрыШтрихкода.Вставить("ОтображатьТекст", Истина);
                //            ПараметрыШтрихкода.Вставить("РазмерШрифта",    12);
                //            
                //            ШтрихкодированиеПечатныхФорм.ВывестиШтрихкодВТабличныйДокумент(ТабличныйДокумент, Макет, ОбластьПодвал, ВыборкаДокументы.Ссылка);
                //            ОбластьПодвал.Рисунки.Штрих.Картинка = МенеджерОборудованияВызовСервера.ПолучитьКартинкуШтрихкода(ПараметрыШтрихкода);
                //            
                //            //-- Изм. EssA 20.11.2018 14:26:23
                //            
                //            ОбластьПодвал.Параметры.Страница = "Страница №" + НомерСтраницы;;
                //            НомерСтраницы = НомерСтраницы + 1;
                //    
                //    
                //    
                //    
                //    
                //    ТабличныйДокумент.Вывести(ОбластьПодвал);
                //    
                //    
                //    ОбластьШапкаКомплектации = Макет.ПолучитьОбласть("ШапкаКомплектации") ;
                //    ОбластьШапкаКомплектации.Параметры.ТМЦ_НоменклатурныйНомерКомплектации = Число(ВыборкаДокументы.Ссылка.ТМЦ_НоменклатурныйНомерКомплектации);
                //    ОбластьШапкаКомплектации.Параметры.ТМЦ_НоменклатураКомплектации = ВыборкаДокументы.Ссылка.ТМЦ_НоменклатураКомплектации;
                //    ОбластьШапкаКомплектации.Параметры.ТМЦ_БалансовыйСчетКомплектации = ВыборкаДокументы.Ссылка.ТМЦ_БалансовыйСчетКомплектации;
                //    ОбластьШапкаКомплектации.Параметры.Дата = Формат(ВыборкаДокументы.Ссылка.Дата,"ДФ=dd.MM.yyyy");
                //    ОбластьШапкаКомплектации.Параметры.Номер = ПрефиксацияОбъектовКлиентСервер.НомерНаПечать(ВыборкаДокументы.Ссылка.Номер);

                //    ТабличныйДокумент.Вывести(ОбластьШапкаКомплектации);                            
                //    
                //    ВыборкаПоСтрокам.Сбросить();
                //    ИтогСумма =0;
                //    Пока ВыборкаПоСтрокам.Следующий() Цикл
                //        
                //        ОбластьСтрокаКомплектации = Макет.ПолучитьОбласть("СтрокаКомплектации") ;
                //        
                //        Если ТоварКод = "Артикул" Тогда
                //            ОбластьСтрокаКомплектации.Параметры.НоменклатурныйНомер = ВыборкаПоСтрокам.НоменклатурныйНомерАртикул;
                //        Иначе
                //            ОбластьСтрокаКомплектации.Параметры.НоменклатурныйНомер = ВыборкаПоСтрокам.НоменклатурныйНомерКод;
                //        КонецЕсли;
                //        ОбластьСтрокаКомплектации.Параметры.МатериалНаименование = НоменклатураКлиентСервер.ПредставлениеНоменклатурыДляПечати(
                //        СокрЛП(ВыборкаПоСтрокам.НоменклатураНаименование),
                //        СокрЛП(ВыборкаПоСтрокам.Характеристика));
                //        ОбластьСтрокаКомплектации.Параметры.Количество = ВыборкаПоСтрокам.Количество;    
                //        ОбластьСтрокаКомплектации.Параметры.Счет = ВыборкаПоСтрокам.Номенклатура.ВидНоменклатуры.СчетУчета;
                //        ОбластьСтрокаКомплектации.Параметры.Цена = ВыборкаПоСтрокам.Номенклатура.ТМЦ_Цена;
                //        ТекСумма = ВыборкаПоСтрокам.Номенклатура.ТМЦ_Цена * ВыборкаПоСтрокам.Количество;
                //        ОбластьСтрокаКомплектации.Параметры.Сумма = ТекСумма;
                //        ИтогСумма = ИтогСумма + ТекСумма;
                //        ТабличныйДокумент.Вывести(ОбластьСтрокаКомплектации);
                //    КонецЦикла;
                //    
                //    ОбластьПодвалКомплектации = Макет.ПолучитьОбласть("ПодвалКомплектации") ;
                //    
                //    ОбластьПодвалКомплектации.Параметры.Результат =   ИтогСумма;
                //    ОбластьПодвалКомплектации.Параметры.УтвердилДолжность = ДолжностьУтвердил;
                //    ОбластьПодвалКомплектации.Параметры.НачальникУтвердил = ФИОСИнициаламиНачальникУтвердил;
                //    ОбластьПодвалКомплектации.Параметры.ФИОПринялМОЛ = ВыборкаДокументы.Ссылка.СкладПолучатель.ТекущийОтветственный;
                //    ОбластьПодвалКомплектации.Параметры.ДолжностьПринялМОЛ = ВыборкаДокументы.Ссылка.СкладПолучатель.ТекущаяДолжностьОтветственного;
                //    ТабличныйДокумент.Вывести(ОбластьПодвалКомплектации);
                //    
                //    
                //    
                //    
                //Иначе
                //    
                    
                    
                    ВыборкаПоСтрокам = ВыборкаПоСкладам.Выбрать();
                    
                    КоличествоСтрок = ВыборкаПоСтрокам.Количество();
                    Счетчик = 0;
                    Пока ВыборкаПоСтрокам.Следующий() Цикл
                                                                    
                        Счетчик = Счетчик +1;
                        
                        Область = Макет.ПолучитьОбласть("Строка");
                        Область.Параметры.Заполнить(ВыборкаПоСтрокам);
                        Область.Параметры.КодСтроки = Счетчик;
                        
                        НомерСтроки = НомерСтроки + 1;
                        
                        МассивВыводимыхОбластей.Очистить();
                        МассивВыводимыхОбластей.Добавить(Область);
                        
                        Если НомерСтроки = КоличествоСтрок Тогда
                            МассивВыводимыхОбластей.Добавить(ОбластьПодвал);
                        КонецЕсли;
                        
                        Если ТоварКод = "Артикул" Тогда
                            Область.Параметры.НоменклатурныйНомер = ВыборкаПоСтрокам.НоменклатурныйНомерАртикул;
                        Иначе
                            Область.Параметры.НоменклатурныйНомер = ВыборкаПоСтрокам.НоменклатурныйНомерКод;
                        КонецЕсли;
                        
                        //++ Изм. EssA 26.07.2018  заполнить добавленный в макет параметр "Счёт учёта". изм 30.10 - если это перемещение товаров, то заполняем стандартный параметр Счет(слева на макете, а не справа)
                        Если ТипЗнч(ВыборкаДокументы.Ссылка) = ТИП("ДокументСсылка.ПеремещениеТоваров") Тогда
                            
                            Область.Параметры.Счет = ВыборкаПоСтрокам.Номенклатура.ВидНоменклатуры.СчетУчета;
                            
                            
                            Запрос = Новый Запрос;
                            Запрос.Текст =
                            "ВЫБРАТЬ
                            |    ПеремещениеТоваровСерии.Серия КАК Серия
                            |ИЗ
                            |    Документ.ПеремещениеТоваров.Товары КАК ПеремещениеТоваровТовары
                            |        ЛЕВОЕ СОЕДИНЕНИЕ Документ.ПеремещениеТоваров.Серии КАК ПеремещениеТоваровСерии
                            |        ПО ПеремещениеТоваровТовары.Ссылка = ПеремещениеТоваровСерии.Ссылка
                            |            И ПеремещениеТоваровТовары.Номенклатура = ПеремещениеТоваровСерии.Номенклатура
                            |            И ПеремещениеТоваровТовары.Назначение = ПеремещениеТоваровСерии.Назначение
                            |            И ПеремещениеТоваровТовары.НазначениеОтправителя = ПеремещениеТоваровСерии.НазначениеОтправителя
                            |            И ПеремещениеТоваровТовары.Характеристика = ПеремещениеТоваровСерии.Характеристика
                            |            И ПеремещениеТоваровТовары.Количество = ПеремещениеТоваровСерии.Количество
                            |ГДЕ
                            |    ПеремещениеТоваровСерии.Номенклатура = &Номенклатура
                            |    И ПеремещениеТоваровСерии.Ссылка = &Ссылка";
                            
                            Запрос.УстановитьПараметр("Номенклатура", ВыборкаПоСтрокам.Номенклатура);
                            Запрос.УстановитьПараметр("Ссылка", ВыборкаДокументы.Ссылка);
                            РезультатЗапроса = Запрос.Выполнить();    
                            ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();    
                            ВыборкаДетальныеЗаписи.Следующий();
                            Область.Параметры.НоменклатурныйНомер = ВыборкаДетальныеЗаписи.Серия;
                            
                        Иначе
                            
                            Область.Параметры.СчётУчёта = ВыборкаПоСтрокам.Номенклатура.ВидНоменклатуры.СчетУчета;
                            
                        КонецЕсли;
                        
                        //Начало изменений ЛАП
                        //Область.Параметры.КодСтроки         = ВыборкаПоСтрокам.Товары.КодСтроки;
                        Область.Параметры.НоменклатурныйНомер     = Формат(ВыборкаПоСтрокам.Номенклатура.ТМЦ_НомНомер, "ЧГ=0");
                        Область.Параметры.Цена                    = ВыборкаПоСтрокам.Номенклатура.ТМЦ_Цена;
                        Область.Параметры.Сумма                    = ВыборкаПоСтрокам.Номенклатура.ТМЦ_Цена * Область.Параметры.Количество;
                        //Область.Параметры.ШПЗ = ВыборкаПоСтрокам.Номенклатура.ТМЦ_ШПЗ.Код;
                        //Начало изменений ЛАП 2020.02.04
                        Если Число(ОбластьШапка.Параметры.Склад.Код) = 6060
                            ИЛИ  Число(ОбластьШапка.Параметры.Склад.Код) = 6010
                            ИЛИ  Число(ОбластьШапка.Параметры.Склад.Код) = 6020
                            ИЛИ  Число(ОбластьШапка.Параметры.Склад.Код) = 6030
                            ИЛИ  Число(ОбластьШапка.Параметры.Склад.Код) = 6040
                            ИЛИ  Число(ОбластьШапка.Параметры.Склад.Код) = 6050
                            ИЛИ  Число(ОбластьШапка.Параметры.Склад.Код) = 6300
                            ИЛИ  Число(ОбластьШапка.Параметры.Склад.Код) = 6070
                            ИЛИ  Число(ОбластьШапка.Параметры.Склад.Код) = 6240
                            ИЛИ  Число(ОбластьШапка.Параметры.Склад.Код) = 6090
                            ИЛИ  Число(ОбластьШапка.Параметры.Склад.Код) = 6110
                            ИЛИ  Число(ОбластьШапка.Параметры.Склад.Код) = 6130
                            ИЛИ  Число(ОбластьШапка.Параметры.Склад.Код) = 6140
                            ИЛИ  Число(ОбластьШапка.Параметры.Склад.Код) = 6070
                            Тогда
                            Область.Параметры.КоличествоОтпущено = "";
                        Иначе
                            Область.Параметры.КоличествоОтпущено = Область.Параметры.Количество;
                        КонецЕсли;
                        //Конец Изменений ЛАП 2020.02.04
                        //Конец изменений ЛАП
                        
                        //-- Изм. EssA 26.07.2018 9:46:41
                        
                        Область.Параметры.МатериалНаименование = НоменклатураКлиентСервер.ПредставлениеНоменклатурыДляПечати(
                        СокрЛП(ВыборкаПоСтрокам.НоменклатураНаименование),
                        СокрЛП(ВыборкаПоСтрокам.Характеристика));
                        
                        //Если НЕ ТабличныйДокумент.ПроверитьВывод(МассивВыводимыхОбластей) Тогда
                        //    НомерСтраницы = НомерСтраницы + 1;
                        //    ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
                        //    УстановитьПараметр(ОбластьШапка, "НомерСтраницы", "Страница " + НомерСтраницы);
                        //    ТабличныйДокумент.Вывести(ОбластьШапка);
                        //КонецЕсли;
                        
                        ТабличныйДокумент.Вывести(Область);
                        
                        
                        //Начало изменений ЛАП 2019.11.27
                        Если ВыборкаПоСтрокам.Номенклатура.ДрагоценныеМатериалы.Количество() > 0 Тогда
                            Для каждого Стр Из ВыборкаПоСтрокам.Номенклатура.ДрагоценныеМатериалы Цикл                        
                                ОбластьМеталл = Макет.ПолучитьОбласть("СтрокаДрагМеталл");
                                ОбластьМеталл.Параметры.ДрагМеталл = Стр.ДрагоценныйМатериал;
                                ОбластьМеталл.Параметры.Норма = "в количестве " + Стр.Количество + " на одну еденицу " + ВыборкаПоСтрокам.Номенклатура.ЕдиницаИзмерения;
                                //ОбластьМеталл.Параметры.Норма = ис_ПолучитьНормуДляТекущейСтроки(ВыборкаДокументы.ис_ДрагМеталлы, Стр.Номенклатура, Стр.Количество, Стр.ДрагоценныйМатериал, Стр.Серия);
                                ТабличныйДокумент.Вывести(ОбластьМеталл);                        
                            КонецЦикла;                                                                
                        КонецЕсли;
                        //Конец изменений ЛАП 2019.11.27
                        
                        
                        //++ Изм. EssA 23.07.2018 11:54:00  заполнение строки, если в номенклатуре присутствует драгметалл
                        //ОтборДрагМ = Новый Структура;
                        //ОтборДрагМ.Вставить("Номенклатура", ВыборкаПоСтрокам.Номенклатура);
                        //ОтборДрагМ.Вставить("Количество", ВыборкаПоСтрокам.Количество);
                        //СтрокиСДрагМет = ТЗ.НайтиСтроки(ОтборДрагМ);
                        //// подразумевается, что в одной накладной может быть одна строка с одной и той же номенклатурой и одним и тем же её количеством
                        //
                        //Для каждого Стр Из СтрокиСДрагМет Цикл                        
                        //    ОбластьМеталл = Макет.ПолучитьОбласть("СтрокаДрагМеталл");
                        //    ОбластьМеталл.Параметры.ДрагМеталл = Стр.ДрагоценныйМатериал;
                        //    ОбластьМеталл.Параметры.Норма = Стр.Норма;
                        //    //ОбластьМеталл.Параметры.Норма = ис_ПолучитьНормуДляТекущейСтроки(ВыборкаДокументы.ис_ДрагМеталлы, Стр.Номенклатура, Стр.Количество, Стр.ДрагоценныйМатериал, Стр.Серия);
                        //    ТабличныйДокумент.Вывести(ОбластьМеталл);                        
                        //КонецЦикла;
                        //-- Изм. EssA 23.07.2018 11:54:00
                        вп=0;
                        Если НомерСтроки = 12 или НомерСтроки = 24 или НомерСтроки = 36 или НомерСтроки = 48 или НомерСтроки = 60 или НомерСтроки = 72 или НомерСтроки = 84 или
                            НомерСтроки = 96 или НомерСтроки = 108 или НомерСтроки = 120 или НомерСтроки = 132 или НомерСтроки = 144 или НомерСтроки = 156 или НомерСтроки = 168
                            или НомерСтроки = 180 или НомерСтроки = 192 или НомерСтроки = 204 или НомерСтроки = 216 или НомерСтроки = 228 или НомерСтроки = 240 или НомерСтроки = 252
                            или НомерСтроки = 264 или НомерСтроки = 276 или НомерСтроки = 288 или НомерСтроки = 300 Тогда
                            вп=1;
                            
                            
                            ОбластьПодвал.Параметры.ДолжностьОтправителя = ВыборкаПоСкладам.ДолжностьКладовщикаОтправителя;
                            ОбластьПодвал.Параметры.ФИООтправителя = ФизическиеЛицаКлиентСервер.ФамилияИнициалы(ВыборкаПоСкладам.КладовщикОтправитель);
                            
                            //++ Изм. EssA 20.11.2018 14:26:23  добавление штрих-кода    
                            Запрос = Новый Запрос;
                            Запрос.Текст =
                            "ВЫБРАТЬ
                            |    ФО_СоответствиеОбъектов.ИдентификаторИсточника КАК ДопПараметр
                            |ИЗ
                            |    РегистрСведений.ФО_СоответствиеОбъектов КАК ФО_СоответствиеОбъектов
                            |ГДЕ
                            |    ФО_СоответствиеОбъектов.СсылкаПриемник = &СсылкаПриемник
                            |    И ФО_СоответствиеОбъектов.ИмяТаблицыИсточника = &ИмяТаблицыИсточника";
                            
                            Запрос.УстановитьПараметр("СсылкаПриемник", ВыборкаДокументы.Ссылка);
                            Запрос.УстановитьПараметр("ИмяТаблицыИсточника", "PrintInfos");
                            
                            РезультатЗапроса = Запрос.Выполнить();
                            ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
                            ВыборкаДетальныеЗаписи.Следующий();
                            //ШК = Формат(ВыборкаДетальныеЗаписи.ДопПараметр, "ЧРГ=''; ЧГ=0");
                            ШК = СтрЗаменить(ВыборкаДетальныеЗаписи.ДопПараметр, " ", "");  //" " В СКОБОЧКАХ СИМВОЛ НЕ ПРОБЕЛ
                            
                            ДлинаШК = СтрДлина(ШК);
                            Если ДлинаШК < 11 Тогда
                                Для к = 1 По 11 - ДлинаШК Цикл
                                    ШК = "0" + ШК;
                                КонецЦикла;
                            КонецЕсли;
                            
                            
                            ПараметрыШтрихкода = Новый Структура;
                            ПараметрыШтрихкода.Вставить("Ширина",          200);
                            ПараметрыШтрихкода.Вставить("Высота",          75);
                            ПараметрыШтрихкода.Вставить("Штрихкод",        ШК);
                            ПараметрыШтрихкода.Вставить("ТипКода",         4); // 1 - EAN13, 4 - Code128, 3 - Code39, 2 - EAN-128, 13 - CodaBar
                            ПараметрыШтрихкода.Вставить("ОтображатьТекст", Истина);
                            ПараметрыШтрихкода.Вставить("РазмерШрифта",    12);
                            
                            ШтрихкодированиеПечатныхФорм.ВывестиШтрихкодВТабличныйДокумент(ТабличныйДокумент, Макет, ОбластьПодвал, ВыборкаДокументы.Ссылка);
                            ОбластьПодвал.Рисунки.Штрих.Картинка = МенеджерОборудованияВызовСервера.ПолучитьКартинкуШтрихкода(ПараметрыШтрихкода);
                            
                            //-- Изм. EssA 20.11.2018 14:26:23
                            
                            ОбластьПодвал.Параметры.Страница = "Страница №" + НомерСтраницы;;
                            НомерСтраницы = НомерСтраницы + 1;
                            
                            
                            
                            ТабличныйДокумент.Вывести(ОбластьПодвал);
                            ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
                            ТабличныйДокумент.Вывести(ОбластьШапка);
                            
                        КонецЕсли;
                    КонецЦикла;
                //КонецЕсли;
                // Вывод подвала.
                Если вп=0 Тогда
                    ОбластьПодвал.Параметры.ДолжностьОтправителя = ВыборкаПоСкладам.ДолжностьКладовщикаОтправителя;
                    ОбластьПодвал.Параметры.ФИООтправителя = ФизическиеЛицаКлиентСервер.ФамилияИнициалы(ВыборкаПоСкладам.КладовщикОтправитель);
                    
                    //++ Изм. EssA 20.11.2018 14:26:23  добавление штрих-кода    
                    Запрос = Новый Запрос;
                    Запрос.Текст =
                    "ВЫБРАТЬ
                    |    ФО_СоответствиеОбъектов.ИдентификаторИсточника КАК ДопПараметр
                    |ИЗ
                    |    РегистрСведений.ФО_СоответствиеОбъектов КАК ФО_СоответствиеОбъектов
                    |ГДЕ
                    |    ФО_СоответствиеОбъектов.СсылкаПриемник = &СсылкаПриемник
                    |    И ФО_СоответствиеОбъектов.ИмяТаблицыИсточника = &ИмяТаблицыИсточника";
                    
                    Запрос.УстановитьПараметр("СсылкаПриемник", ВыборкаДокументы.Ссылка);
                    Запрос.УстановитьПараметр("ИмяТаблицыИсточника", "PrintInfos");
                    
                    РезультатЗапроса = Запрос.Выполнить();
                    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
                    ВыборкаДетальныеЗаписи.Следующий();
                    //ШК = Формат(ВыборкаДетальныеЗаписи.ДопПараметр, "ЧРГ=''; ЧГ=0");
                    ШК = СтрЗаменить(ВыборкаДетальныеЗаписи.ДопПараметр, " ", "");  //" " В СКОБОЧКАХ СИМВОЛ НЕ ПРОБЕЛ
                    
                    ДлинаШК = СтрДлина(ШК);
                    Если ДлинаШК < 11 Тогда
                        Для к = 1 По 11 - ДлинаШК Цикл
                            ШК = "0" + ШК;
                        КонецЦикла;
                    КонецЕсли;
                    
                    
                    ПараметрыШтрихкода = Новый Структура;
                    ПараметрыШтрихкода.Вставить("Ширина",          300);
                    ПараметрыШтрихкода.Вставить("Высота",          100);
                    ПараметрыШтрихкода.Вставить("Штрихкод",        ШК);
                    ПараметрыШтрихкода.Вставить("ТипКода",         4); // 1 - EAN13, 4 - Code128, 3 - Code39, 2 - EAN-128, 13 - CodaBar
                    ПараметрыШтрихкода.Вставить("ОтображатьТекст", Истина);
                    ПараметрыШтрихкода.Вставить("РазмерШрифта",    18);
                    
                    ШтрихкодированиеПечатныхФорм.ВывестиШтрихкодВТабличныйДокумент(ТабличныйДокумент, Макет, ОбластьПодвал, ВыборкаДокументы.Ссылка);
                    ОбластьПодвал.Параметры.Страница = "Страница № " + НомерСтраницы;

                    ОбластьПодвал.Рисунки.Штрих.Картинка = МенеджерОборудованияВызовСервера.ПолучитьКартинкуШтрихкода(ПараметрыШтрихкода);
                КонецЕсли;
                //-- Изм. EssA 20.11.2018 14:26:23
                
                
                
                //Если ВыборкаДокументы.Ссылка.ТМЦ_Комплектация = Ложь Тогда
                //    ОбластьПодвал.Параметры.Страница = "Страница №" + НомерСтраницы;
                //    
                    ТабличныйДокумент.Вывести(ОбластьПодвал);
                //КонецЕсли;
            //КонецЕсли;    
        КонецЦикла;
            
            //++ Изм. EssA 26.07.2018 10:40:20  везде объекты печати это массив, а в эту функцию надо пер
   mistеr
 
1 - 11.09.20 - 14:30
(0) >помогите разобраться

У вас столько ошибок во фразе "сделайте за меня мою работу бесплатно"!
   AnBlast
 
2 - 11.09.20 - 14:36
(0) хоть бы закомментированные куски убрали...
но ответ в запросе... если не знаете что это такое - зовите спеца.
   Энштейн 1С
 
3 - 11.09.20 - 14:49
(0) "ВыборкаПоТабличнымЧастям = ДанныеДляПечати.РезультатПоТабличнойЧасти.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);"
"ВыборкаПоСкладам = ВыборкаПоТабличнымЧастям.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);"

Уберите заклинание "ОбходРезультатаЗапроса.ПоГруппировкам" из кода
   Энштейн 1С
 
4 - 11.09.20 - 14:54
(1) Да ладно, геройки нашлись, над девушкой измываться, и было бы трудная задача, а то обычная печатная форма. Тьфу, позор Вам товарищи 1С-ники
   Novaginn
 
5 - 11.09.20 - 14:58
Спасибо, разобрались где выборка. Извиняюсь за закомментированный код!
   Mikeware
 
6 - 11.09.20 - 14:58
(4) а фигли она без фотки?
   mistеr
 
7 - 11.09.20 - 15:02
(4) А если не девушка, то можно?
   Энштейн 1С
 
8 - 11.09.20 - 15:06
(7) Недевушке даже можно в морду дать)
   Mikeware
 
9 - 11.09.20 - 15:08
(8) а девушка тоже может дать. Но может в морду, а может и не в морду
   mikecool
 
10 - 11.09.20 - 15:08
(0) думаешь кто-то будет такие простыни читать? оО
   Энштейн 1С
 
11 - 11.09.20 - 15:10
(10) Ты не знаешь какие мне приходится действительно простыни читать и совсем даже не печатных форм, а здесь половина кода закомменчено.
   mikecool
 
12 - 11.09.20 - 15:11
(11) мне пофик
код должен быть кратким
   Энштейн 1С
 
13 - 11.09.20 - 15:12
(9) О коде надо думать, товарищ архитектор, о коде, и о красоте архитектуры корпоративного программного обеспечения!
   Энштейн 1С
 
14 - 11.09.20 - 15:13
(12) Код должен быть рабочим, быстро создаваемым и быстро работающим, а твои красоты внутри 1С никто не увидит
   Энштейн 1С
 
15 - 11.09.20 - 15:15
(12) Насчет краткости кода... Ты не видел типовые запросы в ЗУП?
   Ёпрст
 
16 - 11.09.20 - 15:16
(0) Код шедеврален!
Распечатать и на стенку в рамочку
   mikecool
 
17 - 11.09.20 - 15:17
(15) см (12)
   Ёпрст
 
18 - 11.09.20 - 15:18
не ужели в АО нет денех на кодера ? Акционеры жешь должны скинуться
   Mikeware
 
19 - 11.09.20 - 15:18
(13) а я всегда о ней думаю!©Ржевский
   Ёпрст
 
20 - 11.09.20 - 15:20
вот это..
        Если Число(ОбластьШапка.Параметры.Склад.Код) = 6060
                            ИЛИ  Число(ОбластьШапка.Параметры.Склад.Код) = 6010
                            ИЛИ  Число(ОбластьШапка.Параметры.Склад.Код) = 6020
 ....


Добавили новый склад и всё, привет котёнку ?
   Ёпрст
 
21 - 11.09.20 - 15:20
вот это тоже, полный пЭ

              Если НомерСтроки = 12 или НомерСтроки = 24 или НомерСтроки = 36 или НомерСтроки = 48 или НомерСтроки = 60 или НомерСтроки = 72 или НомерСтроки = 84 или
                            НомерСтроки = 96 или НомерСтроки = 108 или НомерСтроки = 120 или НомерСтроки = 132 или НомерСтроки = 144 или НомерСтроки = 156 или НомерСтроки = 168
                            или НомерСтроки = 180 или НомерСтроки = 192 или НомерСтроки = 204 или НомерСтроки = 216 или НомерСтроки = 228 или НомерСтроки = 240 или НомерСтроки = 252
                            или НомерСтроки = 264 или НомерСтроки = 276 или НомерСтроки = 288 или НомерСтроки = 300 Тогда
                            вп=1;

   Ёпрст
 
22 - 11.09.20 - 15:21
если фирма сменилась, опять переделывать ?

   ОбластьШапка.Параметры.НомерФормы = "Модифицированная форма АО """"НПП """"Исток"""" им.Шокина"""" на основе" + Символы.ПС + "формы № М-11, утвержденной постановлением Госкомстата России" + Символы.ПС + "от 30.10.97г. № 71а";

   Энштейн 1С
 
23 - 11.09.20 - 15:21
(20) (21) Енто специально так он сделал, чтобы работы было побольше и его считали незаменимым, что он так легко решает все возникающие проблемы
   Ёпрст
 
24 - 11.09.20 - 15:22
Короче, срочно в печать, в рамку, на стенку!
   Энштейн 1С
 
25 - 11.09.20 - 15:23
(24) Ну ладно прости его, этот код писал начинающий программист с гуманитарным образованием
   Mikeware
 
26 - 11.09.20 - 15:24
(25) наверное, все проще - почти оборонка, оклад по штатному расписанию, а на оклад инженера военпрома какой 1сник пойдет?
   Mikeware
 
27 - 11.09.20 - 15:24
(24) в гранит, в гранит!!!
   Mikeware
 
28 - 11.09.20 - 15:25
Интересно, а свою продукцию они так же моделируют?
   Энштейн 1С
 
29 - 11.09.20 - 15:34
(26) Когда я по направлению из службы занятости приезжал на собеседование на программиста 1С в несколько контор и меня везде брали, а я ведь ничего не смыслил в 1С, я тупо не отличал кнопку 1С:Предприятие от Конфигуратора и везде меня брали, только я отказывался из-за маленькой зарплаты
   hhhh
 
30 - 11.09.20 - 16:31
и чо, реально никто не догадался?
Процедура ЗаполнитьТабличныйДокументМ11(ТабличныйДокумент, ДанныеДляПечати, ОбъектыПечати) 

ДанныеДляПечати надо смотреть.

То есть ТС сюда вообще другой кусок программы захреначила. И его вообще не нужно было смотреть.
 
 Рекламное место пустует


Список тем форума
Рекламное место пустует  Рекламное место пустует
Ошибка? Это не ошибка, это системная функция.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.