Вход | Регистрация
 

Как запустить FAR через WEB клиент.

Как запустить FAR через WEB клиент.
Я
   Gamover
 
10.09.20 - 10:19
Помогите разобраться, что не так.
На моем компьютере (где установлена платформа и апач) все работает через WEB клиент. А на удаленном нет.
Срабатывает Сообщить("НЕ Подключено");


&НаКлиенте
Процедура FAR(Команда)
    НачатьПодключениеРасширенияРаботыСФайлами(Новый ОписаниеОповещения("ПослеПодклФар", Этаформа))
КонецПроцедуры

&НаКлиенте
Процедура ПослеПодклФар(Подключено, Парам)Экспорт
    Если Подключено Тогда
        НачатьЗапускПриложения(Новый ОписаниеОповещения("ПослеЗапуска", Этаформа),"C:\Program Files\Far Manager\Far.exe","C:\Program Files\Far Manager\");
    Иначе
        Сообщить("НЕ Подключено");
    КонецЕсли;
    
КонецПроцедуры
   Василий Алибабаевич
 
1 - 10.09.20 - 10:23
(0) А когда это браузеру разрешили запускать приложения на клиенте? Уже запуск "родных" java-апплетов заперетили и Хром и Огнелис. А то непонятный ФАР...
   Gamover
 
2 - 10.09.20 - 10:26
(1)В обоих случаях стоит FireFox. На моем работает, запускает.
Почему на удаленном нет?
   Василий Алибабаевич
 
3 - 10.09.20 - 10:29
(2) Через патамучто локально или удаленно оно определяет по ссылке. Если ссылка file:// - то можно. Если ссылка http(s):// - то вот вам болт дорогой товарисчЪ. Туда доступ браузеру закрыт.
   Василий Алибабаевич
 
4 - 10.09.20 - 10:30
+ (3) ВотЪ описалово для огнелиса : https://support.mozilla.org/ru/kb/upravlenie-tipami-fajlov
   Gamover
 
5 - 10.09.20 - 10:37
(3) Как то это возможно обойти? Может батник какой можно запускать на клиенте, а он уже программу будет запускать.
Там на самом деле не фар. Это для примера просто. Там программа (*.exe) с параметрами запускается. Очень упрощает жизнь она.
   Василий Алибабаевич
 
6 - 10.09.20 - 10:46
(5) "батник какой можно запускать на клиенте, а он уже программу будет запускать."
Почему не запустить программу напрямую?

"Там программа (*.exe) с параметрами запускается." С тонкого клиента можно запустить внешнюю программу. С браузера не получится. Это дыра в безопасности. Ее уже давно пытаются прикрыть.

Просто представь, что под именем твоей супер-пупер программы на клиенте запустится шифровальщик. Ну вот не ты его там соберешь из двоичных данных, а злодей подменит твою программу на свой скрипт. Клиенту будет плохо. Потому такие финты и запрещают.
   Gamover
 
7 - 10.09.20 - 10:51
(6) Понял. Спасибо
На тонком работает, но надо было в браузере.
   Garykom
 
8 - 10.09.20 - 10:54
   Garykom
 
9 - 10.09.20 - 10:54
   sikuda
 
10 - 10.09.20 - 11:46
(6) Вот именно, что Расширения работы с файлами это РАЗРЕШАЕТ! Да спрашивает у пользователя подтверждение, но разрешает.
   Gamover
 
11 - 10.09.20 - 11:51
(10) Я не совсем понял, как именно работать с этим расширением. Установил его. А дальше как? Есть опыт?
   sikuda
 
12 - 10.09.20 - 11:55
(11) Дальше сама 1С работает а не ругается на невозможность работы
   Gamover
 
13 - 10.09.20 - 11:56
(12) Вы про вот это расширение https://addons.mozilla.org/ru/firefox/addon/1c-enterprise-8-extension/ говорите?
   sikuda
 
14 - 10.09.20 - 12:22
(13) Ну да
   ДенисЧ
 
15 - 10.09.20 - 12:40
Если бы какой-то бровзер могу запускать у меня на компе какие-то левые приложения - этот бровзер сразу бы улетул в корзину...

Кроме того, а если я зайду в вебклиента с линуха, андройда или (не приведи Аллах) с мака?
   sikuda
 
16 - 10.09.20 - 12:41
(15) Это не браузер - Это расширение для браузеров от 1С!
   ДенисЧ
 
17 - 10.09.20 - 12:50
(16) Эквипенисуально. Работает в барузере
   sikuda
 
18 - 10.09.20 - 12:56
(17) Любой запуск внешней обработки в 1С = запуск внешней программы (Астахов из 1С несколько лет назад);)
   ДенисЧ
 
19 - 10.09.20 - 13:36
(18) нет (с)
   sikuda
 
20 - 10.09.20 - 14:38

Список тем форума
Рекламное место пустует  Рекламное место пустует
Оптимист верит, что мы живем в лучшем из миров. Пессимист боится, что так оно и есть.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.