Вход | Регистрация
 

Вывод результатов запроса в таблицу печати

Вывод результатов запроса в таблицу печати
Я
   Mafiozaa
 
09.09.20 - 07:30
Приветствую, необходимо вывести 3 колонки результата в 3 колонки печатной формы застопился,разобраться не могу, выводится макет и все

Процедура Сформировать()
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = "
        |Номенк   = Регистр.ОстаткиТМЦ.Номенклатура;
        |ЦенаПрод = Регистр.ОстаткиТМЦ.ЦенаПрод;
        |Колич      = Регистр.ОстаткиТМЦ.Количество;
        |Группировка Номенк;
        |Группировка ЦенаПрод;
        |Функция КоличОст = КонОст(Колич);
        |Условие (Номенк в ВыборСпр);
        |Условие (ЦенаПрод <> 0);
        |";
        Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
            Предупреждение("Запрос не выполнен");
            Возврат;
        КонецЕсли;    
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    Таб.ВывестиСекцию("Шапка");
    Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать","");
КонецПроцедуры
   ДенисЧ
 
1 - 09.09.20 - 07:33
Найди книжку Митичкина или Радченко. Прочитай. Потом только начинай кодить так, чтобы не под себя получалось...
   ДенисЧ
 
2 - 09.09.20 - 07:34
Ну, или в крайнем (совсем крайнем) возьми в конфигураторе "конструктор запроса с обработкой результата".
По крайней мере - поймёшь, что у тебя не хватает
   Йохохо
 
3 - 09.09.20 - 07:42
секция 7.7
   ДенисЧ
 
4 - 09.09.20 - 07:43
(3) Где?
   ДенисЧ
 
5 - 09.09.20 - 07:44
Ну, запрос-то да. Тогда просто книжки почитать... Хотя где их сейчас найти...
   Ёпрст
 
6 - 09.09.20 - 07:45
(0) ну дык обходи выгрузуку запроса и дальше выводи секции
   SleepyHead
 
7 - 09.09.20 - 07:45
(5) У меня на работе в ящике стола все еще лежат, изрядно выцвевшие ))
   Ёпрст
 
8 - 09.09.20 - 07:45
от тут всё есть
https://old.mista.ru/
   Mafiozaa
 
9 - 09.09.20 - 07:51
(6)
Выводит пустые ячейки таблицы
        Номенк = Запрос.Номенк;
    ЦенаПрод = Запрос.ЦенаПрод;
    Колич = Запрос.Колич;
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    Таб.ВывестиСекцию("Шапка");
    Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);
    Пока Запрос.Группировка(1) = 1 Цикл
        Таб.ВывестиСекцию("Номенк");
        Товар = Запрос.Номенк;
        Пока Запрос.Группировка(2) = 1 Цикл
            Таб.ВывестиСекцию("ЦенаПрод");
            Цена = Запрос.ЦенаПрод;
        КонецЦикла;
   2S
 
10 - 09.09.20 - 07:55
(9)         Таб.ВывестиСекцию("Номенк");
        Товар = Запрос.Номенк;
местами поменяйте
   Mafiozaa
 
11 - 09.09.20 - 08:01
(10) Поменял,конечный код, пустая таблица, ячеек уйма, а информации нет

Процедура Выполнение()
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = "
        |Номенк   = Регистр.ОстаткиТМЦ.Номенклатура;
        |ЦенаПрод = Регистр.ОстаткиТМЦ.ЦенаПрод;
        |Колич      = Регистр.ОстаткиТМЦ.Количество;
        |Группировка Номенк;
        |Группировка ЦенаПрод;
        |Функция КоличОст = КонОст(Колич);
        |Условие (Номенк в ВыборСпр);
        |Условие (ЦенаПрод <> 0);
        |";
        Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
            Предупреждение("Запрос не выполнен");
            Возврат;
        КонецЕсли;
    Номенк = Запрос.Номенк;
    ЦенаПрод = Запрос.ЦенаПрод;
    Колич = Запрос.Колич;
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Выполнение");
    Таб.ВывестиСекцию("Шапка");
    Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);
    Пока Запрос.Группировка(1) = 1 Цикл
        Товар = Запрос.Номенк;
        Таб.ВывестиСекцию("Номенк");
        Пока Запрос.Группировка(2) = 1 Цикл
            Цена = Запрос.ЦенаПрод;
            Таб.ВывестиСекцию("Цена");
            Пока Запрос.Группировка(3) = 1 Цикл
                Остатки = Запрос.Колич;
                Таб.ВывестиСекцию("Остатки");
            КонецЦикла;
        КонецЦикла;
    КонецЦикла;
    Таб.ВывестиСекцию("Подвал");
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Выполнение","");
КонецПроцедуры
   2S
 
12 - 09.09.20 - 08:13
(11) что у вас в 3-ей группировке?
как описан макет? мы отсюда не видим
   2S
 
13 - 09.09.20 - 08:14
(11) дай доступ, минут 5 есть
   Mafiozaa
 
14 - 09.09.20 - 08:23
(13) (12)
|          Выполнение
|шапка

|номенк  <Товар>

|цена   <Цена>      <Остатки>
   Mafiozaa
 
15 - 09.09.20 - 08:24
(13) (12) 
3ю группировку убрал

|          Выполнение
|шапка

|номенк  <Товар>

|цена   <Цена>      <Остатки>
   2S
 
16 - 09.09.20 - 08:26
Номенк = Запрос.Номенк;
    ЦенаПрод = Запрос.ЦенаПрод;
    Колич = Запрос.Колич;
    Таб = СоздатьОбъект("Таблица");

вот тут каша, как параметры описаны в макете?
   Mafiozaa
 
17 - 09.09.20 - 08:29
(16) это все что есть на макете, а    ЦенаПрод = Запрос.ЦенаПрод; Колич = Запрос.Колич; удалил уже

|          Выполнение
|шапка

|номенк  <Товар>

|цена   <Цена>      <Остатки>
   tgu82
 
18 - 09.09.20 - 08:39
(0) Обычное дело. Можно воспользоваться конструктором запросов - достаточно просто. Третья группировка не понял откуда взялась. Ну а так - в конструкторе сразу и формирование таблицы.
   tgu82
 
19 - 09.09.20 - 08:40
(18)+ Хай живе 1С 7.7 )
   Mafiozaa
 
20 - 09.09.20 - 08:49
(19) Спасибо,так лучше,щас макет отредактирую,а так все работает
   2S
 
21 - 09.09.20 - 08:56
(20) вот и сравни с тем что у тебя


Список тем форума
Рекламное место пустует  Рекламное место пустует
Оптимист верит, что мы живем в лучшем из миров. Пессимист боится, что так оно и есть.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.