Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Выбор группы справочника запросом

v7: Выбор группы справочника запросом
Я
   Mafiozaa
 
09.09.20 - 05:02
Приветствую,есть поле ввода,в котором выбирают группу из номенклатуры,затем элементы этой группы должны вывестись в тз,не могу подбить запрос
прошу помощи)

Процедура ПриОткрытии();
    ТаблЗнач.НоваяКолонка("Наименование","Строка");
    ТаблЗнач.НоваяКолонка("Цена","Число");
КонецПроцедуры
Процедура Выполнить();
       ВыбраннаяГруппа = ВыборСпр.Наименование;
    Если ПустоеЗначение(ВыбДата) = 1 Тогда
        Предупреждение("Не задана дата отчета!");
        Активизировать("ВыбДата");
    КонецЕсли;
    ДатаЗапроса = ?(ВыбДата>=ПолучитьДатуТА(),"",ВыбДата);
    ТекстЗапроса = "
        |Период с ДатаЗапроса по ДатаЗапроса;
        |Номенк   = Регистр.ОстаткиТМЦ.Номенклатура;
        |ЦенаПрод = Регистр.ОстаткиТМЦ.ЦенаПрод;
        |Колич      = Регистр.ОстаткиТМЦ.Количество;
        |Группировка Номенк;
        |Группировка ЦенаПрод;
        |Функция КоличОст = КонОст(Колич);
        |Условие (ЦенаПрод <> 0);
        |";
        Запрос = СоздатьОбъект("Запрос");
        РезультатЗапроса = Запрос.Выполнить(ТекстЗапроса);
        Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
            Предупреждение("Запрос не выполнен");
            Возврат;
        КонецЕсли;
        Запрос.Выгрузить(ТаблЗнач, 0, 0);
    КонецПроцедуры
   Андрей_Андреич
 
1 - 09.09.20 - 05:06
|Условие (Номенк в ВыборСпр);
   Mafiozaa
 
2 - 09.09.20 - 05:10
Ошибки после добавления вашего кода


РезультатЗапроса = Запрос.Выполнить(ТекстЗапроса);
{C:\USERS\DMITRIY\DESKTOP\БАЗА\EXTFORMS\ННЦП2.ERT(23)}:  <<?>> Условие (ЦенаПрод <> 0);
Запрос[10] : Ожидается ';' перед 'Условие'
РезультатЗапроса = Запрос.Выполнить(ТекстЗапроса);
{C:\USERS\DMITRIY\DESKTOP\БАЗА\EXTFORMS\ННЦП2.ERT(23)}: Условие (ЦенаПрод <> 0 <<?>> );
Запрос[10] : Ошибка в условии
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{C:\USERS\DMITRIY\DESKTOP\БАЗА\EXTFORMS\ННЦП2.ERT(24)}:  <<?>> Условие (ЦенаПрод <> 0);
Запрос[10] : Ожидается ';' перед 'Условие'
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{C:\USERS\DMITRIY\DESKTOP\БАЗА\EXTFORMS\ННЦП2.ERT(24)}: Условие (ЦенаПрод <> 0 <<?>> );
Запрос[10] : Ошибка в условии (1)
   Mafiozaa
 
3 - 09.09.20 - 05:11
(1) Ошибки появились после добавления вашего кода
РезультатЗапроса = Запрос.Выполнить(ТекстЗапроса);
{C:\USERS\DMITRIY\DESKTOP\БАЗА\EXTFORMS\ННЦП2.ERT(23)}:  <<?>> Условие (ЦенаПрод <> 0);
Запрос[10] : Ожидается ';' перед 'Условие'
РезультатЗапроса = Запрос.Выполнить(ТекстЗапроса);
{C:\USERS\DMITRIY\DESKTOP\БАЗА\EXTFORMS\ННЦП2.ERT(23)}: Условие (ЦенаПрод <> 0 <<?>> );
Запрос[10] : Ошибка в условии
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{C:\USERS\DMITRIY\DESKTOP\БАЗА\EXTFORMS\ННЦП2.ERT(24)}:  <<?>> Условие (ЦенаПрод <> 0);
Запрос[10] : Ожидается ';' перед 'Условие'
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
{C:\USERS\DMITRIY\DESKTOP\БАЗА\EXTFORMS\ННЦП2.ERT(24)}: Условие (ЦенаПрод <> 0 <<?>> );
Запрос[10] : Ошибка в условии
   Mafiozaa
 
4 - 09.09.20 - 05:12
(1) Извините,все четко,спасибо
   tgu82
 
5 - 09.09.20 - 08:58
(0)  |Группировка Номенк без групп; если нужны только элементы в выбираемой группе

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.