Вход | Регистрация
 

Как в типовой получить ссылку на созданный элемент?

Как в типовой получить ссылку на созданный элемент?
Я
   Klesk
 
08.09.20 - 22:00
&НаКлиенте
Процедура СоответствиеНоменклатурыВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
    Если Поле.Имя="СоответствиеНоменклатурыКартинка" Тогда
        ФормаНоменклатуры=ОткрытьФорму("Справочник.Номенклатура.Форма.ФормаЭлемента",,ЭтаФорма
        ,,,, Новый ОписаниеОповещения("ВвелиНоменклатуру", ЭтаФорма,
        ),
        РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);
        ФормаНоменклатуры.Объект.Наименование= Элемент.ТекущиеДанные.Наименование;
        ФормаНоменклатуры.Объект.НаименованиеПолное=Элемент.ТекущиеДанные.Наименование;
        ФормаНоменклатуры.Объект.Артикул=Элемент.ТекущиеДанные.Артикул;
        ФормаНоменклатуры.Объект.ЕдиницаИзмерения=Элемент.ТекущиеДанные.ЕдиницаИзмерения;        
    Иначе
         СтандартнаяОбработка=Истина;
    КонецЕсли;    
КонецПроцедуры

Функция ВвелиНоменклатуру(РезультатВыбора, ДополнительныеПараметры) Экспорт
    Возврат РезультатВыбора; ///Всё Неопределено!!!
КонецФункции
   VladZ
 
1 - 08.09.20 - 22:07
(0) Что это за дичь?
   Klesk
 
2 - 08.09.20 - 22:19
учусь уходить от модальных форм (1)
   Ёпрст
 
3 - 08.09.20 - 22:20
параметры метода получитьформу там подправишь, если че

ФормаНоменклатуры=ПолучитьФорму("Справочник.Номенклатура.Форма.ФормаЭлемента",,ЭтаФорма,,,,,РежимОткрытияОкнаФормы.БлокироватьОкноВладельца);
Оповещение = Новый ОписаниеОповещения("ВвелиНоменклатуру", ЭтаФорма, ФормаНоменклатуры);
ФормаНоменклатуры.ОписаниеОповещенияОЗакрытии = Оповещение;
  ФормаНоменклатуры.Объект.Наименование= Элемент.ТекущиеДанные.Наименование;
        ФормаНоменклатуры.Объект.НаименованиеПолное=Элемент.ТекущиеДанные.Наименование;
        ФормаНоменклатуры.Объект.Артикул=Элемент.ТекущиеДанные.Артикул;
        ФормаНоменклатуры.Объект.ЕдиницаИзмерения=Элемент.ТекущиеДанные.ЕдиницаИзмерения;    

    ФормаНоменклатуры.Открыть();
КонецПроцедуры

&НаКлиенте
Процедура ВвелиНоменклатуру(Результат, ДопПараметры) Экспорт 
    
    ТвояССылка= ДопПараметры.Объект.Ссылка;    
    
КонецПроцедуры

   Klesk
 
4 - 08.09.20 - 23:06
(3) респект

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.