Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Выгрузка и загрузка документов по отборам

Выгрузка и загрузка документов по отборам
Я
   Filkkore
 
08.09.20 - 13:39
Ситуация такая: Есть 4 базы, необходимо выгрузить все документы, например, Реализации из трёх баз в один файл и при загрузке в четвёртую, загружать только документы Реализации с выбранным контрагентом. Как это проще всего реализовать? До этого всего пару раз пользовался КД 2.1
   Tarlich
 
1 - 08.09.20 - 13:41
почему именно в "один файл"?
   ДенисЧ
 
2 - 08.09.20 - 13:41
Проще всего сразу выгружать нужные документы
   Tarlich
 
3 - 08.09.20 - 13:42
а потом окажется что конфигурации одинаковые ....
   Filkkore
 
4 - 08.09.20 - 14:11
(1) Потому что обмен между конфами производится на постоянной основе, просто для ускорения.
   lodger
 
5 - 08.09.20 - 14:13
(4) и как ты видишь ускорение при записи в файл 3х потоков разом? они скорее встанут в очередь и будут толкаться.
   Filkkore
 
6 - 08.09.20 - 14:14
Ну мне вообще по сути скорее важно сделать отбор при загрузке, чем выгрузку в один файл.
   Filkkore
 
7 - 08.09.20 - 14:14
(5) Суть не в записи разом, суть в загрузке разом из трёх конф.
   hhhh
 
8 - 08.09.20 - 14:23
(7) три загрузки будут выполняться в три раза дольше. ОТкулв ускорение?
   Filkkore
 
9 - 08.09.20 - 14:27
(8) В том что не нужно будет вручную выгружать/загружать из трёх баз отдельно в одну. Ну да, скорее не быстрее, а проще.
Но опять же не суть, с этим может как нибудь разберусь да и не самое главное это. Главное - отбор при загрузке...
   hhhh
 
10 - 08.09.20 - 14:42
(9) ну для документа пишете в обработчике ПослеЗагрузки
Если Объект.Контрагент.Наиенование <> "Контрагент Вася" Тогда
    Отказ = ИСтина; 
КонецЕсли;
   Filkkore
 
11 - 08.09.20 - 14:48
(10) Имеете ввиду в типовой обмен добавить реквизит на форме для отбора и в модуле добавить:

Процедура ПослеЗагрузки()

     Если Объект.Контрагент.Наиенование <> "ИмяРеквизита" Тогда
         Отказ = ИСтина; 
     КонецЕсли;
 
КонецПроцедуры
   hhhh
 
12 - 08.09.20 - 21:13
(11) нет, я имею в виду правила обмена. вы же спрашивали про КД 2.1
   Ёпрст
 
13 - 08.09.20 - 21:57
(0)
фильтравать надо на этапе выгрузки, а не загрузки
   Filkkore
 
14 - 09.09.20 - 07:18
(12) "Отбор при загрузке" это при загрузке в базу через обработку Универсальный обмен, это не при выгрузке из базы. С правилами обмена-то несложно такое сделать. Мне бы понять, как реализовать отбор при загрузке непосредственно из самого XML файла в базу.
И не надо мне предлагать уже при выгрузке в файл правила менять и всякое такое, мне задачу поставили сделать так, делаю как сказали.
Конкретно ещё раз: Реализовать выгрузку документов из ТРЁХ баз в ОДИН файл и из этого файла загрузка документов в ОДНУ, четвёртую базу с использованием отбора при загрузке, например по контрагентам.
   ДенисЧ
 
15 - 09.09.20 - 07:21
(14) "Реализовать выгрузку документов из ТРЁХ баз в ОДИН файл "
Ты любишь с наркоманами работать?
   Filkkore
 
16 - 09.09.20 - 07:22
(15) Я обменом практически не занимался, какие с этим проблемы-то собсна?
   Ёпрст
 
17 - 09.09.20 - 07:24
(16) если проблем нет, то делай собсна
   Filkkore
 
18 - 09.09.20 - 07:27
(17) Ну так я и не знаю, как это реализовать, потому и спрашиваю, а тут все в эту идею плюются. Вот мне и интересно, что с идеей не так?
Фирма большая, я у них особо не лазал. Насколько знаю, обменом между базами занимаются они просто постоянно, необходимо это дело для них упростить.
   ДенисЧ
 
19 - 09.09.20 - 07:29
(16) Никаких. Кроме явного вреда от наркомании.
   ДенисЧ
 
20 - 09.09.20 - 07:30
Ты просто в файл выгрузки обмена погляди глазками. И подумай, как он будет выглядеть, если ты последовательно в него запишешь выгрузки из трёх баз.
   ДенисЧ
 
21 - 09.09.20 - 07:31
(18) "необходимо это дело для них упростить"

Когда-то один деятель по похожему поводу произнёс фразу "O sancta simplicitas"
Перевод нужен?
   Filkkore
 
22 - 09.09.20 - 07:40
(20) Хорошо, идея тупая, осталось им это объяснить, попытаюсь. Но всё же, реализуем ли отбор при загрузке файла в базу и как это лучше сделать?
   ДенисЧ
 
23 - 09.09.20 - 07:42
(22) Тебе уже неоднократно сказали, что правильно это делать при выгрузке.
   Ёпрст
 
24 - 09.09.20 - 07:42
(22) Для тех кто в танке. Основная проблема не в отборе. Основная проблема создать один файл из 3-х баз.
Который ты не слепишь, никогда
   Йохохо
 
25 - 09.09.20 - 07:44
(22) переработай (10) на ИНН и всё
(23) да одна белая организация на все и 3 от балды черных
   K1RSAN
 
26 - 09.09.20 - 08:04
(14) Не каждая выдумка пользователей осуществима. Потом захотят, чтобы зашел в одну базу, а там по желанию можно смотреть документы другой базы)


Список тем форума
Рекламное место пустует  Рекламное место пустует
Чтобы обнаруживать ошибки, программист должен иметь ум, которому доставляет удовольствие находить изъяны там, где, казалось, царят красота и совершенство.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.