Вход | Регистрация
 

Ограничение на ввод строк в табличную часть справочника

Ограничение на ввод строк в табличную часть справочника
Я
   NIGHTHUNTER
 
08.09.20 - 12:55
Хочу ограничить ввод количества строк в справочник, тремя строками. Вот в этой процедуре можно определить что вводится новая строка и что её номер 4 .
Я хочу разрешить ввод только трех строк. Когда я отлавливаю что вводится новая строка и ее номер 4, как отказать в ее добавлении, помимо вывода сообщения?



&НаКлиенте
Процедура ОсновныеХарактеристикиПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
    Если НоваяСтрока = Истина и Элементы.ОсновныеХарактеристики.ТекущиеДанные.НомерСтроки = 4 Тогда
        Сообщить("В табличную часть «Основные характеристики», рекомендуется вводить не более 3х строк.");
        Сообщить("Для корректного вывода макета печатной формы коммерческого предложения");
    КонецЕсли;
КонецПроцедуры
   RomaH
 
1 - 08.09.20 - 12:56
рекомендуется вводить не более 3х строк.")

ну так и рекомендуй, почему запрещаешь?
   Fedor-1971
 
2 - 08.09.20 - 12:57
(0) ПередНачаломДобавления  выстави Отказ = Истина
И не номер = 4, а ТЧ.Количество() = 3
   RomaH
 
3 - 08.09.20 - 12:57
после ввода третьей, запрещай добавление строк
ПередНачаломДобавления(Элемент, Отказ, Копирование, Родитель, Группа, Параметр)
    // Вставить содержимое обработчика.

КонецПроцедуры
   NIGHTHUNTER
 
4 - 08.09.20 - 12:59
(1) Да, так подумал, так вот сделать, что бы не на вводили, и макет не сломали.
   Дмитрий
 
5 - 08.09.20 - 12:59
Как вариант - при записи удалять лишние )
   NIGHTHUNTER
 
6 - 08.09.20 - 13:00
(5) Хочу сообщать. И не давать вводить. А то может кто то сядет, и навводит 100 строк. А потом они пропадут.
   RomaH
 
7 - 08.09.20 - 13:04
...
не правильнее - вводить все
а в макет выводить только первые 3?
   NIGHTHUNTER
 
8 - 08.09.20 - 13:05
Тут можно определить номер вводимой строки 

ПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
    Если НоваяСтрока = Истина и Элементы.ОсновныеХарактеристики.ТекущиеДанные.НомерСтроки = 4 Тогда

А тут, как???

&НаКлиенте
Процедура ОсновныеХарактеристикиПередНачаломДобавления(Элемент, Отказ, Копирование, Родитель, Группа, Параметр)
   NIGHTHUNTER
 
9 - 08.09.20 - 13:06
(7) Наверное да правильнее.
   RomaH
 
10 - 08.09.20 - 13:22
(8)
ТЧ.Количество()

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.