Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

МенеджерКриптографии подписать строку

МенеджерКриптографии подписать строку
Я
   МаленькийВопросик
 
08.09.20 - 12:45
Товарищи, доброго времени!

Подскажите примерчик как подписать строку с помощью сертификата криптографии:

Сертификат я получил, теперь, нужно подписать им строку:

ТипыХранилищ = Новый Массив;
    ТипыХранилищ.Добавить(ТипХранилищаСертификатовКриптографии.ПерсональныеСертификаты);
    //ТипыХранилищ.Добавить(ТипХранилищаСертификатовКриптографии.СертификатыПолучателей);
    
    ПроверятьДатуОкончания = Истина;
    
    СписокСертификатов = Новый Массив;
    МенеджерКриптографии = Новый МенеджерКриптографии("", "",75);
    
    Для Каждого ТипХранилища Из ТипыХранилищ Цикл
        
        Хранилище = МенеджерКриптографии.ПолучитьХранилищеСертификатов(ТипХранилища);
        
        СертификатыХранилища = Хранилище.ПолучитьВсе();
        ТекущаяДата          = ТекущаяДата();
        
        Для Каждого Сертификат Из СертификатыХранилища Цикл
            
            Если ПроверятьДатуОкончания И Сертификат.ДатаОкончания < ТекущаяДата Тогда
                Продолжить;
            КонецЕсли;
                        
            СписокСертификатов.Добавить(Сертификат);
        КонецЦикла;
        
    КонецЦикла;
    
    Возврат СписокСертификатов;
   МаленькийВопросик
 
1 - 08.09.20 - 15:33
апнем
   polosov
 
2 - 08.09.20 - 15:36
   МаленькийВопросик
 
3 - 09.09.20 - 16:33
ПутьК_dataFile = ДанныеАвторизации.Получить("data");
    МенеджерКриптографии.ПарольДоступаКЗакрытомуКлючу = "";
    ПутьШифрованный_dataFile = ПутьК_dataFile + "_crypt";
    МенеджерКриптографии.Подписать(ПутьК_dataFile, ПутьШифрованный_dataFile, Сертификат);
    Данные = МенеджерКриптографии.Подписать(ПутьК_dataFile, Сертификат);

вопрос к данныеавторизации

в метод подписать - нужно строку вставить
   МаленькийВопросик
 
4 - 11.09.20 - 07:36
поднимем тему!
   Вафель
 
5 - 11.09.20 - 09:49
сохрани в файл, подпиши и прочитай
   МаленькийВопросик
 
6 - 11.09.20 - 10:49
подписание файла не ест подписание строки в файле...
попробовал уже

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.