Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Запись файла в веб клиенте

Запись файла в веб клиенте
Я
   seraf
 
08.09.20 - 10:08
Привет, почему не работает в вебе Метод объекта не обнаружен (Записать)

&НаКлиенте
Процедура ВыполнитьПечать(ИмяМакета)

Макет_ = ПолучитьМакетП(ИмяМакета);
ИмяФайла = ПолучитьИмяВременногоФайла("docx");
Макет_.Записать(ИмяФайла);


Доступность:
Тонкий клиент, мобильный клиент, сервер, толстый клиент, внешнее соединение, мобильное приложение (клиент), мобильное приложение (сервер), мобильный автономный сервер.
   ДенисЧ
 
1 - 08.09.20 - 10:11
А  проверить тип переменной?
   seraf
 
2 - 08.09.20 - 10:21
какой переменной
Макет - двоичные данные, в обычном клиенте всё ок
   ДенисЧ
 
3 - 08.09.20 - 10:22
А точно там двоичные данные? Ты проверил?
   acht
 
4 - 08.09.20 - 10:38
(0) Найди в своем же сообщении после слова "Доступность" слова "веб клиент", пожалуйста.
   seraf
 
5 - 08.09.20 - 10:59
(3) точно в обычном, в вебе не знаю не мог проверить, думал не отличается, попробую
(4) перепутал с мобильным и прочим, так а как запись файла находясь в веб окне организовать
   acht
 
6 - 08.09.20 - 11:00
(5) НачатьЗапись
   seraf
 
7 - 08.09.20 - 11:25
Спасибо
   sikuda
 
8 - 08.09.20 - 12:01
И в ПолучитьИмяВременногоФайла нем вэб-клиента ;)
Доступность:
Тонкий клиент, мобильный клиент, сервер, толстый клиент, внешнее соединение, мобильное приложение (клиент), мобильное приложение (сервер).
   sikuda
 
9 - 08.09.20 - 12:16
(6) И не забыть что даже НачатьЗапись требует установки расширения 1С в браузер ;)
   sikuda
 
10 - 08.09.20 - 12:31
(0) А еще лучше, все-таки почитать про безопастноть в интернете, отключить в расширение 1С в браузере!
И интерактивно сохранить файл на компьютер

ПараметрыДиалога = Новый ПараметрыДиалогаПолученияФайлов;
НачатьПолучениеФайлаССервера(Адрес,"МойФайл.docx",ПараметрыДиалога);

   seraf
 
11 - 08.09.20 - 12:54
то есть не через расширение делать?
а то что-то не работает

    #Если ВебКлиент Тогда

        Результат = ПодключитьРасширениеРаботыСФайлами();

        Если Не Результат Тогда
            НачатьУстановкуРасширенияРаботыСФайлами();
            Если Не ПодключитьРасширениеРаботыСФайлами() Тогда
               ВызватьИсключение "Ошибка.";
            Иначе
               Макет_.НачатьЗапись(Новый ОписаниеОповещения, ИмяФайла);
            //КонецЕсли;

        КонецЕсли;

    #КонецЕсли


Вроде ушло на установку расширение в хроме, установилось, вначале пишет расширение уже установлено и сразу после сообщение о том что не установлено
   acht
 
12 - 08.09.20 - 13:01
(11) Сколько параметров у НачатьУстановкуРасширенияРаботыСФайлами?
   seraf
 
13 - 08.09.20 - 13:02
один необязательный
   sikuda
 
14 - 08.09.20 - 13:03
(11) Да лучше без расширения, потому-что даже расширение будет тебя спрашивать о необходимости действий записи в вэб.
   seraf
 
15 - 08.09.20 - 13:04
Сначала выводится 
Расширение для работы с файлами уже подключено и сразу за этим Расширение для работы с файлами не подключено)
   acht
 
16 - 08.09.20 - 13:05
(13) А. Ну то есть зачем он там вообще ты даже не понимаешь.
Не, ну тя нафик, пиши сам
   seraf
 
17 - 08.09.20 - 13:09
мне нужно чтобы открылся вордовский файл на клиентском компе
для этого он все равно где-то во временные файлы сначала пишется

(16) понимаю вроде, выполнить процедуру после первой установки расширения, оно уже и так установлено
   sikuda
 
18 - 08.09.20 - 15:25
(17) Да на дворе 2020 год, чтобы открыть Word надо "все равно где-то во временные файлы сначала пишется"
Точно? https://yadi.sk/i/QEyLG2iORAcN-g
   Skylark
 
19 - 08.09.20 - 16:52
(9) вроде как уже не требует

Список тем форума
Рекламное место пустует  Рекламное место пустует
Основная теорема систематики: Новые системы плодят новые проблемы.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.