Вход | Регистрация
 

Не обновляется сумма при пересчете скидки

Не обновляется сумма при пересчете скидки
Я
   NIGHTHUNTER
 
07.09.20 - 09:23
Столкнулся с тем что не обновляется сумма при пересчете скидки. То есть при вводе в табличную часть процента скидки, по коду скидка рассчитывается и вычитается из суммы.
Но в табличной части это не обновляется. Сумма как была до скидки так и остается. Почему так работает?

&НаКлиенте
Процедура СоставляющиеСкидкаПриИзменении(Элемент)
    ТекДанные           = Элементы.Составляющие.ТекущиеДанные;
    СуммаСкидки         = ТекДанные.СуммаСНДС * ТекДанные.Скидка / 100;
    ТекДанные.СуммаСНДС = ТекДанные.СуммаСНДС - СуммаСкидки;
КонецПроцедуры
   NIGHTHUNTER
 
1 - 07.09.20 - 09:23
Например соседняя процедура по пересчету количества работает. В чем глюк ?

&НаКлиенте
Процедура СоставляющиеКоличествоПриИзменении(Элемент)
    ТекДанные           = Элементы.Составляющие.ТекущиеДанные;
    ТекДанные.СуммаСНДС = ТекДанные.ЦенаСНДС * ТекДанные.Количество;    
КонецПроцедуры
   NIGHTHUNTER
 
2 - 07.09.20 - 09:51
было из за этого

//

//&НаКлиенте
//Процедура СоставляющиеПриИзменении(Элемент)

//    ТекДанные       = Элементы.Составляющие.ТекущиеДанные;
//    ТекДанные.Сумма = ТекДанные.Цена * ТекДанные.Количество;

//КонецПроцедуры
//

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.