Вход | Регистрация
 

Как правильно заполнить реквизит табличной части документа.

Как правильно заполнить реквизит табличной части документа.
Я
   NIGHTHUNTER
 
07.09.20 - 06:40
При изменении значения, наименование табличной части документа, делаю заполнение табличной части.
Но вот производителя не могу заполнить. Как правильно заполнять текущие данные они не доступны на сервере.


&НаКлиенте
Процедура СоставляющиеНаименованиеПриИзменении(Элемент)
    ТекДанные = Элементы.Составляющие.ТекущиеДанные.Наименование;
    ЗаполнитьНаСервере(ТекДанные);
КонецПроцедуры
//
&НаСервере
Процедура ЗаполнитьНаСервере(ТекДанные)
    ТекДанные.Производитель = ТекДанные.Наименование.Производитель;
    Для каждого СтрТз Из ТекДанные.Наименование.СоставныеЧасти Цикл
        НоваяСтрока                    = Объект.Составляющие.Добавить();
        НоваяСтрока.Наименование       = СтрТз.Наименование;
        НоваяСтрока.Основное           = СтрТз.Наименование.Основное;        
        НоваяСтрока.Производитель      = ТекДанные.Производитель;        
        НоваяСтрока.Производительность = ТекДанные.Производительность;        
    КонецЦикла;
КонецПроцедуры
   SleepyHead
 
1 - 07.09.20 - 06:41
ТекДанные.Производитель = ТекДанные.Наименование.Производитель

Какого типа "Наименование" в текданных?
   Галахад
 
2 - 07.09.20 - 06:48
В процедуру ЗаполнитьНаСервере(ТекДанные) приходит строка. И как с из этой строки еще что-то получить...
   Fram
 
3 - 07.09.20 - 06:52
(2) это у нормальных прогов Наименование это реквизит типа строка. Тут мы имеем дело с неординарным, так сказать, товарищем
   NIGHTHUNTER
 
4 - 07.09.20 - 06:52
так решил

&НаКлиенте
Процедура СоставляющиеНаименованиеПриИзменении(Элемент)
    ТекДанные = Элементы.Составляющие.ТекущиеДанные;
    ТекДанные.Производитель = ПолучитьПроизводителя(ТекДанные.Наименование);
    ЗаполнитьНаСервере(ТекДанные.Наименование);
КонецПроцедуры
//

&НаСервере
Функция ПолучитьПроизводителя(ОбъектКП)
    Возврат ОбъектКП.Производитель; 
КонецФункции
//
   NIGHTHUNTER
 
5 - 07.09.20 - 06:53
(1)  типа справочник
на клиенте через точку нельзя получать значение

(2) это справочник
   SleepyHead
 
6 - 07.09.20 - 06:58
(5) Маловато серверных вызовов с передачей контекста, пользователи уважать не будут..
   NIGHTHUNTER
 
7 - 07.09.20 - 09:20
(6) А как правильно сделать?
Одним вызовом, передать массив с структурой всего ?
   NIGHTHUNTER
 
8 - 07.09.20 - 11:34
(6) Подскажете для общего развития, и что бы знать как делать правильно?

Список тем форума
Рекламное место пустует  Рекламное место пустует
2 + 2 = 3.9999999999999999999999999999999...
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.