Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Запрос

↓ [Волшебник, 05.09.20 - 15:35]
Запрос
Я
   Anna Margo
 
05.09.20 - 15:21
Помогите дописать запрос к тестовому заданию
Дано:
#Область ПроцедурыИФункцииПервичногоЗаполненияДанных

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    НоваяСтрокаПриходаТоваров("Монитор",   "Ильдарадо",  Дата(2015, 8, 1, 12,30,0), 5);
    НоваяСтрокаПриходаТоваров("Телевизор", "Ильдарадо",  Дата(2015, 8, 1, 13,40,0), 3);
    НоваяСтрокаПриходаТоваров("Планшет",   "ДВидео",     Дата(2015, 8, 1, 18,20,0), 8);
    НоваяСтрокаПриходаТоваров("Компьютер", "Ялмарт",     Дата(2015, 8, 2, 12,30,0), 10);
    НоваяСтрокаПриходаТоваров("Телефон",   "ДВидео",     Дата(2015, 8, 2, 12,30,0), 5);
    НоваяСтрокаПриходаТоваров("Лампа",     "ДВидео",     Дата(2015, 8, 2, 11,35,0), 11);
    НоваяСтрокаПриходаТоваров("Молоток",   "Строитель",  Дата(2015, 8, 4, 12,30,0), 6);
    НоваяСтрокаПриходаТоваров("Стол",      "Мебельный",  Дата(2015, 8, 5, 12,30,0), 20);
    
    НоваяСтрокаТаблицаОстатков("Монитор", "П1", 10);
    НоваяСтрокаТаблицаОстатков("Монитор", "П2", 20);
    НоваяСтрокаТаблицаОстатков("Монитор", "П3", 30);
    НоваяСтрокаТаблицаОстатков("Монитор", "П4", 40);
    
    НоваяСтрокаТаблицаДокумента("Монитор", "",   35);
    НоваяСтрокаТаблицаДокумента("Монитор", "П2", 5);
    НоваяСтрокаТаблицаДокумента("Монитор", "П1", 35);
    
КонецПроцедуры    

&НаСервере
Процедура НоваяСтрокаПриходаТоваров(Товар, КтоПривез, ДатаПривоза, Количество)
    
    НоваяСтрока = Объект.ПриходТовара.Добавить();
    НоваяСтрока.Товар = Товар;
    НоваяСтрока.КтоПривез = КтоПривез;
    НоваяСтрока.ДатаПривоза = ДатаПривоза;
    НоваяСтрока.Количество = Количество;
        
КонецПроцедуры

&НаСервере
Процедура НоваяСтрокаТаблицаОстатков(Номенклатура, Партия, Количество)
    
    НоваяСтрока = Объект.ТаблицаОстатков.Добавить();
    НоваяСтрока.Номенклатура = Номенклатура;
    НоваяСтрока.Партия = Партия;
    НоваяСтрока.Количество = Количество;
        
КонецПроцедуры

&НаСервере
Процедура НоваяСтрокаТаблицаДокумента(Номенклатура, Партия, Количество)
    
    НоваяСтрока = Объект.ТаблицаДокумента.Добавить();
    НоваяСтрока.Номенклатура = Номенклатура;
    НоваяСтрока.Партия = Партия;
    НоваяСтрока.Количество = Количество;
        
КонецПроцедуры

#КонецОбласти
То есть есть одна "таблица прихода" которая заполняется данными приведенными выше, и вторая "таблица Результата" которая заполняется через кнопку "заполнить результат" с колонками Номер, Дата привоза и Кто привез.
Условие задачи по которой выгружается результат во вторую таблицу:
вывести таблицу, в которой указаны в строках день и последний поставщик за этот день и не отображать дни, в которых не было поставки
Вроде простая задача но не выходит дописать или переделать этот код.
   Amra
 
1 - 05.09.20 - 15:28
Анна, пол: мужской, стаж 8 лет и такой вопрос. Даже прям не знаю что сказать
   МихаилМ
 
2 - 05.09.20 - 15:30
+(1) и как чел 8лет помнил пароль ...
   acht
 
3 - 05.09.20 - 15:31
(1) Он себя так идентифицирует, это сейчас модно.

Поиск по фразе "вывести таблицу, в которой указаны в строках день и последний поставщик за этот день и не отображать дни, в которых не было поставки" говорит о том, что эта задача решается уже не первый раз. И, кстати, дает ссылки даже на этот форум.
   Anna Margo
 
4 - 05.09.20 - 15:31
(2) Учетная запись на форуме тут не причем. Есть ответы по существу?
   Anna Margo
 
5 - 05.09.20 - 15:32
(3) не работает этот запрос
   acht
 
6 - 05.09.20 - 15:34
(4) Да нет, конечно, это же форум об аниме. Странно, что ты не в курсе.
   Волшебник
 
7 - 05.09.20 - 15:35
Все тестовые задания адресованы лично Вам, чтобы проверить именно Ваш уровень знаний.
   Krendel
 
8 - 05.09.20 - 15:36
иЛЬДОРАДО;-)
   Anna Margo
 
9 - 05.09.20 - 15:36
все ясно опять толпа троллей
   Web00001
 
10 - 05.09.20 - 15:37
(2)Так браузер же помнит.
(3)Если мы исходим из того, что даты уникальны и от двух поставщиков не может придти товар в один день. Надо в первом запросе выбрать все товары и все даты. Сгруппировать товары по дате с функцией максимум.  Это будут даты последних поступлений. Дальше к этому запросу надо левым соединением(первый запрос слева) добавить общую таблицу. Соединить по товару и дате. Из первого запроса получаем дату из второго поставщика. Вроде как то так должно работать.
   Web00001
 
11 - 05.09.20 - 15:39
(9) К примеру не могу написать такой запрос на коленке. Мне нужен конструктор и данные перед глазами. Так и не научился ручкой писать запросы.
   Anna Margo
 
12 - 05.09.20 - 15:41
(11) я извиняюсь за нубский вопрос ... а зачем там тогда таблица остатков и таблица документа?
   Web00001
 
13 - 05.09.20 - 15:44
Зачем таблица остатков я не знаю. В той таблице которая нужна на выходе нет ни слова про остатки. Можно спросить у того кто дал задание. В таблице документа вроде как у тебя и хранятся данные?
   Anna Margo
 
14 - 05.09.20 - 15:45
(13) нет это внешняя обработка с первой таблицей и кнопкой выгрузки во вторую таблицу. И все это на одной форме
   RomanYS
 
15 - 05.09.20 - 15:46
(12) Просто так. Вероятно существуют задания с другими вопросами, а вводные данные одинаковые
   Anna Margo
 
16 - 05.09.20 - 15:48
(15) т.е. мне просто нужно дописать другой процедурой через скд запрос? и как-то зацепить его за кнопку. Это не я такие ТЗ пишу вот честно, можно былоб и проще)
   acht
 
17 - 05.09.20 - 15:51
Светлана Семененко повеяло
   Ёпрст
 
18 - 05.09.20 - 15:51
(12) ну и пиши примитивный запрос к табличной части ПриходТовара с группировкой по Товару и Максимум(ДатаПривоза) Ну а дальше к этой табличке левое соединение к таб части ПриходТовара из которой берешь КтоПривез датуПривоза и товар и условием соединения ДатаПривоза и товар
   Ёпрст
 
19 - 05.09.20 - 15:52
усё, наслаждаешься, кушаешь печенки

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.