Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Обработка подбора.

v7: Обработка подбора.
Я
   anm37
 
04.09.20 - 17:07
Здравствуйте, форумчане!
Подскажите в чем причина, сам дойти не могу.
Есть документ, на форме СписокЗначений, он передается в Подбор Номенклатуры, в ТаблицеПодбора добавлена колонка для выбора из СпискаЗначений.
Код:
СпПараметров = Форма.Параметр;
МенюП = СпПараметров.Получить("Меню");
Если МенюП.ВыбратьЗначение(, "Список поставщиков", ПозВыбора,,1) = 1 Тогда
     МенюП.ПолучитьЗначение(ПозВыбора, Представление);
     ТаблицаПодбора.Контрагент = Представление;     
КонецЕсли;
Данный код работает правильно, выбранное Значение устанавливается, НО при ОбработкеПодбора колонка остается пустой.
Хотя код:
Спр = СоздатьОбъект ("Справочник.Контрагенты");
ГрПоставщики = Спр.НайтиПоНаименованию("Поставщики");
Если Спр.Выбрать(,ГрПоставщики) = 1 Тогда
    ТаблицаПодбора.Контрагент = Спр.ТекущийЭлемент();
КонецЕсли;
при ОбработкеПодбора заполняет эту колонку.
   Sserj
 
1 - 04.09.20 - 17:28
ТаблицаПодбора.Контрагент = Представление
и 
ТаблицаПодбора.Контрагент = Спр.ТекущийЭлемент()

Как бы намекает что в первом случае в Контрагент пытаешься запихать строку, а во втором случае вставляешь ссылку на элемент справочника.
   anm37
 
2 - 04.09.20 - 18:05
Теперь понял, т.к.
Тип колонки - Справочник.Контрагенты .

Спасибо!!!!!!!!!!

Поменял Тип колонки - Строка.
Все вроде бы работает, осталось доработать немного.
   kupec
 
3 - 09.09.20 - 12:00
(0) Ивановский?
   Ёпрст
 
4 - 09.09.20 - 12:07
(2) передавать надо ссылку и устанвыливать ссылку и выкинуть поиск по наименованию к едрени фени
   Василий Алибабаевич
 
5 - 09.09.20 - 12:12
(2) "Поменял Тип колонки - Строка." Все. Пакуйте чемоданы. Звиздетц базе.
   skafandr
 
6 - 09.09.20 - 13:05
(0) Феерично.Вы бы синтаксис почитывали

ВыбКонтрагент=0;
Если МенюП.ВыбратьЗначение(ВыбКонтрагент, "Список поставщиков", ПозВыбора,,1) = 1 Тогда
     ТаблицаПодбора.Контрагент = ВыбКонтрагент;     
КонецЕсли;
   skafandr
 
7 - 09.09.20 - 13:12
(0)
Как сочетается Ваш текст
ГрПоставщики = Спр.НайтиПоНаименованию("Поставщики");
Если Спр.Выбрать(,ГрПоставщики) = 1 Тогда

и синтаксисом вызова

Выбрать(<Подсказка>,<ФормаСписка>)

Назначение:
Вызов диалога для выбора элемента справочника.
Возвращает: 1 - если элемент выбран; 0 - если не выбран.
Параметры:
<Подсказка> - текст заголовка окна диалога ввода;
<ФормаСписка> - строка, содержащая идентификатор формы списка справочника, используемой для выбора
   oslokot
 
8 - 09.09.20 - 13:12
(5) [Звиздетц базе]
нет еще. он пока поменял тип колонки в тз подбора :)
   skafandr
 
9 - 09.09.20 - 13:16
(8) пугает фраза
"Все вроде бы работает, осталось доработать немного"
:)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.