Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Обмен УТ 11,4 - БП 3, перенос счет-фактур полученных на услуги

Обмен УТ 11,4 - БП 3, перенос счет-фактур полученных на услуги
Я
   vladimir80
 
02.09.20 - 12:05
Доброго времени суток!
Использую штатный перенос.
В торговле транспортные расходы вводятся документом Приобретение услуг и прочих активов.
После обмена в бухгалтерии возникает два документа с одинаковым номером - Приобретение услуг и прочих активов и Поступление (акт, накладная), номера идентичны. Второй документ помечен на удаление. И оба являются основанием для счет-фактуры к этому поступлению. Провести СФ конечно же невозможно. Обе конфигурации последних версий.

Вопрос - возможно что-то неверно в функционале настроено, или это типовой косяк и нужно переделывать правила обмена?
   tesei
 
1 - 02.09.20 - 16:01
Первый документ в БП появился при первом переносе, потом в УТ исправили аналитику статьи затрат, в БП выгрузился документ другого вида. Решение: удалить в БП документ ПНУ, выгрузить приобретение заново из УТ в БП.
   vladimir80
 
2 - 02.09.20 - 17:48
(1) Спасибо! Правда одно но - сносил все документы в БП уже несколько раз - не помогает.
   vladimir80
 
3 - 02.09.20 - 17:49
Перенос делаю вручную, полностью все за месяц. Предварительно закрываю месяц в УТ.
   probably
 
4 - 02.09.20 - 19:50
(0) если решишь проблеиу, отпишись, пожалуйста.аналогичная проблема. При чем было всё ок, но после какого-то обновления пошли эти задвоенности.
В БП документ Поступление пустой создается?
   vladimir80
 
5 - 02.09.20 - 23:00
(4) Да, пустой. С привязкой к СФ и контрагенту, ТЧ пустые, типа операции нет (запрашивает при открытии формы).
   vladimir80
 
6 - 11.09.20 - 15:21
Покопался в отладчике, дошел до этой процедуры.
В ТЧ оснований две ссылки - объект не найден и ПоступлениеДопРасходов.
ОбщегоНазначения.СсылкаСуществует возвращает истину.


Процедура УдалитьДокументыОснованияСБитымиСсылками(Объект)
    // Нужно удалить документы-основания с битыми ссылками.

    // Это нужно для того, что бы корректно установить основание в том случае,

    // если исходный документ-основание в сообщении обмена может превращаться в разные объекты ИБ.

    // В этом случае в ТЧ ДокументыОснования добавляются все возможные правила конвертации.

    // Затем при загрузке объекта проигрывается ПОД и правило конвертации выбирается на основании данных объекта.

    // В строках в ДокументыОснования, которые соответствуют правилам, которые не были выбраны в ПОД, будет

    // записана битая ссылка. Эти битые ссылки нужно удалить.

    
    Индекс = Объект.ДокументыОснования.Количество() - 1;
    
    Пока Индекс >= 0 Цикл
        
        ТекущаяСтрока = Объект.ДокументыОснования[Индекс];
        
        Если ЗначениеЗаполнено(ТекущаяСтрока.ДокументОснование)
            И Не ОбщегоНазначения.СсылкаСуществует(ТекущаяСтрока.ДокументОснование) Тогда
            Объект.ДокументыОснования.Удалить(ТекущаяСтрока);
        КонецЕсли;
        
        Индекс = Индекс - 1;
        
    КонецЦикла;
КонецПроцедуры
   vladimir80
 
7 - 11.09.20 - 22:10
(1) Ты оказался абсолютно прав, но пришлось сделать ТиИ с очисткой битых ссылок, после чего все заработало.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.