Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Обнуление в табличной части числовых значений некоторых строк

Обнуление в табличной части числовых значений некоторых строк
Я
   Svetlana_Kazan
 
01.09.20 - 17:24
Как в табличной части документа обнулить числовые значения в колонках у некоторых строк(отбор по значению в одной из колонок)?
   palpetrovich
 
1 - 01.09.20 - 17:34
для каждого 
если тогда  обнулить 
не катит?
   lubitelxml
 
2 - 01.09.20 - 17:34
НайтиСтроки(Отбор), дальше перебором
   dka80
 
3 - 01.09.20 - 17:35
В лоб:
Для Каждого Строка Из Тч
Если Строка.ИмяКолонки = ТребуемоеЗначение Тогда Строка.Количество = 0 КонецЕсли;
КонецЦикла;
   Svetlana_Kazan
 
4 - 01.09.20 - 17:37
у меня 37 колонок, значения которых надо обнулить.
   eTmy
 
5 - 01.09.20 - 17:39
Ну создайте набор фиксированный и проверяйте входит ли в него ваше поле
   acht
 
6 - 01.09.20 - 17:39
(4) НайтиСтроки, по результату в цикле ЗаполнитьЗначениеСтрок из пустой структуры
   mikecool
 
7 - 01.09.20 - 17:44
(4) еще можно вручную...
   dka80
 
8 - 01.09.20 - 17:46
Для Каждого Строка Из Тч
Для Каждого Колонка Из ТЧ.Колонки Цикл
Если ТипЗнч(Колонка) = Тип(Число) Тогда
Строка[Колонка.Имя] = 0;
КонецЕсли;
КонецЦикла;
КонецЦикла;

Как-то так плюс/минус
   acht
 
9 - 01.09.20 - 17:46
(7) Через диалог с пользователем =)
- Введите 0 в колонку 35 строки 17.
- Введите 0 в колонку 36 строки 17.
- Введите 0 в колонку 37 строки 17.
- Вы ввели единицу, необходимо ввести 0. А то нашему программисту слишком трудно.
   Svetlana_Kazan
 
10 - 01.09.20 - 17:58
(8) , я вот так и сделала в итоге, но подумала, что может есть более оптимальный вариант.
   lubitelxml
 
11 - 01.09.20 - 18:08
(10) см (6)
   Svetlana_Kazan
 
12 - 01.09.20 - 18:10
(11) , спасибо!
   acht
 
13 - 01.09.20 - 18:12
В (6) "ЗаполнитьЗначенияСвойств" ессно
   rudnitskij
 
14 - 01.09.20 - 18:48
(10)
ОбщегоНазначенияКлиентСервер.ОбнулитьТридцатьСемьКолонок(ДокументОбъект,ИмяТабличнойЧасти)

Вы думали, мы что-то типа такого подскажем?)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.