Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

1C ERP модификация встроенных отчетов

1C ERP модификация встроенных отчетов
Я
   DenisVich
 
31.08.20 - 15:28
Очень много управленческих отчетов устроены в формате вызова отчетов, в которых самой схемы отчета(запросов СКД) в общих макетах и отчета нет ничего. Если пройтись по коду то тоже ничего не найти. Вопрос, где хранится схема СКД для таких отчетов? Спасибо.
"Процедура СформироватьОтчетВФоне()
    
    Если НЕ ДлительнаяОперация = Неопределено Тогда
        ОтменитьДлительнуюОперацию(ДлительнаяОперация.ИдентификаторЗадания);
    КонецЕсли;
    
    ПараметрыПроцедуры = Новый Структура;
    ПараметрыПроцедуры.Вставить("Распоряжение", Распоряжение);
    ПараметрыПроцедуры.Вставить("РежимОтображения", РежимОтображения);
    ПараметрыПроцедуры.Вставить("СтатусГрафика", СтатусГрафика);
    
    ПараметрыВыполнения = ДлительныеОперации.ПараметрыВыполненияВФоне(УникальныйИдентификатор);
    ПараметрыВыполнения.НаименованиеФоновогоЗадания = НСтр("ru = 'Формирование отчета ""Диаграмма графика производства заказа""';
                                                            |en = 'Generate the ""Order production schedule chart"" report'");
    
    ДлительнаяОперация = ДлительныеОперации.ВыполнитьВФоне(
        "Отчеты.ДиаграммаПроизводстваЗаказа.СформироватьОтчет",
        ПараметрыПроцедуры,
        ПараметрыВыполнения);
    
    Если ДлительнаяОперация.Статус = "Выполняется" Тогда
        
        НачатьОжиданиеДлительнойОперации = Истина;
        
    Иначе
        
        ОбработатьРезультатФормированияОтчетаВФоне(ЭтотОбъект, ДлительнаяОперация);
        
        НачатьОжиданиеДлительнойОперации = Ложь;
        ДлительнаяОперация = Неопределено;
        
    КонецЕсли;
    
КонецПроцедуры
"
   Ботаник Гарден Меран
 
1 - 31.08.20 - 15:58
И чо? Не бывает отчетов без схемы СКД?
   Вафель
 
2 - 31.08.20 - 16:02
в модуле отчета
   Александр111
 
3 - 31.08.20 - 16:03
Смотри в Отчеты.ДиаграммаПроизводстваЗаказа.СформироватьОтчет
   kzot
 
4 - 31.08.20 - 16:06
(0) из отчета "Диаграмма графика производства заказа" Процедура СформироватьОтчет(Параметры, АдресХранилища) Экспорт
АдресХранилища - Строка - адрес хранилища, в которое будет помещен результат формирования отчета.

если что и есть, через параметрах отправят.
   kzot
 
5 - 31.08.20 - 16:14
(4)+ нет там в параметрах ничего, просто структура.
   Ботаник Гарден Меран
 
6 - 31.08.20 - 16:20
Ну нет в этом отчете скд. Есть диаграмма на форме отчета, параметры, текст запроса и заполнение диаграммы.
   kzot
 
7 - 31.08.20 - 16:24
КомпоновщикНастроек есть )
   shuhard
 
8 - 31.08.20 - 16:50
(0) см ПриКомпоновкеРезультата, там схема и определяется, как правило программно

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.