Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

ОФ: Как программно добавить кнопку на форму ?

ОФ: Как программно добавить кнопку на форму ?
Я
   Trotter
 
30.08.20 - 14:48
Привет!
Делаю так:
Процедура ОсновныеДействияФормыОсновныеДействияФормыВыполнить(Кнопка)

Элемент = ЭтаФорма.ЭлементыФормы.Добавить(Тип("Кнопка"), "Кнопка", Истина);
Элемент.Заголовок = "Выполнить_М";
Элемент.Лево = 80;
Элемент.Верх = 100;
Элемент.Ширина = 100;
Элемент.Высота = 20;    
//Действие = Новый Действие("КнопкаВыполнитьНажатиеМ");
Элемент.УстановитьДействие("Нажатие", Новый Действие("КнопкаВыполнитьНажатиеМ"));
мФормаДокумента.Открыть();    
КонецПроцедуры

Процедура КнопкаВыполнитьНажатиеМ(Кнопка)
Сообщить("Выполнение действия");

КонецПроцедуры

Получаю ошибку:
Элемент.УстановитьДействие("Нажатие", Новый Действие("КнопкаВыполнитьНажатиеМ"));
по причине:
Недопустимое значение параметра (параметр номер '2') (В модуле формы отсутствует процедура с указанным именем)

Подскажите пожалуйста как правильно ?
   ДенисЧ
 
1 - 30.08.20 - 14:52
Экспорт забыл
   Trotter
 
2 - 30.08.20 - 14:59
(1) сделал так:
Процедура КнопкаВыполнитьНажатиеМ(Кнопка) Экспорт
Сообщить("Выполнение действия");
КонецПроцедуры

Не помогло.
   Галахад
 
3 - 30.08.20 - 15:19
"ЭтаФорма" это действительно этаформа?
   ДенисЧ
 
4 - 30.08.20 - 15:36
Я не понял, а в какую форму ты хочешь кнопку добавить?
   Гений 1С
 
5 - 30.08.20 - 18:21
(0) Эх молодежь, молодешь! http://fixin.com.ru/articles/tip_obn/article.htm

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.