Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Вылетает конфигурация при добавление записей в регистр сведений

Вылетает конфигурация при добавление записей в регистр сведений
Я
   FrostBite101
 
30.08.20 - 08:29
Реализую очень простенький алгоритм и тут такое.

Ошибка.
Неспецифицированная ошибка работы с ресурсом
Ошибка при выполнении запроса POST к ресурсу /e1cib/logForm:
Недостаточно свободной памяти для выполнения операции

Код

&НаКлиенте
Процедура Заполнить(Команда)
    
    ОткрытьФорму("Справочник.ТипыГрафиков.ФормаВыбора",,Элементы.Список,)
        
КонецПроцедуры




&НаСервереБезКонтекста
Процедура ЗаполнитьГрафик(ТипГрафика)
    
    
    
    Набор = РегистрыСведений.ГрафикРаботы.СоздатьНаборЗаписей();
    Набор.Отбор.ТипГрафика.Установить(ТипГрафика);
    Набор.Записать();
    
    НачалоГод = НачалоГода(ТекущаяДата());
    КонецГод = КонецГода(ТекущаяДата());
    
    Пока НачалоГод <> КонецГод Цикл
        Запись = Набор.Добавить();
        Запись.Дата = НачалоГод;
        Запись.ТипГрафика = ТипГрафика;
        
        ДеньНед = ДеньНедели(НачалоГод);
        Если ДеньНед <= 5 Тогда
            Запись.Значение = 8;
        КонецЕсли;
        
        НачалоГод = НачалоГод + 24*3600;
    КонецЦикла;
    
    Набор.Записать();

КонецПроцедуры // ЗаполнитьГрафик()


&НаКлиенте
Процедура СписокОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
    
    Если ЗначениеЗаполнено(ВыбранноеЗначение) Тогда
        ЗаполнитьГрафик(ВыбранноеЗначение);
    КонецЕсли;
        
    
КонецПроцедуры
   Александр_Тверь
 
1 - 30.08.20 - 09:00
(0) а чего хочешь?
   Александр_Тверь
 
2 - 30.08.20 - 09:01
ты хвастаеьшся или плакаешся? Не понятно.
   FrostBite101
 
3 - 30.08.20 - 09:04
(1) мне бы решить эту проблему, журнал я почистил, в пк больше 8 гб оперативной памяти. Ошибка вылетает только в данном алгоритме, хотелось бы разобраться.
   Ненавижу 1С
 
4 - 30.08.20 - 09:17
База серверная или локальная? Временные файлы удалял? Кеш чистил?
   FrostBite101
 
5 - 30.08.20 - 09:41
(4) Локальная, все почистил. Не помогло
   Ёпрст
 
6 - 30.08.20 - 09:41
(0)

     Если ДеньНед <= 5 Тогда
            Запись.Значение = 8;
    Иначе
        Запись.Значение = ...//сюда хоть нужное поставь

        КонецЕсли;
   Ёпрст
 
7 - 30.08.20 - 09:42
И.. хотя бы месяц записывает ?
   FrostBite101
 
8 - 30.08.20 - 09:56
(7) Пока НачалоГод <= КонецГод Цикл
поменял и все заработало... Хотя и с таким условием должно записываться, он именно не мог Набор.Записать();  Никакого бесконечного цикла не показывалось...
   FrostBite101
 
9 - 30.08.20 - 10:01
СписокОбработкаВыбора выполняется 2 раза, после выбора и после записи. Почему после записи? Видимо эти 2 процедуры зациклились.
   1Снеговик
 
10 - 30.08.20 - 16:57
Цикл бесконечный, условие проверь поменяй.
   Ненавижу 1С
 
11 - 30.08.20 - 18:31
КонецГода в твоём цикле никогда не будет равной Начало года смени условие на <=

Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь можно обсудить любую тему при этом оставаясь на форуме для 1Сников, который нужен для работы. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.