Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как заполнить поле рс в форме элемента справочника?

Как заполнить поле  рс  в форме элемента справочника?
Я
   Ybr
 
29.08.20 - 22:34
Всем привет !
Вопрос такой:  в форму элемента справочника добавил  динам список - это форма записи регистра сведений

мне нужно по кнопке создать . заполнять поле открывшейся формы записи рег сведений  Основное средство  

в форме записи регистра сведений  добавил обработчик :

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    ТекОС = Неопределено;
    ЗаполненПараметр = ЭтаФорма.Параметры.ЗначенияЗаполнения.Свойство("ОсновноеСредство",ТекОС);
    Если НЕ ЗначениеЗаполнено(Запись.ОсновноеСредство) Тогда
        Если ЗаполненПараметр Тогда
            Запись.ОсновноеСредство = ТекОС;
        Иначе
            ЭтаФорма.ПодчиненныеЭлементы.ОсновноеСредство.Видимость = истина;
        КонецЕсли;    
    КонецЕсли;    
КонецПроцедуры


галка в заполнять из Данных заполнения  стоит .  


Не  заполняет  пустые поля при открытии .
   Gbpltw
 
1 - 29.08.20 - 22:35
Разве записи в РС не через Менеджер делаются?
   Ybr
 
2 - 29.08.20 - 22:38
(1) через менеджер
   Ybr
 
3 - 29.08.20 - 22:57
я тут надумал  при открытии элемента справочника  делать запись в РС  и потом эту запись открывать при создании (по кнопке создать ) - форма записи рс
   vicof
 
4 - 30.08.20 - 05:51
ЭТо делается с помощью события ОбработкаЗаполнения. Не нужно изобретать велосипеды.
   Ybr
 
5 - 30.08.20 - 09:10
(4) примеры ? есть  рабочие
   Ybr
 
6 - 30.08.20 - 10:33
я вот пока не придумал как заполнить форму записи РС  данными  - ссылка элемента справочника  в котором она открывается ( создается)
не записав  элемент в РС .
   Ybr
 
7 - 31.08.20 - 09:51
примеры ? есть  рабочие
   D_E_S_131
 
8 - 31.08.20 - 11:06
Как вариант, сделать свою кнопку создания новой записи.
   RomanYS
 
9 - 31.08.20 - 11:25
(0) Замени ДС на таблицу, а лучше реквизит с типом РегистрСведенийНаборЗаписей...
Записывай РС в обработчике ПослеЗаписиНаСервере, там же заполняй измерение. Ссылка на справочник уже будет
   Ybr
 
10 - 31.08.20 - 11:28
(9) так и делаю в модуле формы справочника при записи  пишу  в регистр  и запись уже есть .когда по кнопке создать открывает форму записи .  но у меня 2 регистра  и это не оптимально

тут Епёрст предложил  без велосипедов  из данных заполнения  обработчиком заполнять . ума не приложу как можно
   Ybr
 
11 - 31.08.20 - 11:29
попутал  vicof предложил . ))
   RomanYS
 
12 - 31.08.20 - 11:38
(10) В чём неоптимальность?
(11) Вероятно он про другое писал. Нет ссылки - нет возможности на нее сослаться. Если бы речь была не про редактирование на форме, а, например, про загрузку там возможно оптимальнее будет УстановитьСсылкуНового. В УФ на клиенте такое не прокатит.
   Ybr
 
13 - 31.08.20 - 11:44
(12) чтоб была ссылка надо ее записать в РС ИмХО
   Ybr
 
14 - 31.08.20 - 11:45
(12) ну ок придется тогда предварительно делать запись в рс .чтобы потом она по отбору была уже в форме ДС
   RomanYS
 
15 - 31.08.20 - 11:51
(13) Чтобы была ссылка нужно записать элемент справочника, а пользователь может передумать записывать.

Если запись справочника гарантированна (например, проверкой перед добавлением записи в РФ), то всё просто и (4) должно работать.

Если мы говорим про редактирование на форме справочника и связанных регистров, то (9) более правильно и удобно чем ДС с отбором
   Ybr
 
16 - 31.08.20 - 11:53
(15) согласен . переделывать на ТЗ не хочется

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.