Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Не заполняется поле в форме записи регистра сведений

Не заполняется поле в форме записи регистра сведений
Я
   Ybr
 
28.08.20 - 13:19
Доброго дня коллеги!

в справочнике Основные средства вывел на форму элемента  динам список - форма записи регистра сведений

по кнопке создать  открывается форма записи  

прописал процедуру  заполнения поля  основное средства  

не заполняет .  хз не пойму где ошибся


&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    ТекОС = Неопределено;
    ЗаполненПараметр = ЭтаФорма.Параметры.ЗначенияЗаполнения.Свойство("ОсновноеСредство",ТекОС);
    Если НЕ ЗначениеЗаполнено(Запись.ОсновноеСредство) Тогда
        Если ЗаполненПараметр Тогда
            Запись.ОсновноеСредство = ТекОС;
        Иначе
            ЭтаФорма.ПодчиненныеЭлементы.ОсновноеСредство.Видимость = истина;
        КонецЕсли;    
    КонецЕсли;    
КонецПроцедуры
   Ybr
 
1 - 28.08.20 - 13:44
ну и что вы молчите  acht ? где ваше офицальное Андрей Николаевич?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.