Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Почему обработчик события документа ОбработкаОповещения вызывается несколько раз?

Почему обработчик события документа ОбработкаОповещения вызывается несколько раз?
Я
   Flutt1
 
28.08.20 - 13:02
Здравствуйте. Обработчик оповещения, после завершения, вызывает почему-то себя еще раз. Абсолютно с теми же параметрами (ИмяСобытия, Параметр, Источник). По стеку вызовов - всё из одного места. Через замер производительности вижу, что ничего между первым вызовом оповещения и повторным - никакой код не отрабатывал. Оборудование не подключено. Подскажите, пожалуйста, что это может быть
   Flutt1
 
1 - 28.08.20 - 13:04
Вызывается изначально оповещение из этого места:
&НаКлиенте
Процедура ПослеЗакрытияФормыРучнойВводШтрихкода (Результат, Параметры) Экспорт
    
    Если ЗначениеЗаполнено(Результат) Тогда
        
        Оповестить("Barcode", Результат, "ПодключаемоеОборудование");
        
    КонецЕсли;

КонецПроцедуры
   acht
 
2 - 28.08.20 - 13:10
Ну, например, был лишний вызов ПодключитьОбработчикОповещения
   Flutt1
 
3 - 28.08.20 - 13:11
(2) Конфигурация самописная, через глобальный поиск не находится ни один вызов ПодключитьОбработчикОповещения
   acht
 
4 - 28.08.20 - 13:15
(3) > самописная
И что написано в обработчике?
   Flutt1
 
5 - 28.08.20 - 13:17
(4)
&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
    
    Если Источник = "ПодключаемоеОборудование"
        И (РежимОтладки = Истина Или (ВводДоступен() И РежимОтладки = Ложь)) Тогда
                
        Если ИмяСобытия = "Barcode" Тогда    
            
            ОбработатьQRКодНаКлиенте(СокрЛП(Параметр));
            
        КонецЕсли;
        
    ИначеЕсли ИмяСобытия = "ДобавитьПартиюПослеМаркировкиВРасфасовку" Тогда
        
        Успешно = ЗаблокироватьОбъектДляРаботыНаСервере(Параметр);
        
        Если Успешно Тогда
        
            ДобавитьКонтейнерВСписокНаСервере(Параметр);
            
        КонецЕсли;
        
    КонецЕсли;
    
КонецПроцедуры
   Flutt1
 
6 - 28.08.20 - 15:16
Был вариант, что открыто несколько форм одного и того же документа - но это не так. При вызове ПолучитьОкна() вижу всего 3 формы: главная форма 1С, форма списка и форма документа. :(
   Kesim
 
7 - 28.08.20 - 16:11
(0) было тоже самое вчера с картридером, но у меня отличались события, то "подключение", то "данные карты + номеркарты", то "нет карты + номеркарты"

Список тем форума
Рекламное место пустует  Рекламное место пустует
Требовать и эффективности, и гибкости от одной и той же программы — все равно, что искать очаровательную и скромную жену... по-видимому, нам следует остановиться на чем-то одном из двух.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.