Вход | Регистрация
 

скд параметр месяц

скд параметр месяц
Я
   Domik26
 
27.08.20 - 17:37
посмотрел тему вроде чисто средствами скд нельзя сделать так чтобы вместо даты выбирать именно месяц, но тема старая, может теперь можно как то?
   Tatitutu
 
1 - 27.08.20 - 17:43
что именно ты хочешь сделать ?
В параметрах посмотри СТАНДАРТНЫЙ ПЕРИОД

НачалоПериода - значение &СтандартныйПериод.ДатаНачала

             ВЫБОР
        КОГДА &ВидПериод = 1
            ТОГДА НАЧАЛОПЕРИОДА(ПродажиОбороты.Период, ДЕНЬ)
        КОГДА &ВидПериод = 2
            ТОГДА НАЧАЛОПЕРИОДА(ПродажиОбороты.Период, НЕДЕЛЯ)
        КОГДА &ВидПериод = 3
            ТОГДА НАЧАЛОПЕРИОДА(ПродажиОбороты.Период, МЕСЯЦ)
        КОГДА &ВидПериод = 4
            ТОГДА НАЧАЛОПЕРИОДА(ПродажиОбороты.Период, ГОД)
        КОГДА &ВидПериод = 5
            ТОГДА НАЧАЛОПЕРИОДА(ПродажиОбороты.Период, КВАРТАЛ)
    КОНЕЦ КАК Период
   Domik26
 
2 - 27.08.20 - 17:48
(1) хочу чтоб в параметре вместо даты пользователи выбирали месяц
   Tatitutu
 
3 - 27.08.20 - 17:49
вот так можно

https://wampi.ru/image/RRA6tpx


или сделай параметр  ВыбМесяц- список значений 1 Январь, 2 февраль....12 декабрь

НачалоПериода (скрытый) Выражение Дата(.додумай.)
   dka80
 
4 - 27.08.20 - 17:55
Январь, Февраль... он хочет. А такого нет. Только форму рисовать и кодом писать
   Андроны едут
 
5 - 27.08.20 - 18:07
   lodger
 
6 - 27.08.20 - 18:08
(4) фе. форму еще рисовать. на

&НаКлиенте
Процедура КакСделатьНемодальныйВыборЗначения(Команда)
 
    Цвета = Новый СписокЗначений;
    Цвета.Добавить("Красный");
    Цвета.Добавить("Зелёный");
    Цвета.Добавить("Синий");
 
    // процедура ПослеВыбораЭлемента определена чуть ниже

    ОповещениеПослеВыбораЭлемента = Новый ОписаниеОповещения(
        "ПослеВыбораЭлемента", ЭтотОбъект
    );
 
    Цвета.ПоказатьВыборЭлемента(
        ОповещениеПослеВыбораЭлемента,
        "Выберите любимый цвет"
    );
 
КонецПроцедуры

&НаКлиенте
Процедура ПослеВыбораЭлемента(Элемент, Параметры) Экспорт
 
    Если Элемент <> Неопределено Тогда
        Сообщить(Элемент.Значение);
    КонецЕсли;
 
КонецПроцедуры
   Мандалай
 
7 - 27.08.20 - 18:38
Стандартный период не?
   Domik26
 
8 - 28.08.20 - 09:47
(7) и как с ним?
   toypaul
 
9 - 28.08.20 - 09:56
чисто средствами СКД можно. смотря как собираешься использовать

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.